diff options
author | Jackie Huang <jackie.huang@windriver.com> | 2017-08-25 16:40:40 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-08-28 11:06:06 +0200 |
commit | c7a28011177cb14a695ed2fd2d4b6ed2b6b404da (patch) | |
tree | b90efb98c59cfb083b47d8b3a16aeaa0372feff8 | |
parent | 5ecae0f0c1b161bff3fe7479178e5ce3517b226d (diff) | |
download | meta-openembedded-c7a28011177cb14a695ed2fd2d4b6ed2b6b404da.tar.gz |
python-html5lib: add Python3 support
Extend the recipe for Python3 support.
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
3 files changed, 18 insertions, 14 deletions
diff --git a/meta-python/recipes-devtools/python/python-html5lib.inc b/meta-python/recipes-devtools/python/python-html5lib.inc new file mode 100644 index 000000000..9c59e0d18 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-html5lib.inc | |||
@@ -0,0 +1,14 @@ | |||
1 | SUMMARY = "HTML parser based on the WHATWG HTML specifcation" | ||
2 | LICENSE = "MIT" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c" | ||
4 | |||
5 | SRC_URI[md5sum] = "8578e4e3a341436cb9743a9e4a299239" | ||
6 | SRC_URI[sha256sum] = "ee747c0ffd3028d2722061936b5c65ee4fe13c8e4613519b4447123fc4546298" | ||
7 | |||
8 | inherit pypi | ||
9 | |||
10 | RDEPENDS_${PN} += "\ | ||
11 | ${PYTHON_PN}-six \ | ||
12 | ${PYTHON_PN}-webencodings \ | ||
13 | ${PYTHON_PN}-xml \ | ||
14 | " | ||
diff --git a/meta-python/recipes-devtools/python/python-html5lib_0.999999999.bb b/meta-python/recipes-devtools/python/python-html5lib_0.999999999.bb index d0f7b56ee..f5941a2a1 100644 --- a/meta-python/recipes-devtools/python/python-html5lib_0.999999999.bb +++ b/meta-python/recipes-devtools/python/python-html5lib_0.999999999.bb | |||
@@ -1,14 +1,2 @@ | |||
1 | SUMMARY = "HTML parser based on the WHATWG HTML specifcation" | 1 | inherit setuptools |
2 | LICENSE = "MIT" | 2 | require python-html5lib.inc |
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1ba5ada9e6fead1fdc32f43c9f10ba7c" | ||
4 | |||
5 | SRC_URI[md5sum] = "8578e4e3a341436cb9743a9e4a299239" | ||
6 | SRC_URI[sha256sum] = "ee747c0ffd3028d2722061936b5c65ee4fe13c8e4613519b4447123fc4546298" | ||
7 | |||
8 | inherit pypi setuptools | ||
9 | |||
10 | RDEPENDS_${PN} += "\ | ||
11 | ${PYTHON_PN}-six \ | ||
12 | ${PYTHON_PN}-webencodings \ | ||
13 | ${PYTHON_PN}-xml \ | ||
14 | " | ||
diff --git a/meta-python/recipes-devtools/python/python3-html5lib_0.999999999.bb b/meta-python/recipes-devtools/python/python3-html5lib_0.999999999.bb new file mode 100644 index 000000000..6bd8b49f5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-html5lib_0.999999999.bb | |||
@@ -0,0 +1,2 @@ | |||
1 | inherit setuptools3 | ||
2 | require python-html5lib.inc | ||