summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMihaela Sendrea <mihaela.sendrea@enea.com>2014-05-13 18:14:19 +0200
committerJoe MacDonald <joe@deserted.net>2014-06-03 21:18:51 -0400
commitab6a7ff9b35689013b0cd76be0c3d8455c205856 (patch)
tree911c58eab3f39973f9f3db6e0137c9882f2349e3
parentc4ba56ceebdd0d42f90e2ec509440f105645c376 (diff)
downloadmeta-openembedded-ab6a7ff9b35689013b0cd76be0c3d8455c205856.tar.gz
lksctp-tools: add recipe (version 1.0.16)
This recipe comes from arago-oe-dev: https://github.com/mrchapp/arago-oe-dev/tree/master/recipes/lksctp-tools Signed-off-by: Mihaela Sendrea <mihaela.sendrea@enea.com> Signed-off-by: Joe MacDonald <joe@deserted.net>
-rw-r--r--meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
new file mode 100644
index 000000000..102c2bb2e
--- /dev/null
+++ b/meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.16.bb
@@ -0,0 +1,43 @@
1SUMMARY = "The Linux Kernel Stream Control Transmission Protocol (lksctp) project"
2SECTION = "libs"
3LICENSE = "LGPLv2"
4
5LIC_FILES_CHKSUM = " \
6 file://COPYING.lib;md5=0a1b79af951c42a9c8573533fbba9a92 \
7 file://COPYING;md5=0c56db0143f4f80c369ee3af7425af6e \
8"
9
10SRC_URI = "${SOURCEFORGE_MIRROR}/lksctp/${BP}.tar.gz"
11
12SRC_URI[md5sum] = "708bb0b5a6806ad6e8d13c55b067518e"
13SRC_URI[sha256sum] = "0903dd526b7f30a89d5031aa2c82757612becc38ed7bc6e4f972f8deae351f26"
14
15S = "${WORKDIR}/${BP}"
16
17BBCLASSEXTEND = "native"
18
19inherit autotools pkgconfig binconfig
20
21SOLIBVERSION="${PV}"
22SOLIBMAJORVERSION="1"
23
24PACKAGES =+ "${PN}-withsctp ${PN}-utils"
25
26FILES_${PN} = " \
27 ${libdir}/libsctp.so.${SOLIBVERSION} \
28"
29
30FILES_${PN}-withsctp = " \
31 ${libdir}/lksctp-tools/libwithsctp.so.${SOLIBVERSION} \
32"
33
34FILES_${PN}-dev += " \
35 ${libdir}/libsctp.so.${SOLIBMAJORVERSION} \
36 ${libdir}/libsctp.so \
37 ${libdir}/lksctp-tools/libwithsctp.so.${SOLIBMAJORVERSION} \
38 ${libdir}/lksctp-tools/libwithsctp.so \
39 ${datadir}/lksctp-tools/*.c \
40 ${datadir}/lksctp-tools/*.h \
41"
42
43FILES_${PN}-utils = "${bindir}/*"