diff options
author | Ioan-Adrian Ratiu <adrian.ratiu@ni.com> | 2016-03-21 12:58:37 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-03-25 11:27:29 +0100 |
commit | 92c5f5594e32ad9f8f63b00493a0ba1211a930c8 (patch) | |
tree | fd6e1b62d57c4c6fd280b9b86f7aae41c85d67f6 | |
parent | 9b7f8e35e1f0708cae4c3d8e62689f6255d03a2d (diff) | |
download | meta-openembedded-92c5f5594e32ad9f8f63b00493a0ba1211a930c8.tar.gz |
ttf-pt-sans: add recipe
PT Sans is an open source licensed font released in 2010 by ParaType.
The ParaTypeFFL-1.3 license file has been submitted to OE-core.
Signed-off-by: Ioan-Adrian Ratiu <adrian.ratiu@ni.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/conf/layer.conf | 1 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/ttf-fonts/ttf-pt-sans_1.1.bb | 39 |
2 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/conf/layer.conf b/meta-oe/conf/layer.conf index 723796459..87f11f028 100644 --- a/meta-oe/conf/layer.conf +++ b/meta-oe/conf/layer.conf | |||
@@ -58,6 +58,7 @@ SIGGEN_EXCLUDE_SAFE_RECIPE_DEPS += " \ | |||
58 | ttf-hunkyfonts->fontconfig \ | 58 | ttf-hunkyfonts->fontconfig \ |
59 | ttf-inconsolata->fontconfig \ | 59 | ttf-inconsolata->fontconfig \ |
60 | ttf-liberation->fontconfig \ | 60 | ttf-liberation->fontconfig \ |
61 | ttf-pt-sans->fontconfig \ | ||
61 | ttf-mplus->fontconfig \ | 62 | ttf-mplus->fontconfig \ |
62 | ttf-sazanami->fontconfig \ | 63 | ttf-sazanami->fontconfig \ |
63 | ttf-tlwg->fontconfig \ | 64 | ttf-tlwg->fontconfig \ |
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-pt-sans_1.1.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-pt-sans_1.1.bb new file mode 100644 index 000000000..ac60a365f --- /dev/null +++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-pt-sans_1.1.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | SUMMARY = "PT Sans Fonts" | ||
2 | DESCRIPTION = "The PT Sans TTF font set" | ||
3 | HOMEPAGE = "http://www.paratype.com/public/" | ||
4 | |||
5 | SECTION = "x11/fonts" | ||
6 | |||
7 | LICENSE = "ParaTypeFFL-1.3" | ||
8 | LIC_FILES_CHKSUM = "file://../PT%20Free%20Font%20License_eng.txt;md5=d720f3a281ed81c3f4cfc465e11b1d0d" | ||
9 | |||
10 | inherit allarch fontcache | ||
11 | |||
12 | # Downloading from fedora because upstream doesn't version its zip file | ||
13 | # and causes hash build failures | ||
14 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/paratype-pt-sans-fonts/PTSans.zip/c3f5a0e20a75cf628387510a720924a7/PTSans.zip" | ||
15 | |||
16 | SRC_URI[md5sum] = "c3f5a0e20a75cf628387510a720924a7" | ||
17 | SRC_URI[sha256sum] = "0164f824e03c32c99e8a225853ec168893a04a09ade132e93a674e85ae033b2e" | ||
18 | |||
19 | do_install () { | ||
20 | install -d ${D}${datadir}/fonts/X11/TTF/ | ||
21 | cd .. | ||
22 | for i in *.ttf; do | ||
23 | install -m 0644 $i ${D}${prefix}/share/fonts/X11/TTF/${i} | ||
24 | done | ||
25 | } | ||
26 | |||
27 | FILES_${PN} += "${datadir}" | ||
28 | |||
29 | pkg_postinst_${PN} () { | ||
30 | set -x | ||
31 | for fontdir in `find $D/usr/lib/X11/fonts -type d`; do | ||
32 | mkfontdir $fontdir | ||
33 | mkfontscale $fontdir | ||
34 | done | ||
35 | for fontdir in `find $D/usr/share/fonts/X11 -type d`; do | ||
36 | mkfontdir $fontdir | ||
37 | mkfontscale $fontdir | ||
38 | done | ||
39 | } | ||