diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-04 18:27:34 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2012-12-11 01:52:57 +0100 |
commit | 7199752c68171a21a888b39d4a7862085b4f0253 (patch) | |
tree | 72da635de0198814d73e2a394dd28360256a7d6e | |
parent | c08c78bb97854e326248dfea913f801452471cb6 (diff) | |
download | meta-openembedded-7199752c68171a21a888b39d4a7862085b4f0253.tar.gz |
python-efl: fix do_configure_prepend to be reentrant
* without '=' it added ${STAGING_DIR_HOST} prefix again when
do_configure was executed twice in the same WORKDIR
causing issues when looking for header files in python-edje,
python-ecore, python-elementary and python-emotion
./python-edje/configure.ac:CYTHON_EDJE_INCLUDEDIR=`$PKG_CONFIG --variable=includedir "python-evas >= ${python_evas_version}"`
./python-ecore/configure.ac:CYTHON_ECORE_EVAS_INCLUDEDIR=""
./python-ecore/configure.ac:CYTHON_ECORE_EVAS_INCLUDEDIR=`$PKG_CONFIG --variable=includedir "python-evas >= ${python_evas_version}"`
./python-elementary/configure.ac:CYTHON_ELEMENTARY_INCLUDEDIR=`$PKG_CONFIG --variable=includedir "python-evas >= ${python_evas_version}"`
./python-emotion/configure.ac:CYTHON_EMOTION_INCLUDEDIR=`$PKG_CONFIG --variable=includedir "python-evas >= ${python_evas_version}"`
* config.log diffs confirms duplicated ${STAGING_DIR_HOST} prefix
< CYTHON_ECORE_EVAS_INCLUDEDIR='/OE/jansa-test/shr-core/tmp-eglibc/sysroots/tuna/usr/include/python-evas'
---
> CYTHON_ECORE_EVAS_INCLUDEDIR='/OE/jansa-test/shr-core/tmp-eglibc/sysroots/tuna/OE/jansa-test/shr-core/tmp-eglibc/sysroots/tuna/usr/include/python-evas'
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-efl/recipes-devtools/python/python-efl.inc | 4 |
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-efl/recipes-devtools/python/python-efl.inc b/meta-efl/recipes-devtools/python/python-efl.inc index 77d4114ca..2bcc43495 100644 --- a/meta-efl/recipes-devtools/python/python-efl.inc +++ b/meta-efl/recipes-devtools/python/python-efl.inc | |||
@@ -6,7 +6,7 @@ AUTHOR = "Gustavo Sverzut Barbieri <barbieri@gmail.com>" | |||
6 | # the extension modules. | 6 | # the extension modules. |
7 | DEPENDS = "python-cython-native python-pyrex-native python-numeric eina" | 7 | DEPENDS = "python-cython-native python-pyrex-native python-numeric eina" |
8 | RDEPENDS_${PN} += "python-lang" | 8 | RDEPENDS_${PN} += "python-lang" |
9 | INC_PR = "r0" | 9 | INC_PR = "r1" |
10 | 10 | ||
11 | # necessary to let the call for python-config succeed | 11 | # necessary to let the call for python-config succeed |
12 | export BUILD_SYS | 12 | export BUILD_SYS |
@@ -24,7 +24,7 @@ S = "${WORKDIR}/${SRCNAME}-${SRCVER}" | |||
24 | 24 | ||
25 | do_configure_prepend() { | 25 | do_configure_prepend() { |
26 | # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly | 26 | # prefix CYTHON_.*_INCLUDEDIR with path to STAGING_DIR_HOST also use $PKG_CONFIG instead of pkg-config directly |
27 | sed -i "s#\`\$PKG_CONFIG --variable=includedir \"python-evas#${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac | 27 | sed -i "s#=\`\$PKG_CONFIG --variable=includedir \"python-evas#=${STAGING_DIR_HOST}\`\$PKG_CONFIG --variable=includedir \"python-evas#g" ${S}/configure.ac |
28 | } | 28 | } |
29 | 29 | ||
30 | do_install_append() { | 30 | do_install_append() { |