diff options
author | Khem Raj <raj.khem@gmail.com> | 2013-01-05 19:50:14 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2013-01-08 09:31:51 -0800 |
commit | 575aa39aa80ec1180c44666fc58841784245620f (patch) | |
tree | 45af85cd26d0353f52e66af96ceafdf5623b680e | |
parent | 13d5ab6cf18dfe03a6164ceb4bd580fe19556e8a (diff) | |
download | meta-openembedded-575aa39aa80ec1180c44666fc58841784245620f.tar.gz |
tcsh: Add recipes for package
Signed-off-by: Khem Raj <raj.khem@gmail.com>
14 files changed, 299 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/tcsh/files/01_build.1.patch b/meta-oe/recipes-extended/tcsh/files/01_build.1.patch new file mode 100644 index 000000000..b9f41ade9 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/01_build.1.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | Author: Franz Pletz <fpletz@franz-pletz.org> | ||
2 | Description: Original comment: Fix build | ||
3 | Not sure why we have this patch. Let's keep it for compatibility. | ||
4 | --- a/pathnames.h | ||
5 | +++ b/pathnames.h | ||
6 | @@ -92,6 +92,10 @@ | ||
7 | # define _PATH_TCSHELL "/local/bin/tcsh" /* use ram disk */ | ||
8 | #endif /* _MINIX && !_PATH_TCSHELL */ | ||
9 | |||
10 | +#ifndef _PATH_TCSHELL | ||
11 | +# define _PATH_TCSHELL "/bin/tcsh" /* Debian */ | ||
12 | +#endif /* !_PATH_TCSHELL */ | ||
13 | + | ||
14 | #if defined(__EMX__) && !defined(_PATH_DEVNULL) | ||
15 | # define _PATH_DEVNULL "nul" | ||
16 | #endif /* __EMX__ && !_PATH_DEVNULL */ | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/01_build.2.patch b/meta-oe/recipes-extended/tcsh/files/01_build.2.patch new file mode 100644 index 000000000..ff2753154 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/01_build.2.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Author: Franz Pletz <fpletz@franz-pletz.org> | ||
2 | Description: Update manpage. | ||
3 | --- a/tcsh.man | ||
4 | +++ b/tcsh.man | ||
5 | @@ -578,7 +578,7 @@ Repeating \fIdabbrev-expand\fR without a | ||
6 | changes to the next previous word etc., skipping identical matches | ||
7 | much like \fIhistory-search-backward\fR does. | ||
8 | .TP 8 | ||
9 | -.B delete-char \fR(not bound) | ||
10 | +.B delete-char \fR(bound to `Del' if using the standard \fI/etc/csh.cshrc\fR) | ||
11 | Deletes the character under the cursor. | ||
12 | See also \fIdelete-char-or-list-or-eof\fR. | ||
13 | .TP 8 | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/01_build.3.patch b/meta-oe/recipes-extended/tcsh/files/01_build.3.patch new file mode 100644 index 000000000..d36c177af --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/01_build.3.patch | |||
@@ -0,0 +1,13 @@ | |||
1 | Author: Franz Pletz <fpletz@franz-pletz.org> | ||
2 | Description: Enable NODOT | ||
3 | --- a/config_f.h | ||
4 | +++ b/config_f.h | ||
5 | @@ -98,7 +98,7 @@ | ||
6 | /* | ||
7 | * NODOT Don't put "." in the default path, for security reasons | ||
8 | */ | ||
9 | -#undef NODOT | ||
10 | +#define NODOT | ||
11 | |||
12 | /* | ||
13 | * AUTOLOGOUT tries to determine if it should set autologout depending | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/07_nls.patch b/meta-oe/recipes-extended/tcsh/files/07_nls.patch new file mode 100644 index 000000000..fe7845f43 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/07_nls.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | Author: Franz Pletz <fpletz@franz-pletz.org> | ||
2 | Description: Fixes NLS build bug | ||
3 | |||
4 | --- a/nls/Makefile.in | ||
5 | +++ b/nls/Makefile.in | ||
6 | @@ -2,7 +2,7 @@ | ||
7 | |||
8 | LOCALES= C et finnish french german greek italian ja pl russian \ | ||
9 | spanish ukrainian | ||
10 | -GENCAT= gencat | ||
11 | +GENCAT= gencat --new | ||
12 | INSTALL= ginstall | ||
13 | |||
14 | datarootdir=@datarootdir@ | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/12_unknown_lscolors.patch b/meta-oe/recipes-extended/tcsh/files/12_unknown_lscolors.patch new file mode 100644 index 000000000..faa59cc80 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/12_unknown_lscolors.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | Author: Franz Pletz <fpletz@franz-pletz.org> | ||
2 | Description: Don't die on unknown LS_COLORS values | ||
3 | Removing the patch causes a segfault when dircolors is set by coreutils' dircolors. | ||
4 | Debian-Bug: #592089 | ||
5 | |||
6 | --- a/tw.color.c | ||
7 | +++ b/tw.color.c | ||
8 | @@ -239,13 +239,10 @@ parseLS_COLORS(const Char *value) | ||
9 | if ((Char)variables[i].variable[0] == (v[0] & CHAR) && | ||
10 | (Char)variables[i].variable[1] == (v[1] & CHAR)) | ||
11 | break; | ||
12 | - if (i < nvariables) { | ||
13 | - v += 3; | ||
14 | + v += 3; | ||
15 | + if (i < nvariables) | ||
16 | getstring(&c, &v, &variables[i].color, ':'); | ||
17 | - continue; | ||
18 | - } | ||
19 | - else | ||
20 | - stderror(ERR_BADCOLORVAR, v[0], v[1]); | ||
21 | + continue; | ||
22 | } | ||
23 | break; | ||
24 | } | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/15_no-strip.patch b/meta-oe/recipes-extended/tcsh/files/15_no-strip.patch new file mode 100644 index 000000000..cbc9f65d0 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/15_no-strip.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | Author: Lucas Nussbaum <lucas@debian.org> | ||
2 | Description: do not strip binary | ||
3 | Stripping should be handled by dh_strip instead, so DEB_BUILD_OPTIONS=nostrip works. | ||
4 | Closes: #438109, #411607 | ||
5 | --- a/Makefile.in | ||
6 | +++ b/Makefile.in | ||
7 | @@ -596,7 +596,6 @@ install: tcsh$(EXEEXT) | ||
8 | -mkdir -p ${DESTBIN} | ||
9 | -mv -f ${DESTBIN}/tcsh$(EXEEXT) ${DESTBIN}/tcsh.old | ||
10 | cp tcsh$(EXEEXT) ${DESTBIN}/tcsh$(EXEEXT) | ||
11 | - -strip ${DESTBIN}/tcsh$(EXEEXT) | ||
12 | chmod 755 ${DESTBIN}/tcsh$(EXEEXT) | ||
13 | |||
14 | install.man: tcsh.man | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/cross-compile.patch b/meta-oe/recipes-extended/tcsh/files/cross-compile.patch new file mode 100644 index 000000000..06dcfdae0 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/cross-compile.patch | |||
@@ -0,0 +1,12 @@ | |||
1 | diff -git a/Makefile.in b/Makefile.in | ||
2 | --- a/Makefile.in | ||
3 | +++ b/Makefile.in | ||
4 | @@ -446,7 +446,7 @@ | ||
5 | |||
6 | gethost: gethost.c sh.err.h tc.const.h sh.h | ||
7 | rm -f gethost | ||
8 | - ${CC} -o gethost ${LDFLAGS} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS} | ||
9 | + ${BUILD_CC} -o gethost ${BUILD_LDFLAGS} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${DFLAGS} $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS} | ||
10 | |||
11 | tc.defs.c: gethost host.defs | ||
12 | @rm -f $@.tmp | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-broken-test.patch b/meta-oe/recipes-extended/tcsh/files/disable-broken-test.patch new file mode 100644 index 000000000..0bda0ba10 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/disable-broken-test.patch | |||
@@ -0,0 +1,14 @@ | |||
1 | Author: Lucas Nussbaum <lucas@debian.org> | ||
2 | Description: disable syntactically incorrect test | ||
3 | --- a/tests/lexical.at | ||
4 | +++ b/tests/lexical.at | ||
5 | @@ -172,9 +172,6 @@ | ||
6 | AT_DATA([nohist.csh], | ||
7 | [echo ! space ! tab != "!(" newline ! | ||
8 | ]) | ||
9 | -AT_CHECK([tcsh -f nohist.csh], , | ||
10 | -[[! space ! tab != !( newline ! | ||
11 | -]]) | ||
12 | |||
13 | AT_CLEANUP | ||
14 | |||
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-lexical.at-31.patch b/meta-oe/recipes-extended/tcsh/files/disable-lexical.at-31.patch new file mode 100644 index 000000000..98a9b2e1d --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/disable-lexical.at-31.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | --- a/tests/lexical.at | ||
2 | +++ b/tests/lexical.at | ||
3 | @@ -27,27 +27,6 @@ AT_CHECK([tcsh -f oneword.csh], , | ||
4 | |||
5 | AT_CLEANUP | ||
6 | |||
7 | - | ||
8 | -AT_SETUP([Comments]) | ||
9 | - | ||
10 | -AT_CHECK([echo 'echo OK@%:@comment' | tcsh -f], , [OK | ||
11 | -]) | ||
12 | - | ||
13 | -AT_CHECK([tcsh -f -c 'echo @%:@no comment'], , | ||
14 | -[@%:@no comment | ||
15 | -]) | ||
16 | - | ||
17 | -AT_DATA([comment2.csh], | ||
18 | -[[echo testing...@%:@\ | ||
19 | -OK | ||
20 | -]]) | ||
21 | -AT_CHECK([tcsh -f comment2.csh], , | ||
22 | -[testing... OK | ||
23 | -]) | ||
24 | - | ||
25 | -AT_CLEANUP | ||
26 | - | ||
27 | - | ||
28 | AT_SETUP([Escaping special characters]) | ||
29 | |||
30 | AT_DATA([nosplit.csh], | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-test-nice.patch b/meta-oe/recipes-extended/tcsh/files/disable-test-nice.patch new file mode 100644 index 000000000..79f918c08 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/disable-test-nice.patch | |||
@@ -0,0 +1,23 @@ | |||
1 | Author: Lucas Nussbaum <lucas@debian.org> | ||
2 | Description: disable test that fails on the buildd with | ||
3 | "setpriority: Permission denied". | ||
4 | --- a/tests/commands.at | ||
5 | +++ b/tests/commands.at | ||
6 | @@ -888,17 +888,6 @@ TCSH_UNTESTED([migrate]) | ||
7 | TCSH_UNTESTED([newgrp]) | ||
8 | |||
9 | |||
10 | -AT_SETUP([nice]) | ||
11 | - | ||
12 | -# Nothing really tested | ||
13 | -AT_CHECK([tcsh -f -c 'nice set var=1; echo $?var'], , | ||
14 | -[0 | ||
15 | -]) | ||
16 | - | ||
17 | - | ||
18 | -AT_CLEANUP | ||
19 | - | ||
20 | - | ||
21 | AT_SETUP([nohup]) | ||
22 | |||
23 | AT_DATA([nohup.csh], | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/disable-test-notty.patch b/meta-oe/recipes-extended/tcsh/files/disable-test-notty.patch new file mode 100644 index 000000000..69f0564e8 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/disable-test-notty.patch | |||
@@ -0,0 +1,30 @@ | |||
1 | From: Lucas Nussbaum <lucas@debian.org> | ||
2 | Description: Those tests fail when running the testsuite without a tty. Disabling them. | ||
3 | |||
4 | --- a/tests/commands.at | ||
5 | +++ b/tests/commands.at | ||
6 | @@ -1203,11 +1203,6 @@ AT_SETUP([source]) | ||
7 | AT_DATA([script.csh], | ||
8 | [[set var=$1 | ||
9 | ]]) | ||
10 | -AT_CHECK([[tcsh -f -c 'source -h script.csh foo; history' \ | ||
11 | - | sed 's/ [^ ]* / TIME /']], , | ||
12 | -[ 1 TIME source -h script.csh foo ; history | ||
13 | - 2 TIME set var=$1 | ||
14 | -]) | ||
15 | |||
16 | AT_CHECK([tcsh -f -c 'source -h script.csh foo; echo $var'], 1, [], | ||
17 | [var: Undefined variable. | ||
18 | --- a/tests/variables.at | ||
19 | +++ b/tests/variables.at | ||
20 | @@ -319,10 +319,6 @@ AT_CLEANUP | ||
21 | |||
22 | AT_SETUP([$ edit]) | ||
23 | |||
24 | -AT_CHECK([TERM=something tcsh -f -c 'echo $?edit'], , | ||
25 | -[1 | ||
26 | -]) | ||
27 | - | ||
28 | AT_CHECK([TERM=dumb tcsh -f -c 'echo $?edit'], , | ||
29 | [0 | ||
30 | ]) | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch b/meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch new file mode 100644 index 000000000..43001f117 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch | |||
@@ -0,0 +1,27 @@ | |||
1 | Author: christos <christos> | ||
2 | Date: Thu May 13 18:39:02 2010 +0000 | ||
3 | |||
4 | add a rule to make catalogs and propagate ${MAKE} instead of hard-coding make. | ||
5 | |||
6 | --- a/Makefile.in | ||
7 | +++ b/Makefile.in | ||
8 | @@ -687,7 +687,7 @@ shar: | ||
9 | rm -rf tcsh-${VERSION} | ||
10 | |||
11 | catalogs: | ||
12 | - @(cd nls; make catalogs) | ||
13 | + @(cd nls; ${MAKE}) | ||
14 | |||
15 | tcsh-${VERSION}.tar.Z: | ||
16 | rm -rf tcsh-${VERSION} | ||
17 | --- a/nls/Makefile.in | ||
18 | +++ b/nls/Makefile.in | ||
19 | @@ -18,7 +18,7 @@ install: $(INSTALLED) | ||
20 | $(INSTALL) $< $@ | ||
21 | |||
22 | %.cat: | ||
23 | - $(GENCAT) $@ $(@:%.cat=%)/*set* | ||
24 | + cat $(@:%.cat=%)/charset $(@:%.cat=%)/set* | $(GENCAT) $@ | ||
25 | |||
26 | clean: | ||
27 | $(RM) $(CATALOGS) | ||
diff --git a/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch b/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch new file mode 100644 index 000000000..7f3e92624 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch | |||
@@ -0,0 +1,16 @@ | |||
1 | Author: Jean-Luc Leger <reiga@dspnet.fr.eu.org> | ||
2 | Description: fix broken globbing expansion | ||
3 | Debian-Bug: #603545 | ||
4 | --- a/tc.str.c | ||
5 | +++ b/tc.str.c | ||
6 | @@ -104,8 +104,9 @@ rt_mbtowc(Char *pwc, const char *s, size_t n) | ||
7 | |||
8 | memset (&mb, 0, sizeof mb); | ||
9 | ret = mbrtowc(&tmp, s, n, &mb); | ||
10 | - if (ret > 0) { | ||
11 | + if (ret >= 0) | ||
12 | *pwc = tmp; | ||
13 | + if (ret > 0) { | ||
14 | #ifdef UTF16_STRINGS | ||
15 | if (tmp >= 0xd800 && tmp <= 0xdbff) { | ||
16 | /* UTF-16 surrogate pair. Fetch second half and compute | ||
diff --git a/meta-oe/recipes-extended/tcsh/tcsh_6.17.02.bb b/meta-oe/recipes-extended/tcsh/tcsh_6.17.02.bb new file mode 100644 index 000000000..c4c78f478 --- /dev/null +++ b/meta-oe/recipes-extended/tcsh/tcsh_6.17.02.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | DESCRIPTION = "TENEX C Shell, an enhanced version of Berkeley csh \ | ||
2 | The TENEX C Shell is an enhanced version of the Berkeley Unix C shell. \ | ||
3 | It includes all features of 4.4BSD C shell, plus a command-line editor, \ | ||
4 | programmable word completion, spelling correction and more." | ||
5 | |||
6 | HOMEPAGE = "http://www.tcsh.org/" | ||
7 | LICENSE = "BSD" | ||
8 | LIC_FILES_CHKSUM = "file://Copyright;md5=1cf29be62df2be1a3763118b25b4c780" | ||
9 | SECTION = "base" | ||
10 | |||
11 | SRC_URI = " \ | ||
12 | ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_6.17.02.orig.tar.gz;name=tarball \ | ||
13 | ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_6.17.02-4.diff.gz;name=diffs \ | ||
14 | file://01_build.1.patch \ | ||
15 | file://01_build.2.patch \ | ||
16 | file://01_build.3.patch \ | ||
17 | file://07_nls.patch \ | ||
18 | file://15_no-strip.patch \ | ||
19 | file://disable-test-notty.patch \ | ||
20 | file://disable-test-nice.patch \ | ||
21 | file://fix-make-catalogs.patch \ | ||
22 | file://disable-lexical.at-31.patch \ | ||
23 | file://12_unknown_lscolors.patch \ | ||
24 | file://tcsh-6.17.02-multibyte.patch \ | ||
25 | file://disable-broken-test.patch \ | ||
26 | file://cross-compile.patch \ | ||
27 | " | ||
28 | |||
29 | inherit autotools | ||
30 | |||
31 | do_install_append () { | ||
32 | oe_runmake install.man DESTDIR=${D} | ||
33 | |||
34 | install -d ${D}${base_bindir} | ||
35 | ln -s /usr/bin/tcsh ${D}${base_bindir}/tcsh | ||
36 | |||
37 | install -d ${D}${sysconfdir}/csh/login.d | ||
38 | install -m 0644 ${S}/debian/csh.cshrc ${S}/debian/csh.login ${S}/debian/csh.logout ${S}/complete.tcsh ${D}${sysconfdir} | ||
39 | install -D -m 0644 ${S}/csh-mode.el ${D}${datadir}/emacs/site-lisp/csh-mode.el | ||
40 | } | ||
41 | |||
42 | FILES_${PN} += "${datadir}/emacs/site-lisp/csh-mode.el" | ||
43 | |||
44 | |||
45 | pkg_postinst_${PN} () { | ||
46 | #!/bin/sh -e | ||
47 | echo /usr/bin/tcsh >> $D/etc/shells | ||
48 | } | ||
49 | |||
50 | SRC_URI[tarball.md5sum] = "ad6e89ddb654972b4c2a8bad06778625" | ||
51 | SRC_URI[tarball.sha256sum] = "8c675729810eb49102b68e09be4f3f592dfa0be2c238f0d0a58e5c1147da7dd8" | ||
52 | SRC_URI[diffs.md5sum] = "735286c36a83a043015b30871c7ab6b6" | ||
53 | SRC_URI[diffs.sha256sum] = "61c0b0f7ebbc07544551f56b66c6e78def702c2197307e960898182b340ffe67" | ||