diff options
author | Ross Burton <ross.burton@intel.com> | 2012-08-30 10:10:55 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-10-24 19:34:31 +0200 |
commit | 55855cd569fbff7182974ca08b1de8435bf0f597 (patch) | |
tree | 9f7518e2e48367fcbd15a7c58101dd601940331f | |
parent | e0fe08a35ae6e1a4458c13daa13167c9a1e74bde (diff) | |
download | meta-openembedded-55855cd569fbff7182974ca08b1de8435bf0f597.tar.gz |
pimlico: remove Poky overrides
There was a poky distro override to enable the "owl" window menu functionality.
As these packages are in meta-oe now and only Sato/poky supported owl, remove
the override and patches.
Signed-off-by: Ross Burton <ross.burton@intel.com>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
9 files changed, 4 insertions, 215 deletions
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts.inc b/meta-gnome/recipes-gnome/pimlico/contacts.inc index 9798985a4..e19727c56 100644 --- a/meta-gnome/recipes-gnome/pimlico/contacts.inc +++ b/meta-gnome/recipes-gnome/pimlico/contacts.inc | |||
@@ -5,15 +5,11 @@ BUGTRACKER = "https://bugzilla.gnome.org/" | |||
5 | LICENSE = "GPLv2 & GPLv2+ & GPLv3+ " | 5 | LICENSE = "GPLv2 & GPLv2+ & GPLv3+ " |
6 | SECTION = "x11" | 6 | SECTION = "x11" |
7 | DEPENDS = "glib-2.0 gtk+ evolution-data-server" | 7 | DEPENDS = "glib-2.0 gtk+ evolution-data-server" |
8 | DEPENDS_append_poky = " libowl" | ||
9 | RDEPENDS_${PN} = "libedata-book" | 8 | RDEPENDS_${PN} = "libedata-book" |
10 | 9 | ||
11 | inherit autotools pkgconfig | 10 | inherit autotools pkgconfig |
12 | 11 | ||
13 | OWL = "--disable-owl" | 12 | EXTRA_OECONF += "--disable-gnome-vfs" |
14 | OWL_poky = "--enable-owl" | ||
15 | |||
16 | EXTRA_OECONF += "--disable-gnome-vfs ${OWL}" | ||
17 | EXTRA_OEMAKE += "GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1" | 13 | EXTRA_OEMAKE += "GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1" |
18 | 14 | ||
19 | do_install_append () { | 15 | do_install_append () { |
@@ -30,5 +26,3 @@ SRC_URI = "file://stock_contact.png \ | |||
30 | file://stock_person.png \ | 26 | file://stock_person.png \ |
31 | file://contacts-conditionally-install-schema.patch \ | 27 | file://contacts-conditionally-install-schema.patch \ |
32 | " | 28 | " |
33 | |||
34 | SRC_URI_append_poky = " file://contacts-owl-window-menu.patch;apply=yes " | ||
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts/contacts-owl-window-menu.patch b/meta-gnome/recipes-gnome/pimlico/contacts/contacts-owl-window-menu.patch deleted file mode 100644 index 532387667..000000000 --- a/meta-gnome/recipes-gnome/pimlico/contacts/contacts-owl-window-menu.patch +++ /dev/null | |||
@@ -1,54 +0,0 @@ | |||
1 | Upstream-Status: Inappropriate [enable feature] | ||
2 | |||
3 | Index: contacts-0.9/src/contacts-gtk.c | ||
4 | =================================================================== | ||
5 | --- contacts-0.9.orig/src/contacts-gtk.c 2008-06-06 12:56:08.000000000 +0100 | ||
6 | +++ contacts-0.9/src/contacts-gtk.c 2008-06-16 08:14:28.000000000 +0100 | ||
7 | @@ -220,8 +220,8 @@ | ||
8 | vbox7 = gtk_vbox_new (FALSE, 0); | ||
9 | gtk_container_add (GTK_CONTAINER (main_window), vbox7); | ||
10 | |||
11 | - main_menubar = gtk_menu_bar_new (); | ||
12 | - gtk_box_pack_start (GTK_BOX (vbox7), main_menubar, FALSE, FALSE, 0); | ||
13 | + main_menubar = gtk_menu_new (); | ||
14 | + gtk_widget_show (main_menubar); | ||
15 | |||
16 | contacts_menu = gtk_menu_item_new_with_mnemonic (_("C_ontacts")); | ||
17 | gtk_container_add (GTK_CONTAINER (main_menubar), contacts_menu); | ||
18 | Index: contacts-0.9/src/Makefile.am | ||
19 | =================================================================== | ||
20 | --- contacts-0.9.orig/src/Makefile.am 2008-06-03 09:16:56.000000000 +0100 | ||
21 | +++ contacts-0.9/src/Makefile.am 2008-06-16 08:15:34.000000000 +0100 | ||
22 | @@ -40,7 +40,7 @@ | ||
23 | contacts-@FRONTEND@.c \ | ||
24 | contacts-@FRONTEND@.h | ||
25 | |||
26 | -contacts_LDADD = $(CONTACTS_LIBS) $(DBUS_LIBS) | ||
27 | +contacts_LDADD = $(CONTACTS_LIBS) $(DBUS_LIBS) -lowl | ||
28 | |||
29 | contacts_LDFLAGS = @CONTACTS_LIBS@ @DBUS_LIBS@ | ||
30 | |||
31 | Index: contacts-0.9/src/contacts-main.c | ||
32 | =================================================================== | ||
33 | --- contacts-0.9.orig/src/contacts-main.c 2008-06-06 10:26:52.000000000 +0100 | ||
34 | +++ contacts-0.9/src/contacts-main.c 2008-06-16 08:14:28.000000000 +0100 | ||
35 | @@ -27,6 +27,8 @@ | ||
36 | #include <libgnomevfs/gnome-vfs.h> | ||
37 | #endif | ||
38 | |||
39 | +#include <libowl/owlwindowmenu.h> | ||
40 | + | ||
41 | #include "bacon-message-connection.h" | ||
42 | #include "contacts-defs.h" | ||
43 | #include "contacts-utils.h" | ||
44 | @@ -266,6 +268,10 @@ | ||
45 | gtk_widget_show_all (widget); | ||
46 | } | ||
47 | |||
48 | + gtk_widget_show_all (data->ui->main_menubar); | ||
49 | + owl_set_window_menu (GTK_WINDOW (data->ui->main_window), | ||
50 | + GTK_MENU (data->ui->main_menubar)); | ||
51 | + | ||
52 | gtk_main (); | ||
53 | |||
54 | /* if we have modified the current contact, but not saved it, do so now */ | ||
diff --git a/meta-gnome/recipes-gnome/pimlico/contacts_0.9.bb b/meta-gnome/recipes-gnome/pimlico/contacts_0.9.bb index 251bbe1d7..da6959b13 100644 --- a/meta-gnome/recipes-gnome/pimlico/contacts_0.9.bb +++ b/meta-gnome/recipes-gnome/pimlico/contacts_0.9.bb | |||
@@ -1,6 +1,6 @@ | |||
1 | require contacts.inc | 1 | require contacts.inc |
2 | 2 | ||
3 | PR = "r7" | 3 | PR = "r8" |
4 | 4 | ||
5 | SRC_URI =+ "http://pimlico-project.org/sources/${BPN}/${BPN}-${PV}.tar.gz" | 5 | SRC_URI =+ "http://pimlico-project.org/sources/${BPN}/${BPN}-${PV}.tar.gz" |
6 | 6 | ||
diff --git a/meta-gnome/recipes-gnome/pimlico/dates.inc b/meta-gnome/recipes-gnome/pimlico/dates.inc index 9b338fd81..9b078e13c 100644 --- a/meta-gnome/recipes-gnome/pimlico/dates.inc +++ b/meta-gnome/recipes-gnome/pimlico/dates.inc | |||
@@ -9,12 +9,3 @@ DEPENDS = "glib-2.0 gtk+ libglade evolution-data-server" | |||
9 | RDEPENDS_${PN} = "libedata-cal" | 9 | RDEPENDS_${PN} = "libedata-cal" |
10 | 10 | ||
11 | inherit autotools gettext pkgconfig gtk-icon-cache | 11 | inherit autotools gettext pkgconfig gtk-icon-cache |
12 | |||
13 | # Poky/Sato specific enhancements | ||
14 | OWL = "--disable-owl" | ||
15 | OWL_poky = "--enable-owl --disable-dnd" | ||
16 | |||
17 | EXTRA_OECONF += "${OWL}" | ||
18 | DEPENDS_append_poky = " libowl" | ||
19 | SRC_URI_append_poky = " file://dates-owl-window-menu.patch;apply=yes " | ||
20 | |||
diff --git a/meta-gnome/recipes-gnome/pimlico/dates/dates-owl-window-menu.patch b/meta-gnome/recipes-gnome/pimlico/dates/dates-owl-window-menu.patch deleted file mode 100644 index 714623efe..000000000 --- a/meta-gnome/recipes-gnome/pimlico/dates/dates-owl-window-menu.patch +++ /dev/null | |||
@@ -1,67 +0,0 @@ | |||
1 | --- | ||
2 | src/dates_gtk.c | 5 ----- | ||
3 | src/dates_main.c | 5 +++++ | ||
4 | src/dates_platform.h | 2 +- | ||
5 | 3 files changed, 7 insertions(+), 7 deletions(-) | ||
6 | |||
7 | Upstream-Status: Inappropriate [enable feature] | ||
8 | |||
9 | Index: git/src/dates_gtk.c | ||
10 | =================================================================== | ||
11 | --- git.orig/src/dates_gtk.c 2009-08-18 12:44:56.000000000 +0100 | ||
12 | +++ git/src/dates_gtk.c 2009-09-03 22:28:50.000000000 +0100 | ||
13 | @@ -33,10 +33,6 @@ | ||
14 | #endif | ||
15 | |||
16 | #ifndef DATES_PLATFORM_create_main_window | ||
17 | -/* the default implementation assumes that menu is GtkMenuBar */ | ||
18 | -#ifdef DATES_MENU_WITHOUT_BAR | ||
19 | -#error Cannot use default create_main_window () if DATES_MENU_WITHOUT_BAR is defined !!! | ||
20 | -#endif | ||
21 | static GtkWidget * | ||
22 | create_main_window (DatesData * d, GtkWidget * toolbar, | ||
23 | GtkWidget * menu, GtkAccelGroup * accel_group) | ||
24 | @@ -59,7 +55,6 @@ | ||
25 | gtk_container_add (GTK_CONTAINER (d->main_window), main_vbox); | ||
26 | |||
27 | gtk_widget_show (menu); | ||
28 | - gtk_box_pack_start (GTK_BOX (main_vbox), menu, FALSE, FALSE, 0); | ||
29 | |||
30 | gtk_box_pack_end (GTK_BOX (main_vbox), toolbar, FALSE, FALSE, 0); | ||
31 | gtk_container_set_border_width (GTK_CONTAINER (toolbar), 3); | ||
32 | Index: git/src/dates_main.c | ||
33 | =================================================================== | ||
34 | --- git.orig/src/dates_main.c 2009-08-18 12:44:56.000000000 +0100 | ||
35 | +++ git/src/dates_main.c 2009-09-03 22:29:21.000000000 +0100 | ||
36 | @@ -26,6 +26,8 @@ | ||
37 | #include <libical/icaltime.h> | ||
38 | #include <gconf/gconf-client.h> | ||
39 | |||
40 | +#include <gtk/gtkmenuitem.h> | ||
41 | +#include <libowl/owlwindowmenu.h> | ||
42 | #include "dates_types.h" | ||
43 | #include "dates_platform.h" | ||
44 | #include "dates_callbacks.h" | ||
45 | @@ -582,6 +584,9 @@ | ||
46 | g_free (url_uri); | ||
47 | } | ||
48 | |||
49 | + owl_set_window_menu (GTK_WINDOW (data.main_window), | ||
50 | + GTK_MENU (data.main_menu)); | ||
51 | + | ||
52 | gtk_main (); | ||
53 | |||
54 | return 0; | ||
55 | Index: git/src/dates_platform.h | ||
56 | =================================================================== | ||
57 | --- git.orig/src/dates_platform.h 2009-08-18 12:44:56.000000000 +0100 | ||
58 | +++ git/src/dates_platform.h 2009-09-03 22:28:50.000000000 +0100 | ||
59 | @@ -20,7 +20,7 @@ | ||
60 | |||
61 | #include "dates_types.h" | ||
62 | |||
63 | -#ifdef WITH_HILDON | ||
64 | +#if 1 | ||
65 | #define DATES_MENU_WITHOUT_BAR 1 | ||
66 | #endif | ||
67 | |||
diff --git a/meta-gnome/recipes-gnome/pimlico/dates_git.bb b/meta-gnome/recipes-gnome/pimlico/dates_git.bb index 9ee010554..cf5343d51 100644 --- a/meta-gnome/recipes-gnome/pimlico/dates_git.bb +++ b/meta-gnome/recipes-gnome/pimlico/dates_git.bb | |||
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ | |||
7 | 7 | ||
8 | SRCREV = "514185dc1f6588085fda41eb59898b93d0487dd4" | 8 | SRCREV = "514185dc1f6588085fda41eb59898b93d0487dd4" |
9 | PV = "0.4.11+git${SRCPV}" | 9 | PV = "0.4.11+git${SRCPV}" |
10 | PR = "r8" | 10 | PR = "r9" |
11 | 11 | ||
12 | S = "${WORKDIR}/git" | 12 | S = "${WORKDIR}/git" |
13 | 13 | ||
diff --git a/meta-gnome/recipes-gnome/pimlico/tasks.inc b/meta-gnome/recipes-gnome/pimlico/tasks.inc index 9cd525987..44f036dd9 100644 --- a/meta-gnome/recipes-gnome/pimlico/tasks.inc +++ b/meta-gnome/recipes-gnome/pimlico/tasks.inc | |||
@@ -6,11 +6,5 @@ LICENSE = "GPLv2 & GPLv2+" | |||
6 | 6 | ||
7 | SECTION = "x11" | 7 | SECTION = "x11" |
8 | DEPENDS = "glib-2.0 gtk+ evolution-data-server" | 8 | DEPENDS = "glib-2.0 gtk+ evolution-data-server" |
9 | DEPENDS_append_poky = " libowl" | ||
10 | 9 | ||
11 | inherit autotools pkgconfig gtk-icon-cache | 10 | inherit autotools pkgconfig gtk-icon-cache |
12 | |||
13 | OWL ?= "--disable-owl" | ||
14 | OWL_poky ?= "--enable-owl" | ||
15 | |||
16 | EXTRA_OECONF += "${OWL}" | ||
diff --git a/meta-gnome/recipes-gnome/pimlico/tasks/tasks-owl.diff b/meta-gnome/recipes-gnome/pimlico/tasks/tasks-owl.diff deleted file mode 100644 index aab23ff28..000000000 --- a/meta-gnome/recipes-gnome/pimlico/tasks/tasks-owl.diff +++ /dev/null | |||
@@ -1,67 +0,0 @@ | |||
1 | This patch enable owl menu, which is hidden in the title bar to save space on | ||
2 | small screen. It has not been used for a long time, rebase needed. | ||
3 | |||
4 | Upstream-Status: Inappropriate [enable feature] | ||
5 | |||
6 | Index: src/gtk/tasks-ui.xml | ||
7 | =================================================================== | ||
8 | --- src/gtk/tasks-ui.xml (revision 338) | ||
9 | +++ src/gtk/tasks-ui.xml (working copy) | ||
10 | @@ -7,17 +7,14 @@ | ||
11 | <menuitem action="EditTask"/> | ||
12 | <menuitem action="CompleteTask"/> | ||
13 | <separator/> | ||
14 | + <menuitem action="Undo"/> | ||
15 | + <menuitem action="Redo"/> | ||
16 | + <separator/> | ||
17 | <menuitem action="DeleteTask"/> | ||
18 | <menuitem action="PurgeTasks"/> | ||
19 | <separator/> | ||
20 | + <menuitem action="About"/> | ||
21 | <menuitem action="Quit"/> | ||
22 | </menu> | ||
23 | - <menu action="EditMenu"> | ||
24 | - <menuitem action="Undo"/> | ||
25 | - <menuitem action="Redo"/> | ||
26 | - </menu> | ||
27 | - <menu action="HelpMenu"> | ||
28 | - <menuitem action="About"/> | ||
29 | - </menu> | ||
30 | </menubar> | ||
31 | </ui> | ||
32 | Index: src/gtk/main.c | ||
33 | =================================================================== | ||
34 | --- src/gtk/main.c (revision 338) | ||
35 | +++ src/gtk/main.c (working copy) | ||
36 | @@ -21,6 +21,7 @@ | ||
37 | #include <libecal/e-cal.h> | ||
38 | #include <glib/gi18n.h> | ||
39 | #include <gtk/gtk.h> | ||
40 | +#include <libowl/owlwindowmenu.h> | ||
41 | |||
42 | #include <libkoto/ical-util.h> | ||
43 | #include <libkoto/koto-actions.h> | ||
44 | @@ -564,8 +565,8 @@ | ||
45 | gtk_window_add_accel_group (GTK_WINDOW (window), gtk_ui_manager_get_accel_group (ui_manager)); | ||
46 | gtk_ui_manager_ensure_update (ui_manager); | ||
47 | |||
48 | - menu = gtk_ui_manager_get_widget (ui_manager, "/MenuBar"); | ||
49 | - gtk_box_pack_start (GTK_BOX (top_box), menu, FALSE, FALSE, 0); | ||
50 | + menu = gtk_ui_manager_get_widget (ui_manager, "/MenuBar/TasksMenu"); | ||
51 | + owl_set_window_menu_item (GTK_WINDOW (window), GTK_MENU_ITEM (menu)); | ||
52 | |||
53 | box = gtk_vbox_new (FALSE, 4); | ||
54 | gtk_container_set_border_width (GTK_CONTAINER (box), 4); | ||
55 | Index: src/gtk/Makefile.am | ||
56 | =================================================================== | ||
57 | --- src/gtk/Makefile.am (revision 338) | ||
58 | +++ src/gtk/Makefile.am (working copy) | ||
59 | @@ -4,7 +4,7 @@ | ||
60 | bin_PROGRAMS = tasks | ||
61 | tasks_CPPFLAGS = -I$(top_srcdir)/ | ||
62 | tasks_CFLAGS = $(WARN_CFLAGS) $(GTK_CFLAGS) $(ECAL_CFLAGS) $(SEXY_CFLAGS) | ||
63 | -tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS) | ||
64 | +tasks_LDADD = $(top_builddir)/libkoto/libkoto.a $(GTK_LIBS) $(ECAL_LIBS) $(SEXY_LIBS) -lowl | ||
65 | |||
66 | tasks_SOURCES = \ | ||
67 | main.c \ | ||
diff --git a/meta-gnome/recipes-gnome/pimlico/tasks_0.19.bb b/meta-gnome/recipes-gnome/pimlico/tasks_0.19.bb index f0d954212..992596eaf 100644 --- a/meta-gnome/recipes-gnome/pimlico/tasks_0.19.bb +++ b/meta-gnome/recipes-gnome/pimlico/tasks_0.19.bb | |||
@@ -10,6 +10,4 @@ SRC_URI = "http://pimlico-project.org/sources/${BPN}/${BPN}-${PV}.tar.gz" | |||
10 | SRC_URI[md5sum] = "0afd969758561599fd782e1effb39c08" | 10 | SRC_URI[md5sum] = "0afd969758561599fd782e1effb39c08" |
11 | SRC_URI[sha256sum] = "1a7fdc5f95a2193a1a25fdb13f071867fb7e42245ce19ccee4bcccb69e557f2e" | 11 | SRC_URI[sha256sum] = "1a7fdc5f95a2193a1a25fdb13f071867fb7e42245ce19ccee4bcccb69e557f2e" |
12 | 12 | ||
13 | OWL_poky = "--with-owl" | 13 | PR = "r3" |
14 | |||
15 | PR = "r2" | ||