diff options
author | Koen Kooi <koen@dominion.thruhere.net> | 2011-06-24 17:55:56 +0200 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2011-06-24 20:13:02 +0200 |
commit | 4e70eb9149d3de3d9e0b1bc5d6e6454bba645bed (patch) | |
tree | bbb374763a25f3ac71386763af7562f22d53ecf7 | |
parent | 208315e47adf40ced02649f084a850af59ee2cd8 (diff) | |
download | meta-openembedded-4e70eb9149d3de3d9e0b1bc5d6e6454bba645bed.tar.gz |
gnome-panel3: add 3.0.2
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-panel/gnome-panel3/as-needed.patch | 36 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb | 45 |
2 files changed, 81 insertions, 0 deletions
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3/as-needed.patch b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3/as-needed.patch new file mode 100644 index 000000000..378e3e405 --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3/as-needed.patch | |||
@@ -0,0 +1,36 @@ | |||
1 | From c65f1ae3472cfd4cd96fd376b7bbd95fba5eef0a Mon Sep 17 00:00:00 2001 | ||
2 | From: Vincent Untz <vuntz@gnome.org> | ||
3 | Date: Fri, 27 May 2011 17:00:14 +0000 | ||
4 | Subject: build: Fix build with --as-needed | ||
5 | |||
6 | upstream-status: backport | ||
7 | |||
8 | --- | ||
9 | diff --git a/applets/notification_area/Makefile.am b/applets/notification_area/Makefile.am | ||
10 | index 0afc6c5..9734536 100644 | ||
11 | --- a/applets/notification_area/Makefile.am | ||
12 | +++ b/applets/notification_area/Makefile.am | ||
13 | @@ -29,17 +29,17 @@ libtray_la_SOURCES = \ | ||
14 | NOTIFICATION_AREA_SOURCES = main.c main.h | ||
15 | |||
16 | NOTIFICATION_AREA_LDADD = \ | ||
17 | + libtray.la \ | ||
18 | ../../libpanel-applet/libpanel-applet-4.la \ | ||
19 | $(X_LIBS) \ | ||
20 | $(NOTIFICATION_AREA_LIBS) \ | ||
21 | - $(LIBPANEL_APPLET_LIBS) \ | ||
22 | - libtray.la | ||
23 | + $(LIBPANEL_APPLET_LIBS) | ||
24 | |||
25 | testtray_SOURCES = testtray.c | ||
26 | testtray_LDADD = \ | ||
27 | + libtray.la \ | ||
28 | $(X_LIBS) \ | ||
29 | - $(NOTIFICATION_AREA_LIBS) \ | ||
30 | - libtray.la | ||
31 | + $(NOTIFICATION_AREA_LIBS) | ||
32 | |||
33 | if NOTIFICATION_AREA_INPROCESS | ||
34 | APPLET_IN_PROCESS = true | ||
35 | -- | ||
36 | cgit v0.9 | ||
diff --git a/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb new file mode 100644 index 000000000..f1d6b3da0 --- /dev/null +++ b/meta-gnome/recipes-gnome/gnome-panel/gnome-panel3_3.0.2.bb | |||
@@ -0,0 +1,45 @@ | |||
1 | DESCRIPTION = "GNOME panel" | ||
2 | LICENSE = "GPLv2 && LGPLv2 && GFDLv1.1" | ||
3 | |||
4 | BPN = "gnome-panel" | ||
5 | |||
6 | DEFAULT_PREFERENCE = "-1" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
9 | file://COPYING-DOCS;md5=c9211dab3ae61e580f48432020784324 \ | ||
10 | file://COPYING.LIB;md5=5f30f0716dfdd0d91eb439ebec522ec2" | ||
11 | |||
12 | SECTION = "x11/gnome" | ||
13 | |||
14 | DEPENDS = "gnome-doc-utils-native gtk+3 gconf glib-2.0 gnome-desktop3 gtk+ pango libwnck3 gnome-menus cairo libgweather3 dbus-glib librsvg libcanberra" | ||
15 | |||
16 | inherit gtk-doc gnome gettext pkgconfig | ||
17 | |||
18 | SRC_URI += "file://as-needed.patch " | ||
19 | |||
20 | SRC_URI[archive.md5sum] = "0f2f644dc4081b72f6df7a65282af7c6" | ||
21 | SRC_URI[archive.sha256sum] = "25db8ec026c4bf47f0ef5cc7e2712f2aad175bd7fb8e4952ef5f8b200f17f196" | ||
22 | |||
23 | EXTRA_OECONF = "--disable-scrollkeeper --disable-eds --enable-bonobo=no --with-in-process-applets=none" | ||
24 | |||
25 | do_configure_prepend() { | ||
26 | gnome-doc-prepare --automake | ||
27 | sed -i -e s:help:: ${S}/Makefile.am | ||
28 | } | ||
29 | |||
30 | pkg_postinst_append () { | ||
31 | gconftool-2 --config-source=xml:readwrite:/etc/gconf/gconf.xml.defaults \ | ||
32 | --direct --load /etc/gconf/schemas/panel-default-setup.entries | ||
33 | } | ||
34 | |||
35 | PACKAGES =+ "libpanel-applet" | ||
36 | FILES_libpanel-applet = "${libdir}/libpanel-applet-3.so.*" | ||
37 | |||
38 | FILES_${PN} =+ "${datadir}/gnome* \ | ||
39 | ${datadir}/dbus-1 \ | ||
40 | ${datadir}/icons \ | ||
41 | ${datadir}/PolicyKit \ | ||
42 | ${libdir}/bonobo \ | ||
43 | " | ||
44 | |||
45 | |||