diff options
author | Khem Raj <raj.khem@gmail.com> | 2017-09-06 20:57:54 -0700 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2017-09-13 11:13:20 +0200 |
commit | 3bacc2323f89048b91e548fd5a40bf9a899e322b (patch) | |
tree | 26e5ec415a26a3aaef6275b9f8c83ef48cad9ded | |
parent | 948132006e1174cfc9834965c167b998f99eca51 (diff) | |
download | meta-openembedded-3bacc2323f89048b91e548fd5a40bf9a899e322b.tar.gz |
aufs-util: Use cross strip tool
Honor the STRIP variable when passed from environment
Fixes build with musl/raspberrypi
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Define-STRIP-weakly.patch | 39 | ||||
-rw-r--r-- | meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb | 2 |
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Define-STRIP-weakly.patch b/meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Define-STRIP-weakly.patch new file mode 100644 index 000000000..9efea804b --- /dev/null +++ b/meta-filesystems/recipes-utils/aufs-util/aufs-util/0001-libau-Define-STRIP-weakly.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From bb8801fb21ac8d73e3b1a11a8555aaf822182a51 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 5 Sep 2017 10:36:52 -0700 | ||
4 | Subject: [PATCH] libau: Define STRIP weakly | ||
5 | |||
6 | STRIP can be set on environment to use cross version of strip utility | ||
7 | hardcoding to strip is not working in cross environment | ||
8 | |||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | Upstream-Status: Submitted | ||
12 | |||
13 | libau/Makefile | 3 ++- | ||
14 | 1 file changed, 2 insertions(+), 1 deletion(-) | ||
15 | |||
16 | diff --git a/libau/Makefile b/libau/Makefile | ||
17 | index 81520ac..c25eef2 100644 | ||
18 | --- a/libau/Makefile | ||
19 | +++ b/libau/Makefile | ||
20 | @@ -25,6 +25,7 @@ LibSoHdr = libau.h rdu.h | ||
21 | LibSoExport = $(addsuffix .exp, $(basename ${LibSoObj})) | ||
22 | LibSoExportErr = $(addsuffix .err, ${LibSoExport}) | ||
23 | LibSoVerScript = verscript | ||
24 | +STRIP ?= strip | ||
25 | |||
26 | all: ${LibSo} | ||
27 | |||
28 | @@ -77,7 +78,7 @@ ${LibSo}.${LibSoMajor}.${LibSoMinor}: ${LibSoObj} | ||
29 | ${CC} --shared -Wl,-soname,${LibSo}.${LibSoMajor} \ | ||
30 | -Wl,--version-script,${LibSoVerScript} \ | ||
31 | ${LDFLAGS} -o $@ $^ ${LDLIBS} | ||
32 | - strip -R EXP $@ | ||
33 | + ${STRIP} -R EXP $@ | ||
34 | # readelf --syms --use-dynamic libau.so | ||
35 | |||
36 | install_ulib: File = ${LibSo}.${LibSoMajor}.${LibSoMinor} | ||
37 | -- | ||
38 | 2.14.1 | ||
39 | |||
diff --git a/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb b/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb index 66f560c37..2e855e313 100644 --- a/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb +++ b/meta-filesystems/recipes-utils/aufs-util/aufs-util_git.bb | |||
@@ -12,6 +12,7 @@ SRC_URI = "git://git.code.sf.net/p/aufs/aufs-util;protocol=git;branch=aufs4.4 \ | |||
12 | https://raw.githubusercontent.com/sfjro/aufs4-linux/aufs4.4/include/uapi/linux/aufs_type.h;name=aufs_type \ | 12 | https://raw.githubusercontent.com/sfjro/aufs4-linux/aufs4.4/include/uapi/linux/aufs_type.h;name=aufs_type \ |
13 | file://aufs-util-don-t-strip-executables.patch \ | 13 | file://aufs-util-don-t-strip-executables.patch \ |
14 | file://aufs-util-add-tool-concept-to-Makefile-for-cross-com.patch \ | 14 | file://aufs-util-add-tool-concept-to-Makefile-for-cross-com.patch \ |
15 | file://0001-libau-Define-STRIP-weakly.patch \ | ||
15 | " | 16 | " |
16 | SRC_URI[aufs_type.md5sum] = "f7b4a255dcb55fe7b0967f5f59b44f19" | 17 | SRC_URI[aufs_type.md5sum] = "f7b4a255dcb55fe7b0967f5f59b44f19" |
17 | SRC_URI[aufs_type.sha256sum] = "85bc8e4c1a94a7d526c382e4b047b4256cab8c4a65fc0396291707ad9a327a18" | 18 | SRC_URI[aufs_type.sha256sum] = "85bc8e4c1a94a7d526c382e4b047b4256cab8c4a65fc0396291707ad9a327a18" |
@@ -26,7 +27,6 @@ do_configure_prepend() { | |||
26 | sed -i -e 's;install_sbin: Tgt = ${DESTDIR}/sbin;install_sbin: Tgt = ${DESTDIR}/${base_sbindir};' \ | 27 | sed -i -e 's;install_sbin: Tgt = ${DESTDIR}/sbin;install_sbin: Tgt = ${DESTDIR}/${base_sbindir};' \ |
27 | -e 's;install_ubin: Tgt = ${DESTDIR}/usr/sbin;install_sbin: Tgt = ${DESTDIR}/${bindir};' \ | 28 | -e 's;install_ubin: Tgt = ${DESTDIR}/usr/sbin;install_sbin: Tgt = ${DESTDIR}/${bindir};' \ |
28 | ${S}/Makefile | 29 | ${S}/Makefile |
29 | sed -i -e 's;strip -R;${STRIP} -R;' ${S}/libau/Makefile | ||
30 | } | 30 | } |
31 | 31 | ||
32 | do_configure_append () { | 32 | do_configure_append () { |