diff options
author | Otavio Salvador <otavio@ossystems.com.br> | 2012-05-18 17:39:16 +0000 |
---|---|---|
committer | Koen Kooi <koen@dominion.thruhere.net> | 2012-05-18 22:21:22 +0200 |
commit | 2bf758cb0298c9b02d015a51d518094dcb39f710 (patch) | |
tree | 003083ef9e8aaf8461fe088e50f16f3afbfc7544 | |
parent | b87c64f8b4823b02c309a7ad630f572c67fb0640 (diff) | |
download | meta-openembedded-2bf758cb0298c9b02d015a51d518094dcb39f710.tar.gz |
nodejs: update to 0.6.18 and fix hardfloat detection
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch | 22 | ||||
-rw-r--r-- | meta-oe/recipes-devtools/nodejs/nodejs_0.6.18.bb (renamed from meta-oe/recipes-devtools/nodejs/nodejs_0.6.17.bb) | 12 |
2 files changed, 29 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch b/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch new file mode 100644 index 000000000..36e8bf1c9 --- /dev/null +++ b/meta-oe/recipes-devtools/nodejs/nodejs/fix-hardfloat-detection.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | Fix hardfloat detection | ||
2 | |||
3 | gcc has a builtin define to denote hard abi when in use, e.g. when | ||
4 | using -mfloat-abi=hard it will define __ARM_PCS_VFP to 1 and therefore | ||
5 | we should check that to determine which calling convention is in use | ||
6 | and not __VFP_FP__ which merely indicates presence of VFP unit | ||
7 | |||
8 | The fix has been provided by Khem Raj <raj.khem@gmail.com> | ||
9 | |||
10 | Upstream-Status: Forwarded | ||
11 | |||
12 | --- a/deps/v8/src/platform-linux.cc 2012-05-17 12:52:59.329519921 -0700 | ||
13 | +++ b/deps/v8/src/platform-linux.cc 2012-05-17 12:54:02.037521511 -0700 | ||
14 | @@ -212,7 +212,7 @@ | ||
15 | // calling this will return 1.0 and otherwise 0.0. | ||
16 | static void ArmUsingHardFloatHelper() { | ||
17 | asm("mov r0, #0"); | ||
18 | -#if defined(__VFP_FP__) && !defined(__SOFTFP__) | ||
19 | +#if defined(__ARM_PCS_VFP) && !defined(__SOFTFP__) | ||
20 | // Load 0x3ff00000 into r1 using instructions available in both ARM | ||
21 | // and Thumb mode. | ||
22 | asm("mov r1, #3"); | ||
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.17.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.18.bb index 1be5ce1d5..d5785d25d 100644 --- a/meta-oe/recipes-devtools/nodejs/nodejs_0.6.17.bb +++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.6.18.bb | |||
@@ -5,9 +5,11 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=914812f2875eef849b5c509cc25dcb4f" | |||
5 | 5 | ||
6 | DEPENDS = "openssl" | 6 | DEPENDS = "openssl" |
7 | 7 | ||
8 | SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz" | 8 | SRC_URI = "http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz \ |
9 | SRC_URI[md5sum] = "55641d5d280cdd4e0c030c203107599d" | 9 | file://gcc-4.7.patch" |
10 | SRC_URI[sha256sum] = "8dfe5948de27e37a14af184f06e7bd89a23c3b248af44c8ef5cffcd0e4c65778" | 10 | |
11 | SRC_URI[md5sum] = "4a3d3123ccc7b9b21c1990fe074e3d14" | ||
12 | SRC_URI[sha256sum] = "6cf4311ecbc1700e88f4382a31b3a7017c1572cd641fd06e653fc1692c2cffff" | ||
11 | 13 | ||
12 | S = "${WORKDIR}/node-v${PV}" | 14 | S = "${WORKDIR}/node-v${PV}" |
13 | 15 | ||
@@ -42,14 +44,14 @@ do_configure () { | |||
42 | } | 44 | } |
43 | 45 | ||
44 | do_compile_virtclass-native () { | 46 | do_compile_virtclass-native () { |
45 | make | 47 | make BUILDTYPE=Release |
46 | } | 48 | } |
47 | 49 | ||
48 | do_compile () { | 50 | do_compile () { |
49 | export PATH=${WORKDIR}:${PATH} | 51 | export PATH=${WORKDIR}:${PATH} |
50 | export CC=gcc | 52 | export CC=gcc |
51 | export CXX=g++ | 53 | export CXX=g++ |
52 | make | 54 | make BUILDTYPE=Release |
53 | } | 55 | } |
54 | 56 | ||
55 | do_install () { | 57 | do_install () { |