diff options
author | Shakeel, Muhammad <muhammad_shakeel@mentor.com> | 2013-09-12 15:28:53 +0000 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2013-09-17 19:06:27 +0200 |
commit | 03e6d3cba831c2de2dbfe2a869be706466122d12 (patch) | |
tree | 52fc320a50811e4755744d24cd8d718b08901e96 | |
parent | c837f8a883f1ff9aa6fd4a313b151e8967a1d9cc (diff) | |
download | meta-openembedded-03e6d3cba831c2de2dbfe2a869be706466122d12.tar.gz |
lighttpd: Remove systemd support which is merged in oe-core
OE-Core has been updated to support lighttpd with systemd. Stuff here is
not required anymore.
Signed-off-by: Muhammad Shakeel <muhammad_shakeel@mentor.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service | 13 | ||||
-rw-r--r-- | meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend | 13 |
2 files changed, 0 insertions, 26 deletions
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service deleted file mode 100644 index f4564f3f7..000000000 --- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd/lighttpd.service +++ /dev/null | |||
@@ -1,13 +0,0 @@ | |||
1 | [Unit] | ||
2 | Description=Lightning Fast Webserver With Light System Requirements | ||
3 | After=syslog.target | ||
4 | |||
5 | [Service] | ||
6 | Type=oneshot | ||
7 | EnvironmentFile=-/etc/sysconfig/lighttpd | ||
8 | ExecStart=/usr/sbin/lighttpd -D -f /etc/lighttpd.conf | ||
9 | RemainAfterExit=yes | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
13 | |||
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend index 96fa989f1..5cb6bf434 100644 --- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend +++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend | |||
@@ -1,18 +1,5 @@ | |||
1 | FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:" | ||
2 | |||
3 | PRINC := "${@int(PRINC) + 2}" | 1 | PRINC := "${@int(PRINC) + 2}" |
4 | 2 | ||
5 | inherit systemd | ||
6 | |||
7 | SRC_URI += "file://lighttpd.service" | ||
8 | |||
9 | RPROVIDES_${PN} += "${PN}-systemd" | 3 | RPROVIDES_${PN} += "${PN}-systemd" |
10 | RREPLACES_${PN} += "${PN}-systemd" | 4 | RREPLACES_${PN} += "${PN}-systemd" |
11 | RCONFLICTS_${PN} += "${PN}-systemd" | 5 | RCONFLICTS_${PN} += "${PN}-systemd" |
12 | SYSTEMD_SERVICE_${PN} = "lighttpd.service" | ||
13 | |||
14 | do_install_append() { | ||
15 | install -d ${D}${systemd_unitdir}/system | ||
16 | install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system | ||
17 | } | ||
18 | |||