summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@googlemail.com>2015-02-12 16:06:31 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2015-02-19 10:09:59 +0100
commitc22da8be7468c140c7aa56f44b4d02c125df19b3 (patch)
treeede61d3f48b89e4c7d1dcf69a614910e98f3dd12
parenteaa248e369b5445e41e895e6894d6e2a47c917a2 (diff)
downloadmeta-openembedded-c22da8be7468c140c7aa56f44b4d02c125df19b3.tar.gz
gimp: update to 2.8.14 / fix build by not configuring with freetype-config
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
-rw-r--r--meta-oe/recipes-graphics/gimp/gimp/0001-configure-ac-do-not-check-for-freetype-config.patch38
-rw-r--r--meta-oe/recipes-graphics/gimp/gimp/freetype.patch30
-rw-r--r--meta-oe/recipes-graphics/gimp/gimp_2.8.14.bb (renamed from meta-oe/recipes-graphics/gimp/gimp_2.8.10.bb)13
3 files changed, 45 insertions, 36 deletions
diff --git a/meta-oe/recipes-graphics/gimp/gimp/0001-configure-ac-do-not-check-for-freetype-config.patch b/meta-oe/recipes-graphics/gimp/gimp/0001-configure-ac-do-not-check-for-freetype-config.patch
new file mode 100644
index 000000000..fecd0121c
--- /dev/null
+++ b/meta-oe/recipes-graphics/gimp/gimp/0001-configure-ac-do-not-check-for-freetype-config.patch
@@ -0,0 +1,38 @@
1From 72ad76841d87e857428693d812a961935284ac62 Mon Sep 17 00:00:00 2001
2From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
3Date: Thu, 12 Feb 2015 15:57:47 +0100
4Subject: [PATCH] configure-ac: do not check for freetype-config
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9freetype-config is not allowed in our environment - see also binconfig-disabled
10
11Upstream-Status: inappropriate [OE specific]
12
13Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
14---
15 configure.ac | 7 -------
16 1 file changed, 7 deletions(-)
17
18diff --git a/configure.ac b/configure.ac
19index 26812b6..abec714 100644
20--- a/configure.ac
21+++ b/configure.ac
22@@ -647,13 +647,6 @@ if test "x$fontconfig_ok" = xno; then
23 fi
24
25
26-AC_PATH_PROG(FREETYPE_CONFIG, freetype-config, no)
27-if test "x$FREETYPE_CONFIG" != "xno" ; then
28- AC_MSG_CHECKING([for freetype libraries])
29- FREETYPE_LIBS=`$FREETYPE_CONFIG --libs`
30- AC_MSG_RESULT($FREETYPE_LIBS)
31-fi
32-AC_SUBST(FREETYPE_LIBS)
33
34
35 ##########################################
36--
371.9.3
38
diff --git a/meta-oe/recipes-graphics/gimp/gimp/freetype.patch b/meta-oe/recipes-graphics/gimp/gimp/freetype.patch
deleted file mode 100644
index ed6c09791..000000000
--- a/meta-oe/recipes-graphics/gimp/gimp/freetype.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1Include the freetype headers via macros ( recommended way)
2
3Signed-off-by: Khem Raj <raj.khem@gmail.com>
4Upstream-Status: Backport
5
6From 6c73f28b6d87a2afd11974552a075bffec52347f Mon Sep 17 00:00:00 2001
7From: Michael Natterer <mitch@gimp.org>
8Date: Fri, 29 Nov 2013 20:57:46 +0000
9Subject: Bug 719560 - Build failure with freetype 2.5.1
10
11Apply patch from su-v that fixes the freetype include to
12the madness devised and recommended by freetype.
13---
14diff --git a/app/text/gimpfont.c b/app/text/gimpfont.c
15index 4045ca9..66c6e52 100644
16--- a/app/text/gimpfont.c
17+++ b/app/text/gimpfont.c
18@@ -28,7 +28,9 @@
19
20 #define PANGO_ENABLE_ENGINE 1 /* Argh */
21 #include <pango/pango-ot.h>
22-#include <freetype/tttables.h>
23+
24+#include <ft2build.h>
25+#include FT_TRUETYPE_TABLES_H
26
27 #include "text-types.h"
28
29--
30cgit v0.9.2
diff --git a/meta-oe/recipes-graphics/gimp/gimp_2.8.10.bb b/meta-oe/recipes-graphics/gimp/gimp_2.8.14.bb
index a893dc259..7d52cf18e 100644
--- a/meta-oe/recipes-graphics/gimp/gimp_2.8.10.bb
+++ b/meta-oe/recipes-graphics/gimp/gimp_2.8.14.bb
@@ -7,16 +7,17 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
7DEPENDS = "babl gdk-pixbuf-native libart-lgpl gtk+ jpeg libpng libexif tiff lcms gegl poppler jasper bzip2" 7DEPENDS = "babl gdk-pixbuf-native libart-lgpl gtk+ jpeg libpng libexif tiff lcms gegl poppler jasper bzip2"
8DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)}" 8DEPENDS += "${@base_contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)}"
9 9
10inherit gnome 10inherit gnome gtk-doc
11 11
12PACKAGECONFIG ??= "" 12PACKAGECONFIG ??= ""
13PACKAGECONFIG[helpbrowser] = "--with-webkit, --without-webkit, webkit-gtk" 13PACKAGECONFIG[helpbrowser] = "--with-webkit, --without-webkit, webkit-gtk"
14 14
15SRC_URI = "http://ftp.gimp.org/pub/gimp/v2.8/gimp-${PV}.tar.bz2 \ 15SRC_URI = " \
16 file://freetype.patch \ 16 http://ftp.gimp.org/pub/gimp/v2.8/gimp-${PV}.tar.bz2 \
17 " 17 file://0001-configure-ac-do-not-check-for-freetype-config.patch \
18SRC_URI[md5sum] = "84c964aab7044489af69f7319bb59b47" 18"
19SRC_URI[sha256sum] = "e7fd8b19f989138d826003c75f56bd5b6f136eef597e86e3978ede0bba470ae6" 19SRC_URI[md5sum] = "233c948203383fa078434cc3f8f925cb"
20SRC_URI[sha256sum] = "d82a958641c9c752d68e35f65840925c08e314cea90222ad845892a40e05b22d"
20 21
21EXTRA_OECONF = "--disable-python \ 22EXTRA_OECONF = "--disable-python \
22 --without-wmf" 23 --without-wmf"