summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2017-04-24 04:38:17 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-26 20:13:33 +0200
commit8dec4d3f93fead21beea2a817068a006ea955571 (patch)
tree3c73e27c08f272ed90541b4095e5f21f92c80e22
parent47a9500b47f062be9d1b625b6090b1642e324007 (diff)
downloadmeta-openembedded-8dec4d3f93fead21beea2a817068a006ea955571.tar.gz
ntfs-3g-ntfsprogs: fix install failed while host dir not exist
While cross compiling, if the dir of "$(rootlibdir)" and "$(libdir)" (such as "/usr/lib64") do not exist on host system, the do_instal failed. ----------------------- make[3]: Entering directory `tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/build/libntfs-3g' if [ ! "/usr/lib64" -ef "/usr/lib64" ]; then \ mv -f "tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/image//usr/lib64"/libntfs-3g.so* \ "tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/image//usr/lib64"; \ fi mv:...are the same file ----------------------- Use `=' rather than `-ef' to compare them, the cross compile does not care about host dir. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch52
-rw-r--r--meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb4
2 files changed, 55 insertions, 1 deletions
diff --git a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch
new file mode 100644
index 000000000..7b8eec7cb
--- /dev/null
+++ b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/files/0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch
@@ -0,0 +1,52 @@
1From 575591caf1e8972f765885679b76787ef92de77b Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Mon, 24 Apr 2017 04:24:10 -0400
4Subject: [PATCH] libntfs-3g/Makefile.am: fix install failed while host dir not exist
5
6While cross compiling, if the dir of "$(rootlibdir)" and "$(libdir)"
7(such as "/usr/lib64") do not exist on host system, the do_instal failed.
8-----------------------
9make[3]: Entering directory `tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/build/libntfs-3g'
10if [ ! "/usr/lib64" -ef "/usr/lib64" ]; then \
11 mv -f "tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/image//usr/lib64"/libntfs-3g.so* \
12 "tmp/work/core2-64-wrs-linux/ntfs-3g-ntfsprogs/2017.3.23-r0/image//usr/lib64"; \
13fi
14mv:...are the same file
15-----------------------
16
17Use `=' rather than `-ef' to compare them, the cross compile does not
18care about host dir.
19
20Upstream-Status: Pending
21
22Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
23---
24 libntfs-3g/Makefile.am | 6 +++---
25 1 file changed, 3 insertions(+), 3 deletions(-)
26
27diff --git a/libntfs-3g/Makefile.am b/libntfs-3g/Makefile.am
28index d6b150e..806109d 100644
29--- a/libntfs-3g/Makefile.am
30+++ b/libntfs-3g/Makefile.am
31@@ -59,15 +59,15 @@ endif
32 # And create ldscript or symbolic link from /usr
33 install-exec-hook: install-rootlibLTLIBRARIES
34 if INSTALL_LIBRARY
35- if [ ! "$(rootlibdir)" -ef "$(libdir)" ]; then \
36+ if [ "$(rootlibdir)" != "$(libdir)" ]; then \
37 $(MV) -f "$(DESTDIR)/$(libdir)"/libntfs-3g.so* "$(DESTDIR)/$(rootlibdir)"; \
38 fi
39 if GENERATE_LDSCRIPT
40- if [ ! "$(rootlibdir)" -ef "$(libdir)" ]; then \
41+ if [ "$(rootlibdir)" != "$(libdir)" ]; then \
42 $(install_sh_PROGRAM) "libntfs-3g.script.so" "$(DESTDIR)/$(libdir)/libntfs-3g.so"; \
43 fi
44 else
45- if [ ! "$(rootlibdir)" -ef "$(libdir)" ]; then \
46+ if [ "$(rootlibdir)" != "$(libdir)" ]; then \
47 $(LN_S) "$(rootlibdir)/libntfs-3g.so" "$(DESTDIR)/$(libdir)/libntfs-3g.so"; \
48 fi
49 endif
50--
512.8.1
52
diff --git a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb
index 63627deda..9e77766e6 100644
--- a/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb
+++ b/meta-filesystems/recipes-filesystems/ntfs-3g-ntfsprogs/ntfs-3g-ntfsprogs_2017.3.23.bb
@@ -6,7 +6,9 @@ LICENSE = "GPLv2 & LGPLv2"
6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \ 6LIC_FILES_CHKSUM = "file://COPYING;md5=59530bdf33659b29e73d4adb9f9f6552 \
7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a" 7 file://COPYING.LIB;md5=f30a9716ef3762e3467a2f62bf790f0a"
8 8
9SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz" 9SRC_URI = "http://tuxera.com/opensource/ntfs-3g_ntfsprogs-${PV}.tgz \
10 file://0001-libntfs-3g-Makefile.am-fix-install-failed-while-host.patch \
11"
10S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}" 12S = "${WORKDIR}/ntfs-3g_ntfsprogs-${PV}"
11SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c" 13SRC_URI[md5sum] = "d97474ae1954f772c6d2fa386a6f462c"
12SRC_URI[sha256sum] = "3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5" 14SRC_URI[sha256sum] = "3e5a021d7b761261836dcb305370af299793eedbded731df3d6943802e1262d5"