diff options
author | mike.looijmans@topic.nl <mike.looijmans@topic.nl> | 2016-01-11 18:53:52 +0100 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-01-20 21:41:46 -0500 |
commit | 751659c243caae359213ee1cdb242c7eaadda73b (patch) | |
tree | e5d892d9e4e95e7e0186f71ac3ca490361241110 | |
parent | 37edcea5b7285df33dbaf125f9287c46f89c43bb (diff) | |
download | meta-openembedded-751659c243caae359213ee1cdb242c7eaadda73b.tar.gz |
recipes-connectivity/samba: Only rmdir directories that exist
Depending on PACKAGECONFIG selection, the /run/samba directory may not
have been created. Make the do_install_append handle both situations
by checking whether these directories exist before attempting to remove
them.
This fixes do_install failing with an error like this:
rmdir: failed to remove '/.../samba/4.1.12-r0/image/run/samba': No such file or directory
Signed-off-by: Mike Looijmans <mike.looijmans@topic.nl>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r-- | meta-networking/recipes-connectivity/samba/samba_4.1.12.bb | 8 |
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb b/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb index 3d677bec1..42315138e 100644 --- a/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb +++ b/meta-networking/recipes-connectivity/samba/samba_4.1.12.bb | |||
@@ -111,8 +111,12 @@ EXTRA_OECONF += "--enable-fhs \ | |||
111 | LDFLAGS += "-Wl,-z,relro,-z,now" | 111 | LDFLAGS += "-Wl,-z,relro,-z,now" |
112 | 112 | ||
113 | do_install_append() { | 113 | do_install_append() { |
114 | rmdir --ignore-fail-on-non-empty "${D}/run/samba" | 114 | if [ -d "${D}/run" ]; then |
115 | rmdir --ignore-fail-on-non-empty "${D}/run" | 115 | if [ -d "${D}/run/samba" ]; then |
116 | rmdir --ignore-fail-on-non-empty "${D}/run/samba" | ||
117 | fi | ||
118 | rmdir --ignore-fail-on-non-empty "${D}/run" | ||
119 | fi | ||
116 | 120 | ||
117 | if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then | 121 | if ${@bb.utils.contains('PACKAGECONFIG', 'systemd', 'true', 'false', d)}; then |
118 | install -d ${D}${systemd_unitdir}/system | 122 | install -d ${D}${systemd_unitdir}/system |