summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-04-26 16:22:03 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-27 11:14:57 +0200
commit3a4385bc051338379d7d18337cce85d3a827e2f7 (patch)
tree747c9c89659b784cc807b71b9476fa3441e316e6
parentc94e1362276f210961ca9fa541c19973aed623ed (diff)
downloadmeta-openembedded-3a4385bc051338379d7d18337cce85d3a827e2f7.tar.gz
libdata-hexdump-perl: add new recipe
Data::HexDump - Hexadecial Dumper module for perl. It's required by libauthen-radius-perl. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libdata/files/run-ptest16
-rw-r--r--meta-perl/recipes-perl/libdata/libdata-hexdump-perl_0.02.bb33
2 files changed, 49 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libdata/files/run-ptest b/meta-perl/recipes-perl/libdata/files/run-ptest
new file mode 100644
index 000000000..c9f9ca94d
--- /dev/null
+++ b/meta-perl/recipes-perl/libdata/files/run-ptest
@@ -0,0 +1,16 @@
1#!/bin/sh
2
3for case in `find t -type f -name '*.t'`; do
4 perl $case >$case.output 2>&1
5 ret=$?
6 cat $case.output
7 if [ $ret -ne 0 ]; then
8 echo "FAIL: ${case%.t}"
9 elif grep -i 'SKIP' $case.output; then
10 echo "SKIP: ${case%.t}"
11 else
12 echo "PASS: ${case%.t}"
13 fi
14
15 rm -f $case.output
16done
diff --git a/meta-perl/recipes-perl/libdata/libdata-hexdump-perl_0.02.bb b/meta-perl/recipes-perl/libdata/libdata-hexdump-perl_0.02.bb
new file mode 100644
index 000000000..6ab5a4204
--- /dev/null
+++ b/meta-perl/recipes-perl/libdata/libdata-hexdump-perl_0.02.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Data::HexDump - Hexadecial Dumper"
2DESCRIPTION = "Dump in hexadecimal the content of a scalar. The result \
3is returned in a string. Each line of the result consists of the offset \
4in the source in the leftmost column of each line, followed by one or \
5more columns of data from the source in hexadecimal. The rightmost column \
6of each line shows the printable characters \
7(all others are shown as single dots).\
8"
9
10HOMEPAGE = "http://search.cpan.org/~ftassin/Data-HexDump-0.02/lib/Data/HexDump.pm"
11SECTION = "libs"
12
13LICENSE = "Artistic-1.0"
14LIC_FILES_CHKSUM = "file://lib/Data/HexDump.pm;beginline=215;endline=217;md5=bf1cd9373f8d1f85fe091ee069a480e9"
15
16DEPENDS = "perl"
17
18SRC_URI = "http://search.cpan.org/CPAN/authors/id/F/FT/FTASSIN/Data-HexDump-${PV}.tar.gz \
19 file://run-ptest \
20"
21SRC_URI[md5sum] = "467b7183d1062ab4a502b50c34e7d67f"
22SRC_URI[sha256sum] = "1a9d843e7f667c1c6f77c67af5d77e7462ff23b41937cb17454d03535cd9be70"
23
24S = "${WORKDIR}/Data-HexDump-${PV}"
25
26inherit cpan ptest
27
28do_install_ptest () {
29 install -d ${D}${PTEST_PATH}/t
30 install -m 0755 ${B}/t/* ${D}${PTEST_PATH}/t
31}
32
33BBCLASSEXTEND = "native"