diff options
author | Richard Purdie <richard.purdie@linuxfoundation.org> | 2016-06-02 10:34:06 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-06-08 14:55:27 +0200 |
commit | 24fe575e796798fb0a41ae81bbd554e35b4cdb2e (patch) | |
tree | 7b14159472181acafb9376b36ed37bd87e3f9b8b | |
parent | 80cf5e0ee961436fbcb2fa2c03cb709f79fa9e3c (diff) | |
download | meta-openembedded-24fe575e796798fb0a41ae81bbd554e35b4cdb2e.tar.gz |
abiword, gnome-vfs: Use print as a function
In python 3, print is a function. Disable some pointless debug output
whilst here.
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb | 2 | ||||
-rw-r--r-- | meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb | 2 |
2 files changed, 1 insertions, 3 deletions
diff --git a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb index 962a56cb9..e0888c18f 100644 --- a/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb +++ b/meta-gnome/recipes-gnome/abiword/abiword_3.0.1.bb | |||
@@ -113,7 +113,7 @@ python populate_packages_prepend () { | |||
113 | packages = d.getVar('PACKAGES', 1).split() | 113 | packages = d.getVar('PACKAGES', 1).split() |
114 | for pkg in packages[1:]: | 114 | for pkg in packages[1:]: |
115 | if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"): | 115 | if not pkg in blacklist and not pkg in metapkg_rdepends and not pkg.count("-dev") and not pkg.count("-dbg") and not pkg.count("static") and not pkg.count("locale") and not pkg.count("abiword-doc"): |
116 | print "Modifying ", pkg | 116 | print("Modifying %s" % pkg) |
117 | metapkg_rdepends.append(pkg) | 117 | metapkg_rdepends.append(pkg) |
118 | d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends)) | 118 | d.setVar('RDEPENDS_' + metapkg, ' '.join(metapkg_rdepends)) |
119 | d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package') | 119 | d.setVar('DESCRIPTION_' + metapkg, 'abiword-plugin meta package') |
diff --git a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb index f9b02b1db..1c784743f 100644 --- a/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb +++ b/meta-gnome/recipes-gnome/gnome-vfs/gnome-vfs_2.24.4.bb | |||
@@ -53,8 +53,6 @@ FILES_${PN}-doc += "${datadir}/gtk-doc" | |||
53 | PACKAGES_DYNAMIC += "^gnome-vfs-plugin-.*" | 53 | PACKAGES_DYNAMIC += "^gnome-vfs-plugin-.*" |
54 | 54 | ||
55 | python populate_packages_prepend () { | 55 | python populate_packages_prepend () { |
56 | print d.getVar('FILES_gnome-vfs', 1) | ||
57 | |||
58 | plugindir = d.expand('${libdir}/gnome-vfs-2.0/modules/') | 56 | plugindir = d.expand('${libdir}/gnome-vfs-2.0/modules/') |
59 | do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s') | 57 | do_split_packages(d, plugindir, '^lib(.*)\.so$', 'gnome-vfs-plugin-%s', 'GNOME VFS plugin for %s') |
60 | } | 58 | } |