summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-04-26 16:22:07 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-27 11:14:58 +0200
commit18dcde134609683685c06a651c9913cb0f23724d (patch)
tree69fa1e62a6b926eef5a67e66ead55366bdd25821
parent5f4191269065d701ac0ac9e1127797b60923226d (diff)
downloadmeta-openembedded-18dcde134609683685c06a651c9913cb0f23724d.tar.gz
ipmitool: add new recipe
Utility for IPMI control which is for interfacing with devices that support the Intelligent Platform Management Interface specification. Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta-oe/recipes-support/ipmitool/ipmitool_1.8.18.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ipmitool/ipmitool_1.8.18.bb b/meta-oe/recipes-support/ipmitool/ipmitool_1.8.18.bb
new file mode 100644
index 000000000..9f73d2799
--- /dev/null
+++ b/meta-oe/recipes-support/ipmitool/ipmitool_1.8.18.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Utility for IPMI control"
2DESCRIPTION = "This package contains a utility for interfacing with devices that support \
3the Intelligent Platform Management Interface specification. IPMI is \
4an open standard for machine health, inventory, and remote power control. \
5\
6This utility can communicate with IPMI-enabled devices through either a \
7kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in \
8the IPMI specification. IPMIv2 adds support for encrypted LAN \
9communications and remote Serial-over-LAN functionality. \
10\
11It provides commands for reading the Sensor Data Repository (SDR) and \
12displaying sensor values, displaying the contents of the System Event \
13Log (SEL), printing Field Replaceable Unit (FRU) information, reading and \
14setting LAN configuration, and chassis power control. \
15"
16
17HOMEPAGE = "http://ipmitool.sourceforge.net/"
18SECTION = "kernel/userland"
19
20LICENSE = "BSD-3-Clause"
21LIC_FILES_CHKSUM = "file://COPYING;md5=9aa91e13d644326bf281924212862184"
22
23DEPENDS = "openssl readline ncurses"
24
25SRC_URI = "${SOURCEFORGE_MIRROR}/ipmitool/ipmitool-${PV}.tar.bz2"
26SRC_URI[md5sum] = "bab7ea104c7b85529c3ef65c54427aa3"
27SRC_URI[sha256sum] = "0c1ba3b1555edefb7c32ae8cd6a3e04322056bc087918f07189eeedfc8b81e01"
28
29inherit autotools
30
31# --disable-dependency-tracking speeds up the build
32# --enable-file-security adds some security checks
33# --disable-intf-free disables FreeIPMI support - we don't want to depend on
34# FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
35#
36EXTRA_OECONF = "--disable-dependency-tracking --enable-file-security --disable-intf-free"