summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-06-02 16:04:56 +0800
committerArmin Kuster <akuster808@gmail.com>2017-07-17 11:17:47 -0700
commitb16e4010e3341b8cdc2b45ec0693da932cd62092 (patch)
tree65b50842b8df4e1ec888fa654f9d340edf8fb502
parent55d9648664c36604b7a11649827b6d8e924ebef1 (diff)
downloadmeta-openembedded-b16e4010e3341b8cdc2b45ec0693da932cd62092.tar.gz
umip: fix for parallel compilation
Add missing dependency in Makefile to fix the parallel compile issue and re-enable PARALLEL_MAKE Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch23
-rw-r--r--meta-oe/recipes-connectivity/umip/umip_1.0.bb6
2 files changed, 26 insertions, 3 deletions
diff --git a/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch b/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch
new file mode 100644
index 000000000..dbf008264
--- /dev/null
+++ b/meta-oe/recipes-connectivity/umip/files/add-dependency-to-support-parallel-compilation.patch
@@ -0,0 +1,23 @@
1When "make -j10", the compilation will fail,
2because scan.c has included gram.h, but gram.h was produced
3after scan.c was compiled
4
5So add this dependency to ensure that gram.h is produced
6before scan.c is produced.
7
8Upstream-Status: Inappropriate [upstream is not active]
9
10Signed-off-by: Roy.Li <RongQing.Li@windriver.com>
11Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
12---
13 src/Makefile.am | 2 ++
14 1 file changed, 2 insertions(+)
15
16--- a/src/Makefile.am
17+++ b/src/Makefile.am
18@@ -81,3 +81,5 @@ CLEANFILES = gram.c gram.h \
19
20 DISTCLEANFILES = $(BUILT_SOURCES)
21 MAINTAINERCLEANFILES = Makefile.in
22+
23+scan.c: gram.h
diff --git a/meta-oe/recipes-connectivity/umip/umip_1.0.bb b/meta-oe/recipes-connectivity/umip/umip_1.0.bb
index e80c1b130..e97dd48f6 100644
--- a/meta-oe/recipes-connectivity/umip/umip_1.0.bb
+++ b/meta-oe/recipes-connectivity/umip/umip_1.0.bb
@@ -9,12 +9,12 @@ LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=073dc31ccb2ebed70db54f1e8aeb4c33" 9LIC_FILES_CHKSUM = "file://COPYING;md5=073dc31ccb2ebed70db54f1e8aeb4c33"
10DEPENDS = "rpm indent-native" 10DEPENDS = "rpm indent-native"
11 11
12SRC_URI = "git://git.umip.org/umip.git" 12SRC_URI = "git://git.umip.org/umip.git \
13 file://add-dependency-to-support-parallel-compilation.patch \
14"
13SRCREV = "428974c2d0d8e75a2750a3ab0488708c5dfdd8e3" 15SRCREV = "428974c2d0d8e75a2750a3ab0488708c5dfdd8e3"
14 16
15S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
16EXTRA_OE_CONF = "--enable-vt" 18EXTRA_OE_CONF = "--enable-vt"
17 19
18inherit autotools-brokensep 20inherit autotools-brokensep
19
20PARALLEL_MAKE = ""