summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-27 19:08:07 -0700
committerArmin Kuster <akuster808@gmail.com>2017-09-13 17:16:28 -0700
commit386613255973754d0d99c84149c327abd48f821d (patch)
treed017f8dd3888a22dc2aebf0da7a6f62d186ca3a5
parent84d5454ade283f60586adfb6f146f2bd76856cb0 (diff)
downloadmeta-openembedded-386613255973754d0d99c84149c327abd48f821d.tar.gz
sblim-sfcb: Add stdint.h for 'UINT16_MAX'
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit c0d763a6e604647f6dad25119eed5820195c2280) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.9/0001-include-stdint.h-system-header-for-UINT16_MAX.patch29
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb4
2 files changed, 32 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.9/0001-include-stdint.h-system-header-for-UINT16_MAX.patch b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.9/0001-include-stdint.h-system-header-for-UINT16_MAX.patch
new file mode 100644
index 000000000..c2111a2c1
--- /dev/null
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb-1.4.9/0001-include-stdint.h-system-header-for-UINT16_MAX.patch
@@ -0,0 +1,29 @@
1From 446fb15f79499f52ce01ca759dbdcfe635519a82 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 27 Jun 2017 07:09:33 -0700
4Subject: [PATCH] include stdint.h system header for UINT16_MAX
5
6Fixes build error
7
8error: 'UINT16_MAX' undeclared (first use in this function)
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 interopServerProvider.c | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/interopServerProvider.c b/interopServerProvider.c
16index 23ae182..532febe 100644
17--- a/interopServerProvider.c
18+++ b/interopServerProvider.c
19@@ -33,6 +33,7 @@
20 #include <sfcCommon/utilft.h>
21 #include <stdio.h>
22 #include <stdlib.h>
23+#include <stdint.h>
24 #include <ctype.h>
25 #include <string.h>
26 #include <sys/types.h>
27--
282.13.2
29
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
index fa75fcc16..ddb1cba7f 100644
--- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
@@ -12,6 +12,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=f300afd598546add034364cd0a533261"
12DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native" 12DEPENDS = "curl libpam openssl sblim-sfc-common unzip-native"
13 13
14SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \ 14SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \
15 file://sfcb.service \
15 file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \ 16 file://sblim-sfcb-1.3.9-sfcbrepos-schema-location.patch \
16 file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \ 17 file://sblim-sfcb-1.3.15-fix-provider-debugging.patch \
17 file://sblim-sfcb-1.3.16-maxMsgLen.patch \ 18 file://sblim-sfcb-1.3.16-maxMsgLen.patch \
@@ -19,7 +20,8 @@ SRC_URI = "http://downloads.sourceforge.net/sblim/${BP}.tar.bz2 \
19 file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \ 20 file://sblim-sfcb-1.3.16-multilib-man-cfg.patch \
20 file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \ 21 file://sblim-sfcb-1.4.8-default-ecdh-curve-name.patch \
21 file://sblim-sfcb-1.4.9-fix-ftbfs.patch \ 22 file://sblim-sfcb-1.4.9-fix-ftbfs.patch \
22 file://sfcb.service" 23 file://0001-include-stdint.h-system-header-for-UINT16_MAX.patch \
24"
23 25
24SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30" 26SRC_URI[md5sum] = "28021cdabc73690a94f4f9d57254ce30"
25SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd" 27SRC_URI[sha256sum] = "634a67b2f7ac3b386a79160eb44413d618e33e4e7fc74ae68b0240484af149dd"