summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-30 19:03:59 -0700
committerArmin Kuster <akuster808@gmail.com>2017-09-13 17:16:28 -0700
commit3232999d645d166cad1e6f678afd45e974fb506b (patch)
treebe4ae97eb4b999d3e1d0077d7d6a2fd5d63f8766
parentbd4cc1044eeb9ba967eebf982d70b44055012809 (diff)
downloadmeta-openembedded-3232999d645d166cad1e6f678afd45e974fb506b.tar.gz
corosync: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 2756ef68c92db20c093ef44460ff0ff7047006ec) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch28
-rw-r--r--meta-oe/recipes-extended/corosync/corosync_2.4.2.bb4
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch b/meta-oe/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch
new file mode 100644
index 000000000..fe4b0793f
--- /dev/null
+++ b/meta-oe/recipes-extended/corosync/corosync/0001-Include-fcntl.h-for-F_-and-O_-defines.patch
@@ -0,0 +1,28 @@
1From 85ea47fedbc96ed9180e08b0d371d9966e3a88da Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 30 Aug 2017 17:28:55 -0700
4Subject: [PATCH] Include fcntl.h for F_* and O_* defines
5
6Fixes errors like
7utils.c:95:22: error: use of undeclared identifier 'O_WRONLY'
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 qdevices/utils.c | 1 +
12 1 file changed, 1 insertion(+)
13
14diff --git a/qdevices/utils.c b/qdevices/utils.c
15index 41850b8c..87090853 100644
16--- a/qdevices/utils.c
17+++ b/qdevices/utils.c
18@@ -39,6 +39,7 @@
19
20 #include <err.h>
21 #include <errno.h>
22+#include <fcntl.h>
23 #include <inttypes.h>
24 #include <libgen.h>
25 #include <stdio.h>
26--
272.14.1
28
diff --git a/meta-oe/recipes-extended/corosync/corosync_2.4.2.bb b/meta-oe/recipes-extended/corosync/corosync_2.4.2.bb
index 2f3aef299..c4af00650 100644
--- a/meta-oe/recipes-extended/corosync/corosync_2.4.2.bb
+++ b/meta-oe/recipes-extended/corosync/corosync_2.4.2.bb
@@ -7,7 +7,9 @@ SECTION = "base"
7 7
8inherit autotools pkgconfig systemd 8inherit autotools pkgconfig systemd
9 9
10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz" 10SRC_URI = "http://build.clusterlabs.org/corosync/releases/${BP}.tar.gz \
11 file://0001-Include-fcntl.h-for-F_-and-O_-defines.patch \
12 "
11SRC_URI[md5sum] = "547fa78704da53aa35912be58d31035f" 13SRC_URI[md5sum] = "547fa78704da53aa35912be58d31035f"
12SRC_URI[sha256sum] = "f26e3011309fe4bcce94b1dc20ea8c462f19483a73f3ca62f13b925d011a4ba9" 14SRC_URI[sha256sum] = "f26e3011309fe4bcce94b1dc20ea8c462f19483a73f3ca62f13b925d011a4ba9"
13 15