summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-08-27 12:12:03 -0700
committerArmin Kuster <akuster808@gmail.com>2017-09-13 17:16:28 -0700
commit2946ce1c9ab30f4be93e177a0610f8b74b32e9f3 (patch)
tree3e2e5b1e84120fee0768d95a5c6d19d4b95761ca
parent0f01e553f852c6e0943b7e19ae32c344d436e380 (diff)
downloadmeta-openembedded-2946ce1c9ab30f4be93e177a0610f8b74b32e9f3.tar.gz
glade: Fix format string warnings with clang
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 059b3b24747e96c2220e13f3078b3fd93e96e468) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch62
-rw-r--r--meta-oe/recipes-devtools/glade/glade3_3.8.5.bb10
2 files changed, 67 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch b/meta-oe/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch
new file mode 100644
index 000000000..03cb762ce
--- /dev/null
+++ b/meta-oe/recipes-devtools/glade/glade3/0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch
@@ -0,0 +1,62 @@
1From fcf29abe59607b5791f9de18ddb86b9ae3c9b7cc Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 26 Aug 2017 23:50:05 -0700
4Subject: [PATCH] Add G_GNUC_PRINTF on functions with format strings
5
6This allows compilation with clang without errors, even when
7-Wformat-nonliteral is active (as long as there are no real cases of
8non literal formatting).
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 gladeui/glade-command.c | 4 ++--
13 gladeui/glade-utils.c | 4 ++--
14 2 files changed, 4 insertions(+), 4 deletions(-)
15
16diff --git a/gladeui/glade-command.c b/gladeui/glade-command.c
17index 9819766..4ac40ee 100644
18--- a/gladeui/glade-command.c
19+++ b/gladeui/glade-command.c
20@@ -266,7 +266,7 @@ glade_command_collapse (GladeCommand *command,
21 *
22 * Marks the begining of a group.
23 */
24-void
25+G_GNUC_PRINTF(1, 2) void
26 glade_command_push_group (const gchar *fmt, ...)
27 {
28 va_list args;
29@@ -655,7 +655,7 @@ glade_command_set_properties_list (GladeProject *project, GList *props)
30
31 multiple = g_list_length (me->sdata) > 1;
32 if (multiple)
33- glade_command_push_group (cmd->description);
34+ glade_command_push_group ("%s", cmd->description);
35
36
37 glade_command_check_group (GLADE_COMMAND (me));
38diff --git a/gladeui/glade-utils.c b/gladeui/glade-utils.c
39index ae52501..c51ae59 100644
40--- a/gladeui/glade-utils.c
41+++ b/gladeui/glade-utils.c
42@@ -197,7 +197,7 @@ glade_utils_get_pspec_from_funcname (const gchar *funcname)
43 * selected "OK", True if the @type was GLADE_UI_YES_OR_NO and
44 * the user selected "YES"; False otherwise.
45 */
46-gint
47+G_GNUC_PRINTF(4, 5) gint
48 glade_util_ui_message (GtkWidget *parent,
49 GladeUIMessageType type,
50 GtkWidget *widget,
51@@ -320,7 +320,7 @@ remove_message_timeout (FlashInfo * fi)
52 *
53 * Flash a temporary message on the statusbar.
54 */
55-void
56+G_GNUC_PRINTF(3, 4) void
57 glade_util_flash_message (GtkWidget *statusbar, guint context_id, gchar *format, ...)
58 {
59 va_list args;
60--
612.14.1
62
diff --git a/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb b/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb
index fd655366f..c4f600095 100644
--- a/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb
+++ b/meta-oe/recipes-devtools/glade/glade3_3.8.5.bb
@@ -8,11 +8,11 @@ DEPENDS = "gtk+ gnome-doc-utils gnome-common libxml2 intltool-native"
8 8
9inherit autotools pkgconfig pythonnative gtk-icon-cache 9inherit autotools pkgconfig pythonnative gtk-icon-cache
10 10
11SRC_URI = " \ 11SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/glade3/3.8/glade3-${PV}.tar.xz \
12 http://ftp.gnome.org/pub/GNOME/sources/glade3/3.8/glade3-${PV}.tar.xz \ 12 file://0001-gnome-doc-utils.make-sysrooted-pkg-config.patch \
13 file://0001-gnome-doc-utils.make-sysrooted-pkg-config.patch \ 13 file://0002-fix-gcc-6-build.patch \
14 file://0002-fix-gcc-6-build.patch \ 14 file://0001-Add-G_GNUC_PRINTF-on-functions-with-format-strings.patch \
15" 15 "
16SRC_URI[md5sum] = "4e4b4f5ee34a03e017e4cef97d796c1f" 16SRC_URI[md5sum] = "4e4b4f5ee34a03e017e4cef97d796c1f"
17SRC_URI[sha256sum] = "58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735" 17SRC_URI[sha256sum] = "58a5f6e4df4028230ddecc74c564808b7ec4471b1925058e29304f778b6b2735"
18 18