summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@codeconstruct.com.au>2023-10-30 14:17:53 +1030
committerArmin Kuster <akuster808@gmail.com>2023-11-01 08:16:30 -0400
commitf6eb3b597a3530b7afd9e817b1b7d7d8443ee6aa (patch)
treead9ab76f613fd6853c85561f4b59a0d00be68816
parent650cab0cff5e3a6131db757636669d380fe25ceb (diff)
downloadmeta-openembedded-f6eb3b597a3530b7afd9e817b1b7d7d8443ee6aa.tar.gz
mdio-tools: Add virtual/kernel dependency to avoid stale SPDX reference
OpenBMC enables SPDX SBOM generation by default. For Meta's Bletchley platform we found that mdio-tools and its relationships with both mdio-netlink and the mdio-netlink kernel module break SPDX processing while generating the rootfs after a kernel bump. For example, the following output was generated by `bitbake obmc-phosphor-image`: ERROR: obmc-phosphor-image-1.0-r0 do_rootfs: Cannot find any SPDX file for document http://spdx.org/spdxdoc/kernel-module-mdio-netlink-6.5.4-da279e9-00089-gda279e98c07f-89187488-3164-50cb-94c5-8b76a30ea093 The error occurred after the following patch was applied (again, in the context of OpenBMC): diff --git a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb index e6f98297c540..b852e993f0f6 100644 --- a/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb +++ b/meta-aspeed/recipes-kernel/linux/linux-aspeed_git.bb @@ -1,6 +1,6 @@ KBRANCH ?= "dev-6.5" -LINUX_VERSION ?= "6.5.4" +LINUX_VERSION ?= "6.5.9" -SRCREV="da279e98c07f9c948c60a434ab0043a55c26ea1d" +SRCREV="fc8d4fdba5bd2b9b1cea2aa8a731531943c45aa7" require linux-aspeed.inc With the lack of a dependency the mdio-tools package is not rebuilt subsequent to the kernel bump and the package information remains stale, leading to an incorrect SPDX path being generated. Signed-off-by: Andrew Jeffery <andrew@codeconstruct.com.au> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit 668cf43b21e27faa34b7c3c7133a480a9e4e480f) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-networking/recipes-support/mdio-tools/mdio-tools_1.3.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-networking/recipes-support/mdio-tools/mdio-tools_1.3.0.bb b/meta-networking/recipes-support/mdio-tools/mdio-tools_1.3.0.bb
index cd4df3da0..0c64889bc 100644
--- a/meta-networking/recipes-support/mdio-tools/mdio-tools_1.3.0.bb
+++ b/meta-networking/recipes-support/mdio-tools/mdio-tools_1.3.0.bb
@@ -1,6 +1,6 @@
1require mdio-tools.inc 1require mdio-tools.inc
2 2
3DEPENDS += "libmnl" 3DEPENDS += "virtual/kernel libmnl"
4 4
5S = "${WORKDIR}/git" 5S = "${WORKDIR}/git"
6 6