summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-04-03 16:01:57 +0200
committerArmin Kuster <akuster808@gmail.com>2017-08-04 21:07:42 -0700
commit412865c3258913992f6b2a6c302c870ea4dfcbea (patch)
tree164913ec40c995a223494e0413b4dd8cabcd9430
parent35a020bc87028cbb0014895187dddec6dc39321f (diff)
downloadmeta-openembedded-412865c3258913992f6b2a6c302c870ea4dfcbea.tar.gz
uml-utilities: respect LDFLAGS not only for mconsole but for other binaries as well
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit 1214d169f52301bf89b8b15339feb92d84306e2e) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch88
1 files changed, 88 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
index 05cc5371f..f4a175cdf 100644
--- a/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
+++ b/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
@@ -14,3 +14,91 @@
14 14
15 clean : 15 clean :
16 rm -f $(BIN) $(OBJS) *~ 16 rm -f $(BIN) $(OBJS) *~
17diff -uNr tools.orig/jailtest/Makefile tools/jailtest/Makefile
18--- tools.orig/jailtest/Makefile 2017-04-03 15:56:02.068461380 +0200
19+++ tools/jailtest/Makefile 2017-04-03 16:00:04.857449005 +0200
20@@ -7,7 +7,7 @@
21 all : $(BIN)
22
23 $(BIN) : $(OBJS)
24- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
25+ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
26
27 clean :
28 rm -f $(BIN) $(OBJS) *~
29diff -uNr tools.orig/moo/Makefile tools/moo/Makefile
30--- tools.orig/moo/Makefile 2017-04-03 15:56:02.068461380 +0200
31+++ tools/moo/Makefile 2017-04-03 15:59:56.466449432 +0200
32@@ -10,10 +10,10 @@
33 all : $(BIN)
34
35 uml_moo : $(uml_moo_OBJS)
36- $(CC) $(CFLAGS) -o $@ $($@_OBJS)
37+ $(CC) $(CFLAGS) -o $@ $($@_OBJS) $(LDFLAGS)
38
39 uml_mkcow : $(uml_mkcow_OBJS)
40- $(CC) $(CFLAGS) -o $@ $($@_OBJS)
41+ $(CC) $(CFLAGS) -o $@ $($@_OBJS) $(LDFLAGS)
42
43 $(uml_moo_OBJS) $(uml_mkcow_OBJS) : cow.h cow_sys.h
44
45diff -uNr tools.orig/port-helper/Makefile tools/port-helper/Makefile
46--- tools.orig/port-helper/Makefile 2017-04-03 15:56:02.068461380 +0200
47+++ tools/port-helper/Makefile 2017-04-03 15:59:41.251450208 +0200
48@@ -7,7 +7,7 @@
49 all : $(BIN)
50
51 $(BIN) : $(OBJS)
52- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
53+ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
54
55 clean :
56 rm -f $(BIN) $(OBJS) *~
57diff -uNr tools.orig/tunctl/Makefile tools/tunctl/Makefile
58--- tools.orig/tunctl/Makefile 2017-04-03 15:56:02.068461380 +0200
59+++ tools/tunctl/Makefile 2017-04-03 16:00:01.091449197 +0200
60@@ -7,7 +7,7 @@
61 all : $(BIN)
62
63 $(BIN) : $(OBJS)
64- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
65+ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
66
67 clean :
68 rm -f $(BIN) $(OBJS) *~
69diff -uNr tools.orig/uml_net/Makefile tools/uml_net/Makefile
70--- tools.orig/uml_net/Makefile 2017-04-03 15:56:02.068461380 +0200
71+++ tools/uml_net/Makefile 2017-04-03 16:00:12.449448618 +0200
72@@ -14,7 +14,7 @@
73 all : $(BIN)
74
75 $(BIN) : $(OBJS)
76- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
77+ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
78
79 clean :
80 rm -f $(BIN) $(OBJS) *~
81diff -uNr tools.orig/uml_router/Makefile tools/uml_router/Makefile
82--- tools.orig/uml_router/Makefile 2017-04-03 15:56:02.068461380 +0200
83+++ tools/uml_router/Makefile 2017-04-03 16:00:46.796446867 +0200
84@@ -13,7 +13,7 @@
85 all : $(BIN)
86
87 $(BIN) : $(OBJS)
88- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
89+ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
90
91 clean :
92 rm -f $(BIN) $(OBJS) *~
93diff -uNr tools.orig/watchdog/Makefile tools/watchdog/Makefile
94--- tools.orig/watchdog/Makefile 2017-04-03 15:56:02.068461380 +0200
95+++ tools/watchdog/Makefile 2017-04-03 15:59:45.216450006 +0200
96@@ -7,7 +7,7 @@
97 all : $(BIN)
98
99 $(BIN) : $(OBJS)
100- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
101+ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
102
103 clean :
104 rm -f $(BIN) $(OBJS) *~