summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-19 22:31:51 -0700
committerArmin Kuster <akuster808@gmail.com>2017-08-04 20:54:20 -0700
commit35a020bc87028cbb0014895187dddec6dc39321f (patch)
treed73a2ab51d2462f767f4aab65cb7076de48f5695
parentd40e2dafc5452056563aa2f1c9edf8265063a0b8 (diff)
downloadmeta-openembedded-35a020bc87028cbb0014895187dddec6dc39321f.tar.gz
memstat: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> (cherry picked from commit cafa3a45425108ecbae0ef9324a6228c145fc9f8) Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/memstat/memstat/0001-Include-limits.h-for-PATH_MAX-definition.patch29
-rw-r--r--meta-oe/recipes-devtools/memstat/memstat_1.0.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/memstat/memstat/0001-Include-limits.h-for-PATH_MAX-definition.patch b/meta-oe/recipes-devtools/memstat/memstat/0001-Include-limits.h-for-PATH_MAX-definition.patch
new file mode 100644
index 000000000..9a0a17e0e
--- /dev/null
+++ b/meta-oe/recipes-devtools/memstat/memstat/0001-Include-limits.h-for-PATH_MAX-definition.patch
@@ -0,0 +1,29 @@
1From 4b6c957372314562bf7b9117103e3a08643eb7b8 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sat, 18 Mar 2017 17:47:28 -0700
4Subject: [PATCH] Include limits.h for PATH_MAX definition
5
6Fixes
7
8error: use of undeclared identifier 'PATH_MAX'
9
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11---
12 memstat.c | 1 +
13 1 file changed, 1 insertion(+)
14
15diff --git a/memstat.c b/memstat.c
16index 5039fb0..3ff6ee4 100644
17--- a/memstat.c
18+++ b/memstat.c
19@@ -19,6 +19,7 @@
20 #include <unistd.h>
21 #include <getopt.h>
22 #include <errno.h>
23+#include <limits.h>
24
25 /* blacklist devices that just map physical memory */
26 char *blacklist[] = {
27--
282.12.0
29
diff --git a/meta-oe/recipes-devtools/memstat/memstat_1.0.bb b/meta-oe/recipes-devtools/memstat/memstat_1.0.bb
index 825215372..91a9200c3 100644
--- a/meta-oe/recipes-devtools/memstat/memstat_1.0.bb
+++ b/meta-oe/recipes-devtools/memstat/memstat_1.0.bb
@@ -13,7 +13,8 @@ S = "${WORKDIR}/memstattool"
13LIC_FILES_CHKSUM = "file://debian/copyright;md5=87be186443b1ac2cfa466f475e1ee0cb" 13LIC_FILES_CHKSUM = "file://debian/copyright;md5=87be186443b1ac2cfa466f475e1ee0cb"
14 14
15SRC_URI = "http://sourceforge.net/projects/memstattool/files/memstat_${PV}.tar.gz \ 15SRC_URI = "http://sourceforge.net/projects/memstattool/files/memstat_${PV}.tar.gz \
16 " 16 file://0001-Include-limits.h-for-PATH_MAX-definition.patch \
17 "
17 18
18SRC_URI[md5sum] = "2c3acc0c62b2a18f6601b84e54aa7462" 19SRC_URI[md5sum] = "2c3acc0c62b2a18f6601b84e54aa7462"
19SRC_URI[sha256sum] = "245d5fc7fb87bcfd14486cd34917cae2856e799559ac568434af12c4852bce94" 20SRC_URI[sha256sum] = "245d5fc7fb87bcfd14486cd34917cae2856e799559ac568434af12c4852bce94"