summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2023-11-01 17:27:04 +0000
committerArmin Kuster <akuster808@gmail.com>2023-11-16 21:49:15 -0500
commit644edb8b6a8786f84e50cd7cf955731ec4609c65 (patch)
tree3ffd1db5c6ea3970f8026a208bbb9f572d40a0f3
parentd5d3526d5cd83259528ee702d7a394c5a628a720 (diff)
downloadmeta-openembedded-644edb8b6a8786f84e50cd7cf955731ec4609c65.tar.gz
libssh: upgrade 0.10.4 -> 0.10.5
Changelog: https://git.libssh.org/projects/libssh.git/tag/?h=libssh-0.10.5 * Generate cases list dynamically in run-ptest. * Install missing file to fix ptest failure. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> (cherry picked from commit b0833f1f3ec78f16a79d9ff66cdd19da93496018) Signed-off-by: Yogita Urade <yogita.urade@windriver.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/libssh/libssh/run-ptest42
-rw-r--r--meta-oe/recipes-support/libssh/libssh_0.10.5.bb (renamed from meta-oe/recipes-support/libssh/libssh_0.10.4.bb)5
2 files changed, 7 insertions, 40 deletions
diff --git a/meta-oe/recipes-support/libssh/libssh/run-ptest b/meta-oe/recipes-support/libssh/libssh/run-ptest
index 159994e9b..6346b72d5 100644
--- a/meta-oe/recipes-support/libssh/libssh/run-ptest
+++ b/meta-oe/recipes-support/libssh/libssh/run-ptest
@@ -1,53 +1,17 @@
1#!/bin/sh 1#!/bin/sh
2 2
3# Valid tests to run
4tests="torture_bind_config \
5 torture_buffer \
6 torture_bytearray \
7 torture_callbacks \
8 torture_channel \
9 torture_config \
10 torture_crypto \
11 torture_hashes \
12 torture_init \
13 torture_isipaddr \
14 torture_keyfiles \
15 torture_knownhosts_parsing \
16 torture_list \
17 torture_misc \
18 torture_moduli \
19 torture_options \
20 torture_packet \
21 torture_packet_filter \
22 torture_pki \
23 torture_pki_ecdsa \
24 torture_pki_ed25519 \
25 torture_pki_rsa \
26 torture_push_pop_dir \
27 torture_rand \
28 torture_session_keys \
29 torture_temp_dir \
30 torture_temp_file \
31 torture_threads_buffer \
32 torture_threads_crypto \
33 torture_threads_init \
34 torture_threads_pki_rsa \
35 torture_tokens \
36 "
37
38ptestdir=$(dirname "$(readlink -f "$0")") 3ptestdir=$(dirname "$(readlink -f "$0")")
39cd "$ptestdir"/tests || exit 4cd "$ptestdir"/tests || exit
40 5
41# Run specified tests 6tests=$(find * -type f -name 'torture_*')
7
42for f in $tests 8for f in $tests
43do 9do
44 if test -e ./"$f"; then 10 if test -x ./"$f"; then
45 if ./"$f" > ./"$f".out 2> ./"$f".err; then 11 if ./"$f" > ./"$f".out 2> ./"$f".err; then
46 echo "PASS: $f" 12 echo "PASS: $f"
47 else 13 else
48 echo "FAIL: $f" 14 echo "FAIL: $f"
49 fi 15 fi
50 else
51 echo "SKIP: $f"
52 fi 16 fi
53done 17done
diff --git a/meta-oe/recipes-support/libssh/libssh_0.10.4.bb b/meta-oe/recipes-support/libssh/libssh_0.10.5.bb
index 4b2ced5e5..f33987acf 100644
--- a/meta-oe/recipes-support/libssh/libssh_0.10.4.bb
+++ b/meta-oe/recipes-support/libssh/libssh_0.10.5.bb
@@ -11,7 +11,7 @@ SRC_URI = "git://git.libssh.org/projects/libssh.git;protocol=https;branch=stable
11 file://0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch \ 11 file://0001-libgcrypt.c-Fix-prototype-of-des3_encrypt-des3_decry.patch \
12 file://run-ptest \ 12 file://run-ptest \
13 " 13 "
14SRCREV = "e8322817a9e5aaef0698d779ddd467a209a85d85" 14SRCREV = "479eca13aaaa46b43e68c52186e3783f06ae6f34"
15 15
16S = "${WORKDIR}/git" 16S = "${WORKDIR}/git"
17 17
@@ -34,12 +34,15 @@ EXTRA_OECMAKE = " \
34do_compile:prepend () { 34do_compile:prepend () {
35 if [ ${PTEST_ENABLED} = "1" ]; then 35 if [ ${PTEST_ENABLED} = "1" ]; then
36 sed -i -e 's|${B}|${PTEST_PATH}|g' ${B}/config.h 36 sed -i -e 's|${B}|${PTEST_PATH}|g' ${B}/config.h
37 sed -i -e 's|${S}|${PTEST_PATH}|g' ${B}/config.h
37 fi 38 fi
38} 39}
39 40
40do_install_ptest () { 41do_install_ptest () {
41 install -d ${D}${PTEST_PATH}/tests 42 install -d ${D}${PTEST_PATH}/tests
42 cp -f ${B}/tests/unittests/torture_* ${D}${PTEST_PATH}/tests/ 43 cp -f ${B}/tests/unittests/torture_* ${D}${PTEST_PATH}/tests/
44 install -d ${D}${PTEST_PATH}/tests/unittests
45 cp -f ${S}/tests/unittests/hello*.sh ${D}${PTEST_PATH}/tests/unittests/
43} 46}
44 47
45BBCLASSEXTEND = "native nativesdk" 48BBCLASSEXTEND = "native nativesdk"