summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-09-05 15:02:21 +0200
committerArmin Kuster <akuster808@gmail.com>2023-09-06 08:16:15 -0400
commit2091b63c9d7ab528164c3ba01879108f5fa1d9f2 (patch)
tree70d0e12f05276b9dddd74418033a92f3c214ed71
parent1d67c934ee665711c7ec8d41453d912be65e8faf (diff)
downloadmeta-openembedded-2091b63c9d7ab528164c3ba01879108f5fa1d9f2.tar.gz
libcyusbserial: fix installed-vs-shipped QA issue with multilib
* testing ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR} existence doesn't really work in cross compilation and on some hosts was causing: ERROR: QA Issue: libcyusbserial: Files/directories were installed but not shipped in any package: /usr/lib/libcyusbserial.so.1 /usr/lib/libcyusbserial.so Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. libcyusbserial: 2 installed and not shipped files. [installed-vs-shipped] with multilib using /usr/lib32 or /usr/lib64 when the same didn't exist on host. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-oe/recipes-support/libcyusbserial/libcyusbserial/0001-CMakeLists.txt-don-t-fall-back-CMAKE_INSTALL_LIBDIR-.patch43
-rw-r--r--meta-oe/recipes-support/libcyusbserial/libcyusbserial_git.bb4
2 files changed, 46 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/libcyusbserial/libcyusbserial/0001-CMakeLists.txt-don-t-fall-back-CMAKE_INSTALL_LIBDIR-.patch b/meta-oe/recipes-support/libcyusbserial/libcyusbserial/0001-CMakeLists.txt-don-t-fall-back-CMAKE_INSTALL_LIBDIR-.patch
new file mode 100644
index 000000000..d9e10469d
--- /dev/null
+++ b/meta-oe/recipes-support/libcyusbserial/libcyusbserial/0001-CMakeLists.txt-don-t-fall-back-CMAKE_INSTALL_LIBDIR-.patch
@@ -0,0 +1,43 @@
1From 655c5c32b37a2bea12389ed69c0869215fcf5abe Mon Sep 17 00:00:00 2001
2From: Martin Jansa <Martin.Jansa@gmail.com>
3Date: Sun, 3 Sep 2023 11:22:35 +0200
4Subject: [PATCH] CMakeLists.txt: don't fall back CMAKE_INSTALL_LIBDIR to lib
5
6* testing ${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR} existence
7 doesn't really work in cross compilation and on some hosts was causing:
8
9 ERROR: QA Issue: libcyusbserial: Files/directories were installed but not shipped in any package:
10 /usr/lib/libcyusbserial.so.1
11 /usr/lib/libcyusbserial.so
12 Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install.
13 libcyusbserial: 2 installed and not shipped files. [installed-vs-shipped]
14
15 with multilib using /usr/lib32 or /usr/lib64 when the same didn't
16 exist on host.
17
18Upstream-Status: Pending
19Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
20---
21 lib/CMakeLists.txt | 9 ---------
22 1 file changed, 9 deletions(-)
23
24diff --git a/lib/CMakeLists.txt b/lib/CMakeLists.txt
25index 2b031cb..53a7263 100644
26--- a/lib/CMakeLists.txt
27+++ b/lib/CMakeLists.txt
28@@ -6,15 +6,6 @@ if (NOT CMAKE_INSTALL_LIBDIR)
29 include(GNUInstallDirs)
30 endif (NOT CMAKE_INSTALL_LIBDIR)
31
32-# Fall back to just "lib" if the item provided by GNUInstallDirs doesn't exist
33-# For example, on Ubuntu 13.10 with CMake 2.8.11.2,
34-# /usr/lib/${CMAKE_LIBRARY_ARCHITECTURE} doesn't exist.
35-if (NOT EXISTS "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR}")
36- message(STATUS "${CMAKE_INSTALL_PREFIX}/${CMAKE_INSTALL_LIBDIR} does not exist. Defaulting libcyusbserial install location to ${CMAKE_INSTALL_PREFIX}/lib.")
37- set(CMAKE_INSTALL_LIBDIR lib)
38-endif()
39-
40-
41 ################################################################################
42 # Include paths
43 ################################################################################
diff --git a/meta-oe/recipes-support/libcyusbserial/libcyusbserial_git.bb b/meta-oe/recipes-support/libcyusbserial/libcyusbserial_git.bb
index 81453fb88..a69194996 100644
--- a/meta-oe/recipes-support/libcyusbserial/libcyusbserial_git.bb
+++ b/meta-oe/recipes-support/libcyusbserial/libcyusbserial_git.bb
@@ -8,7 +8,9 @@ DEPENDS = "libusb udev"
8PV = "1.0.0+git${SRCPV}" 8PV = "1.0.0+git${SRCPV}"
9 9
10SRCREV = "655e2d544183d094f0e2d119c7e0c6206a0ddb3f" 10SRCREV = "655e2d544183d094f0e2d119c7e0c6206a0ddb3f"
11SRC_URI = "git://github.com/cyrozap/${BPN}.git;branch=master;protocol=https" 11SRC_URI = "git://github.com/cyrozap/${BPN}.git;branch=master;protocol=https \
12 file://0001-CMakeLists.txt-don-t-fall-back-CMAKE_INSTALL_LIBDIR-.patch \
13"
12 14
13S = "${WORKDIR}/git" 15S = "${WORKDIR}/git"
14 16