diff options
author | Mingli Yu <mingli.yu@windriver.com> | 2022-05-05 17:33:08 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-05-05 10:11:24 -0700 |
commit | f334a009472136b266c4f72612b549846df20c0e (patch) | |
tree | 7384a3bff5daf1f9d767994cfed21a41285702b5 | |
parent | 6c2bd3c0fae072e23f6572d5448fce5e5f4fae08 (diff) | |
download | meta-openembedded-f334a009472136b266c4f72612b549846df20c0e.tar.gz |
s-nail: Set VAL_MTA
Some build server may provide sendmail like /usr/lib/sendmail which
may result the VAL_MTA to be /usr/lib/sendmail during do_configure,
but the sendmail is actually /usr/sbin/sendmail on the target.
Fixes:
# echo "invalide address email" | s-nail -s "test mail" -r test@test.com tester@test.com
s-nail: Cannot start /usr/lib/sendmail: executable not found (adjust *mta* variable)
/home/root/dead.letter 10/234
s-nail: ... message not sent
# which sendmail
/usr/sbin/sendmail
Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch | 48 | ||||
-rw-r--r-- | meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb | 3 |
2 files changed, 50 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch b/meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch new file mode 100644 index 000000000..f4decda14 --- /dev/null +++ b/meta-oe/recipes-extended/s-nail/files/0001-make.rc-set-VAL_MTA.patch | |||
@@ -0,0 +1,48 @@ | |||
1 | From da8c7a027390de7828d4272a3c8bcdbffbac25ad Mon Sep 17 00:00:00 2001 | ||
2 | From: Mingli Yu <mingli.yu@windriver.com> | ||
3 | Date: Thu, 5 May 2022 16:57:48 +0800 | ||
4 | Subject: [PATCH] make.rc: set VAL_MTA | ||
5 | |||
6 | Some build server may provide sendmail like /usr/lib/sendmail which | ||
7 | may result the VAL_MTA to be /usr/lib/sendmail, but the sendmail | ||
8 | is actually /usr/sbin/sendmail on the target. | ||
9 | |||
10 | Fixes: | ||
11 | # echo "invalide address email" | s-nail -s "test mail" -r test@test.com tester@test.com | ||
12 | s-nail: Cannot start /usr/lib/sendmail: executable not found (adjust *mta* variable) | ||
13 | /home/root/dead.letter 10/234 | ||
14 | s-nail: ... message not sent | ||
15 | |||
16 | # which sendmail | ||
17 | /usr/sbin/sendmail | ||
18 | |||
19 | Upstream-Status: Inappropriate[oe-specific] | ||
20 | |||
21 | Signed-off-by: Mingli Yu <mingli.yu@windriver.com> | ||
22 | --- | ||
23 | make.rc | 9 +-------- | ||
24 | 1 file changed, 1 insertion(+), 8 deletions(-) | ||
25 | |||
26 | diff --git a/make.rc b/make.rc | ||
27 | index 98bd968..45ac0d4 100644 | ||
28 | --- a/make.rc | ||
29 | +++ b/make.rc | ||
30 | @@ -96,14 +96,7 @@ VAL_MAIL=`\ | ||
31 | |||
32 | # Path to the local MTA (Mail-Transfer-Agent). | ||
33 | # MTA aliases (aliases(5)) are optionally supported via OPT_MTA_ALIASES. | ||
34 | -VAL_MTA=`\ | ||
35 | - if [ -x /usr/bin/sendmail ]; then \ | ||
36 | - echo /usr/bin/sendmail;\ | ||
37 | - elif [ -x /usr/lib/sendmail ]; then \ | ||
38 | - echo /usr/lib/sendmail;\ | ||
39 | - else \ | ||
40 | - echo /usr/sbin/sendmail;\ | ||
41 | - fi` | ||
42 | +VAL_MTA=/usr/sbin/sendmail | ||
43 | |||
44 | # Today a lot of systems no longer use sendmail(1), but a different MTA. | ||
45 | # To ensure compatibility with sendmail(1), a system called | ||
46 | -- | ||
47 | 2.25.1 | ||
48 | |||
diff --git a/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb b/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb index bc514b577..539f9c3c8 100644 --- a/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb +++ b/meta-oe/recipes-extended/s-nail/s-nail_14.9.24.bb | |||
@@ -6,7 +6,8 @@ LICENSE = "ISC & BSD-3-Clause & BSD-4-Clause" | |||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=87266591c81260f10221f1f38872d023" | 6 | LIC_FILES_CHKSUM = "file://COPYING;md5=87266591c81260f10221f1f38872d023" |
7 | 7 | ||
8 | SRC_URI = "https://ftp.sdaoden.eu/${BP}.tar.xz \ | 8 | SRC_URI = "https://ftp.sdaoden.eu/${BP}.tar.xz \ |
9 | file://make-errors.patch" | 9 | file://make-errors.patch \ |
10 | file://0001-make.rc-set-VAL_MTA.patch" | ||
10 | SRC_URI[sha256sum] = "2714d6b8fb2af3b363fc7c79b76d058753716345d1b6ebcd8870ecd0e4f7ef8c" | 11 | SRC_URI[sha256sum] = "2714d6b8fb2af3b363fc7c79b76d058753716345d1b6ebcd8870ecd0e4f7ef8c" |
11 | 12 | ||
12 | DEPENDS = "coreutils-native" | 13 | DEPENDS = "coreutils-native" |