diff options
author | leimaohui <leimaohui@cn.fujitsu.com> | 2015-07-16 13:32:47 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-07-30 21:26:01 +0200 |
commit | f1a792f69cea7f9e81ca3941e136928954e67782 (patch) | |
tree | 0d22f7588b46e56716005475727754cebfaa3821 | |
parent | f2ead8e30870388a65b3a7ffbd4e5e1a929bdcda (diff) | |
download | meta-openembedded-f1a792f69cea7f9e81ca3941e136928954e67782.tar.gz |
openwsman: add new recipe
Openwsman is an open source implementation of WS-Management; enabling the in-band management of Linux/uni*/Windows platforms.
Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
3 files changed, 94 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/openwsman/openwsman/libssl-is-required-if-eventint-supported.patch b/meta-oe/recipes-extended/openwsman/openwsman/libssl-is-required-if-eventint-supported.patch new file mode 100644 index 000000000..bd540e37c --- /dev/null +++ b/meta-oe/recipes-extended/openwsman/openwsman/libssl-is-required-if-eventint-supported.patch | |||
@@ -0,0 +1,17 @@ | |||
1 | libssl is required by wsman_client_transport if ENABLE_EVENTING_SUPPORT enabled. | ||
2 | |||
3 | Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> | ||
4 | |||
5 | diff -Nurp openwsman-2.4.12.orig/src/lib/CMakeLists.txt openwsman-2.4.12/src/lib/CMakeLists.txt | ||
6 | --- openwsman-2.4.12.orig/src/lib/CMakeLists.txt 2014-10-28 23:04:47.000000000 +0800 | ||
7 | +++ openwsman-2.4.12/src/lib/CMakeLists.txt 2014-12-31 11:09:20.340428523 +0800 | ||
8 | @@ -56,6 +56,9 @@ TARGET_LINK_LIBRARIES( ${WSMAN_CLIENT_TR | ||
9 | SET_TARGET_PROPERTIES( ${WSMAN_CLIENT_TRANSPORT_PKG} PROPERTIES VERSION 1.0.0 SOVERSION 1) | ||
10 | INSTALL(TARGETS ${WSMAN_CLIENT_TRANSPORT_PKG} DESTINATION ${LIB_INSTALL_DIR}) | ||
11 | |||
12 | +IF( ENABLE_EVENTING_SUPPORT ) | ||
13 | +TARGET_LINK_LIBRARIES( ${WSMAN_CLIENT_TRANSPORT_PKG} ${OPENSSL_LIBRARIES} ) | ||
14 | +ENDIF( ENABLE_EVENTING_SUPPORT ) | ||
15 | |||
16 | ############### wsman_client ############### | ||
17 | |||
diff --git a/meta-oe/recipes-extended/openwsman/openwsman/openwsmand.service b/meta-oe/recipes-extended/openwsman/openwsman/openwsmand.service new file mode 100644 index 000000000..154f3cdaf --- /dev/null +++ b/meta-oe/recipes-extended/openwsman/openwsman/openwsmand.service | |||
@@ -0,0 +1,12 @@ | |||
1 | [Unit] | ||
2 | Description=Openwsman WS-Management Service | ||
3 | After=syslog.target | ||
4 | |||
5 | [Service] | ||
6 | Type=forking | ||
7 | ExecStart=@SBINDIR@/openwsmand | ||
8 | ExecStartPre=@SYSCONFDIR@/openwsman/owsmangencert.sh | ||
9 | PIDFile=@LOCALSTATEDIR@/run/wsmand.pid | ||
10 | |||
11 | [Install] | ||
12 | WantedBy=multi-user.target | ||
diff --git a/meta-oe/recipes-extended/openwsman/openwsman_2.6.0.bb b/meta-oe/recipes-extended/openwsman/openwsman_2.6.0.bb new file mode 100644 index 000000000..67cd618ee --- /dev/null +++ b/meta-oe/recipes-extended/openwsman/openwsman_2.6.0.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | SUMMARY = "Opensource Implementation of WS-Management" | ||
2 | DESCRIPTION = "Openwsman is a project intended to provide an open-source \ | ||
3 | implementation of the Web Services Management specipication \ | ||
4 | (WS-Management) and to expose system management information on the \ | ||
5 | Linux operating system using the WS-Management protocol. WS-Management \ | ||
6 | is based on a suite of web services specifications and usage \ | ||
7 | requirements that exposes a set of operations focused on and covers \ | ||
8 | all system management aspects. \ | ||
9 | Openwsman Server and service libraries" | ||
10 | HOMEPAGE = "http://www.openwsman.org/" | ||
11 | SECTION = "Applications/System" | ||
12 | |||
13 | DEPENDS = "curl libxml2 openssl libpam" | ||
14 | |||
15 | SRC_URI = "https://github.com/Openwsman/openwsman/archive/v${PV}.tar.gz \ | ||
16 | file://libssl-is-required-if-eventint-supported.patch \ | ||
17 | file://openwsmand.service" | ||
18 | |||
19 | SRC_URI[md5sum] = "824834a86040b98b03f3fc0f7f62e853" | ||
20 | SRC_URI[sha256sum] = "449b4972dc7700918f8f674047f0a1a9c19eeee3f4ce82f47890dddfa56e823f" | ||
21 | |||
22 | LICENSE = "BSD" | ||
23 | LIC_FILES_CHKSUM = "file://COPYING;md5=d4f53d4c6cf73b9d43186ce3be6dd0ba" | ||
24 | |||
25 | inherit systemd cmake pkgconfig pythonnative perlnative | ||
26 | |||
27 | SYSTEMD_SERVICE_${PN} = "openwsmand.service" | ||
28 | SYSTEMD_AUTO_ENABLE = "disable" | ||
29 | |||
30 | LDFLAGS_append = "${@base_contains('DISTRO_FEATURES', 'ld-is-gold', " -fuse-ld=bfd ", '', d)}" | ||
31 | |||
32 | EXTRA_OECMAKE = "-DBUILD_BINDINGS=NO \ | ||
33 | -DBUILD_LIBCIM=NO \ | ||
34 | -DBUILD_PERL=YES \ | ||
35 | -DCMAKE_INSTALL_PREFIX=${prefix} \ | ||
36 | -DLIB=lib \ | ||
37 | " | ||
38 | |||
39 | do_configure_prepend() { | ||
40 | export HOST_SYS=${HOST_SYS} | ||
41 | export BUILD_SYS=${BUILD_SYS} | ||
42 | export STAGING_INCDIR=${STAGING_INCDIR} | ||
43 | export STAGING_LIBDIR=${STAGING_LIBDIR} | ||
44 | } | ||
45 | |||
46 | do_install_append() { | ||
47 | install -d ${D}/${sysconfdir}/init.d | ||
48 | install -m 755 ${B}/etc/init/openwsmand.sh ${D}/${sysconfdir}/init.d/openwsmand | ||
49 | ln -sf ${sysconfdir}/init.d/openwsmand ${D}/${sbindir}/rcopenwsmand | ||
50 | chmod 755 ${D}/${sysconfdir}/openwsman/owsmangencert.sh | ||
51 | if ${@base_contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
52 | install -d ${D}/${systemd_unitdir}/system | ||
53 | install -m 644 ${WORKDIR}/openwsmand.service ${D}/${systemd_unitdir}/system | ||
54 | |||
55 | sed -i -e 's,@SBINDIR@,${sbindir},g' ${D}${systemd_unitdir}/system/openwsmand.service | ||
56 | sed -i -e 's,@SYSCONFDIR@,${sysconfdir},g' ${D}${systemd_unitdir}/system/openwsmand.service | ||
57 | sed -i -e 's,@LOCALSTATEDIR@,${localstatedir},g' ${D}${systemd_unitdir}/system/openwsmand.service | ||
58 | fi | ||
59 | } | ||
60 | |||
61 | FILES_${PN}-dbg += "${libdir}/openwsman/plugins/.debug/ \ | ||
62 | ${libdir}/openwsman/authenticators/.debug/ \ | ||
63 | " | ||
64 | |||
65 | INSANE_SKIP_${PN} = "dev-so" | ||