summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2024-04-19 17:34:58 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-19 18:20:17 -0700
commiteb30a6b92ba45eae63cd8aefa37dc3961ad5b7bb (patch)
tree55c67f5952d7fcc67ff6d26cf8bb3d0d826bd6fb
parentd607d161bf6cb32c152c7841aeee622e6b92534b (diff)
downloadmeta-openembedded-eb30a6b92ba45eae63cd8aefa37dc3961ad5b7bb.tar.gz
sdbus-c++: Fix build and upgrade to latest git
Fix ptest run while here Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rwxr-xr-xmeta-oe/recipes-core/sdbus-c++/sdbus-c++-1.5.0/run-ptest15
-rwxr-xr-xmeta-oe/recipes-core/sdbus-c++/sdbus-c++/run-ptest6
-rw-r--r--meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.5.0.bb10
3 files changed, 11 insertions, 20 deletions
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.5.0/run-ptest b/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.5.0/run-ptest
deleted file mode 100755
index 2dc6e1eca..000000000
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++-1.5.0/run-ptest
+++ /dev/null
@@ -1,15 +0,0 @@
1#!/bin/sh
2set -e
3set -o pipefail
4
5SCRIPTPATH="$( cd "$(dirname "$0")" ; pwd -P )"
6
7${SCRIPTPATH}/sdbus-c++-unit-tests 2>&1 | \
8sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \
9sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \
10awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}'
11
12${SCRIPTPATH}/sdbus-c++-integration-tests 2>&1 | \
13sed -r 's/^\[\s+OK\s+\] (.*) \([0-9]+\sms\)$/OK: \1 /' | \
14sed -r 's/^\[\s+FAILED\s+\] (.*) \([0-9]+\sms\)$/FAILED: \1 /' | \
15awk '{if ($1 == "OK:" || $1 == "FAILED:") {print $0}}'
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++/run-ptest b/meta-oe/recipes-core/sdbus-c++/sdbus-c++/run-ptest
new file mode 100755
index 000000000..5e285b39e
--- /dev/null
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++/run-ptest
@@ -0,0 +1,6 @@
1#!/bin/sh
2set -e
3
4./sdbus-c++-unit-tests 2>&1 && echo "PASS: sdbus-c++-unit-tests" || echo "FAIL: sdbus-c++-unit-tests"
5
6./sdbus-c++-integration-tests 2>&1 && echo "PASS: sdbus-c++-integration-tests" || echo "FAIL: sdbus-c++-integration-tests"
diff --git a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.5.0.bb b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.5.0.bb
index f52ba141e..5422e08dd 100644
--- a/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.5.0.bb
+++ b/meta-oe/recipes-core/sdbus-c++/sdbus-c++_1.5.0.bb
@@ -12,14 +12,14 @@ PACKAGECONFIG ??= "${@bb.utils.contains('DISTRO_FEATURES', 'systemd', 'with-exte
12 ${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}" 12 ${@bb.utils.contains('PTEST_ENABLED', '1', 'with-tests', '', d)}"
13PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap,basu" 13PACKAGECONFIG[with-builtin-libsystemd] = ",,sdbus-c++-libsystemd,libcap,basu"
14PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd" 14PACKAGECONFIG[with-external-libsystemd] = ",,systemd,libsystemd"
15PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DTESTS_INSTALL_PATH=${PTEST_PATH},-DBUILD_TESTS=OFF,googletest gmock" 15PACKAGECONFIG[with-tests] = "-DBUILD_TESTS=ON -DINSTALL_TESTS=ON -DTESTS_INSTALL_PATH=${PTEST_PATH},-DBUILD_TESTS=OFF,googletest gmock"
16 16
17DEPENDS += "expat" 17DEPENDS += "expat"
18 18
19SRCREV = "30d9f1d46258c2be4ce29b7f7f168ecdf6d4f328" 19PV .= "+git"
20 20SRCREV = "334fcb8833afb298270531dde369135e4b5b88fd"
21SRC_URI = "git://github.com/Kistler-Group/sdbus-cpp.git;protocol=https;branch=master" 21SRC_URI = "git://github.com/Kistler-Group/sdbus-cpp.git;protocol=https;branch=master \
22SRC_URI += "file://run-ptest" 22 file://run-ptest"
23 23
24EXTRA_OECMAKE = "-DBUILD_CODE_GEN=OFF \ 24EXTRA_OECMAKE = "-DBUILD_CODE_GEN=OFF \
25 -DBUILD_DOC=ON \ 25 -DBUILD_DOC=ON \