diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-02-24 13:25:09 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-03-01 11:06:09 -0800 |
commit | eae89d17bf771a57b53cc3259c5252bbc385403c (patch) | |
tree | 918b191d99c8721de9dcd3fc80c870ded2bd59aa | |
parent | 41b266a9a5cb5ff4560a9cd3b74b64968d0989e3 (diff) | |
download | meta-openembedded-eae89d17bf771a57b53cc3259c5252bbc385403c.tar.gz |
python3-pandas: Upgrade 1.2.1 -> 1.2.2
Upgrade to release 1.2.2:
- Fixed regression in read_excel() that caused it to raise
AttributeError when checking version of older xlrd versions
- Fixed regression in DataFrame constructor reordering element
when construction from datetime ndarray with dtype not
"datetime64[ns]"
- Fixed regression in DataFrame.astype() and Series.astype()
not casting to bytes dtype
- Fixed regression in to_pickle() failing to create bz2/xz
compressed pickle files with protocol=5
- Fixed regression in pandas.testing.assert_series_equal() and
pandas.testing.assert_frame_equal() always raising
AssertionError when comparing extension dtypes
- Fixed regression in to_csv() opening codecs.StreamWriter in
binary mode instead of in text mode and ignoring user-provided
mode
- Fixed regression in Categorical.astype() casting to incorrect
dtype when np.int32 is passed to dtype argument
- Fixed regression in to_excel() creating corrupt files when
appending (mode="a") to an existing file
- Fixed regression in DataFrame.transform() failing in case of an
empty DataFrame or Series
- Fixed regression in groupby() or resample() when aggregating an
all-NaN or numeric object dtype column
- Fixed regression in Rolling.count() where the min_periods
argument would be set to 0 after the operation
- Fixed regression in read_excel() that incorrectly raised when
the argument io was a non-path and non-buffer and the engine
argument was specified
- pandas.read_excel() error message when a specified sheetname
does not exist is now uniform across engines
- Fixed bug in pandas.read_excel() producing incorrect results
when the engine openpyxl is used and the excel file is missing
or has incorrect dimension information; the fix requires
openpyxl >= 3.0.0, prior versions may still fail
- Fixed bug in pandas.read_excel() sometimes producing a DataFrame
with trailing rows of np.nan when the engine openpyxl is used
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-pandas_1.2.2.bb (renamed from meta-python/recipes-devtools/python/python3-pandas_1.2.1.bb) | 2 |
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pandas_1.2.1.bb b/meta-python/recipes-devtools/python/python3-pandas_1.2.2.bb index ae8a55f84..752923786 100644 --- a/meta-python/recipes-devtools/python/python3-pandas_1.2.1.bb +++ b/meta-python/recipes-devtools/python/python3-pandas_1.2.2.bb | |||
@@ -6,7 +6,7 @@ HOMEPAGE = "http://pandas.pydata.org/" | |||
6 | LICENSE = "BSD-3-Clause" | 6 | LICENSE = "BSD-3-Clause" |
7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c2a8f987b2ce77c368c6b3e1b5b10774" | 7 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c2a8f987b2ce77c368c6b3e1b5b10774" |
8 | 8 | ||
9 | SRC_URI[sha256sum] = "5527c5475d955c0bc9689c56865aaa2a7b13c504d6c44f0aadbf57b565af5ebd" | 9 | SRC_URI[sha256sum] = "14ed84b463e9b84c8ff9308a79b04bf591ae3122a376ee0f62c68a1bd917a773" |
10 | 10 | ||
11 | inherit pypi setuptools3 | 11 | inherit pypi setuptools3 |
12 | 12 | ||