diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-08-28 13:11:06 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-08-28 23:57:15 -0700 |
commit | dd8ceca71e96a12de6ea65339bf51fe9db6fdc2d (patch) | |
tree | fb084309e0e160d30250b514f42118d1be8c7b89 | |
parent | 87797529033f11cf20e983506c1ab25a62483b82 (diff) | |
download | meta-openembedded-dd8ceca71e96a12de6ea65339bf51fe9db6fdc2d.tar.gz |
mongodb: Fix boost build with clang-15
Signed-off-by: Khem Raj <raj.khem@gmail.com>
2 files changed, 41 insertions, 0 deletions
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch new file mode 100644 index 000000000..4594bec81 --- /dev/null +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb/0001-The-std-lib-unary-binary_function-base-classes-are-d.patch | |||
@@ -0,0 +1,40 @@ | |||
1 | From f9b55f5a1fab85bf73c95e6372779d6f50f75e84 Mon Sep 17 00:00:00 2001 | ||
2 | From: jzmaddock <john@johnmaddock.co.uk> | ||
3 | Date: Mon, 11 Jul 2022 18:26:07 +0100 | ||
4 | Subject: [PATCH] The std lib unary/binary_function base classes are | ||
5 | deprecated/removed from libcpp15. Fixes | ||
6 | https://github.com/boostorg/container_hash/issues/24. | ||
7 | |||
8 | Upstream-Status: Backport [https://github.com/boostorg/config/pull/440/commits/f0af4a9184457939b89110795ae2d293582c5f66] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | src/third_party/boost-1.70.0/boost/config/stdlib/libcpp.hpp | 9 +++++++++ | ||
12 | 1 file changed, 9 insertions(+) | ||
13 | |||
14 | --- a/src/third_party/boost-1.70.0/boost/config/stdlib/libcpp.hpp | ||
15 | +++ b/src/third_party/boost-1.70.0/boost/config/stdlib/libcpp.hpp | ||
16 | @@ -140,4 +140,13 @@ | ||
17 | # define BOOST_NO_CXX14_HDR_SHARED_MUTEX | ||
18 | #endif | ||
19 | |||
20 | +#if _LIBCPP_VERSION >= 15000 | ||
21 | +// | ||
22 | +// Unary function is now deprecated in C++11 and later: | ||
23 | +// | ||
24 | +#if __cplusplus >= 201103L | ||
25 | +#define BOOST_NO_CXX98_FUNCTION_BASE | ||
26 | +#endif | ||
27 | +#endif | ||
28 | + | ||
29 | // --- end --- | ||
30 | --- a/src/third_party/boost-1.70.0/boost/container_hash/hash.hpp | ||
31 | +++ b/src/third_party/boost-1.70.0/boost/container_hash/hash.hpp | ||
32 | @@ -118,7 +118,7 @@ namespace boost | ||
33 | { | ||
34 | namespace hash_detail | ||
35 | { | ||
36 | -#if defined(_HAS_AUTO_PTR_ETC) && !_HAS_AUTO_PTR_ETC | ||
37 | +#if defined(BOOST_NO_CXX98_FUNCTION_BASE) | ||
38 | template <typename T> | ||
39 | struct hash_base | ||
40 | { | ||
diff --git a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb index ff4a16e9f..d040ab160 100644 --- a/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb +++ b/meta-oe/dynamic-layers/meta-python/recipes-dbs/mongodb/mongodb_git.bb | |||
@@ -32,6 +32,7 @@ SRC_URI = "git://github.com/mongodb/mongo.git;branch=v4.4;protocol=https \ | |||
32 | file://PTHREAD_STACK_MIN.patch \ | 32 | file://PTHREAD_STACK_MIN.patch \ |
33 | file://0001-add-explict-static_cast-size_t-to-maxMemoryUsageByte.patch \ | 33 | file://0001-add-explict-static_cast-size_t-to-maxMemoryUsageByte.patch \ |
34 | file://0001-server-Adjust-the-cache-alignment-assumptions.patch \ | 34 | file://0001-server-Adjust-the-cache-alignment-assumptions.patch \ |
35 | file://0001-The-std-lib-unary-binary_function-base-classes-are-d.patch \ | ||
35 | " | 36 | " |
36 | SRC_URI:append:libc-musl ="\ | 37 | SRC_URI:append:libc-musl ="\ |
37 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ | 38 | file://0001-Mark-one-of-strerror_r-implementation-glibc-specific.patch \ |