summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPerceval Arenou <perceval.arenou@gmail.com>2024-04-19 14:37:27 -0700
committerKhem Raj <raj.khem@gmail.com>2024-04-19 14:39:03 -0700
commitd607d161bf6cb32c152c7841aeee622e6b92534b (patch)
tree4272b8606ef6c178a72f06712bfa502a879ca1e1
parentb5ebed99e2185fd8deb1fa347983083f988ef7cd (diff)
downloadmeta-openembedded-d607d161bf6cb32c152c7841aeee622e6b92534b.tar.gz
aravis: new recipe
aravis is a vision library for genicam based cameras. aravis project allows to stream from genicam and GigE cameras Signed-off-by: Perceval Arenou <perceval.arenou@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-multimedia/recipes-multimedia/aravis/aravis_0.8.31.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-multimedia/recipes-multimedia/aravis/aravis_0.8.31.bb b/meta-multimedia/recipes-multimedia/aravis/aravis_0.8.31.bb
new file mode 100644
index 000000000..b5d7772e7
--- /dev/null
+++ b/meta-multimedia/recipes-multimedia/aravis/aravis_0.8.31.bb
@@ -0,0 +1,40 @@
1SUMMARY = "A vision library for genicam based cameras"
2DESCRIPTION = "\
3 Aravis is a glib/gobject based library for video acquisition using Genicam cameras.\
4 It currently implements the gigabit ethernet and USB3 protocols used by industrial cameras.\
5 It also provides a basic ethernet camera simulator and a simple video viewer.\
6"
7AUTHOR = "Emmanuel Pacaud"
8HOMEPAGE = "https://github.com/AravisProject/aravis"
9LICENSE = "LGPL-2.1"
10LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
11
12DEPENDS += "\
13 glib-2.0 \
14 glib-2.0-native \
15 libxml2 \
16 zlib \
17"
18
19SRC_URI = "https://github.com/AravisProject/aravis/releases/download/${PV}/${BPN}-${PV}.tar.xz"
20SRC_URI[sha256sum] = "9c4ebe6273ed3abe466cb6ed8fa5c132bdd7e9a9298ca43fa0212c4311a084da"
21
22EXTRA_OEMESON += "-Dtests=false"
23
24GIR_MESON_ENABLE_FLAG = 'enabled'
25GIR_MESON_DISABLE_FLAG = 'disabled'
26GIDOCGEN_MESON_OPTION = "documentation"
27GIDOCGEN_MESON_ENABLE_FLAG = "enabled"
28GIDOCGEN_MESON_DISABLE_FLAG = "disabled"
29
30inherit meson pkgconfig gi-docgen gobject-introspection
31
32PACKAGECONFIG ?= "gstreamer usb viewer"
33PACKAGECONFIG[gstreamer] = "-Dgst-plugin=enabled, -Dgst-plugin=disabled,gstreamer1.0 gstreamer1.0-plugins-base,"
34PACKAGECONFIG[usb] = "-Dusb=enabled, -Dusb=disabled, libusb1,"
35PACKAGECONFIG[viewer] = "-Dviewer=enabled, -Dviewer=disabled, gtk+3 gstreamer1.0-plugins-base,"
36
37FILES:${PN} += "\
38 ${datadir} \
39 ${libdir}/gstreamer-1.0/libgstaravis.0.8.so \
40"