diff options
author | Romain Naour <romain.naour@smile.fr> | 2024-02-21 14:29:14 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-02-21 19:59:52 -0800 |
commit | ce1410179841a814d4485454ae975d4cc97230a8 (patch) | |
tree | 9503820bdc8118d19d7809e7b74e42183e625dc5 | |
parent | e2792568a08e802187ca9875f54695f3395c0181 (diff) | |
download | meta-openembedded-ce1410179841a814d4485454ae975d4cc97230a8.tar.gz |
wavemon: add recipe for version 0.9.5
wavemon is an ncurses-based monitoring application for wireless network
devices on Linux.
We have to provide the path to libnl3 headers since the build system is
not able to find them.
In order to workaround a link issue with pthread library, we have to
add -pthread to CFLAGS in order to add the library after the object
file.
arm-none-linux-gnueabihf/bin/ld: info_scr.o: undefined reference to symbol 'pthread_mutex_trylock@@GLIBC_2.4'
[...]/wavemon/0.9.5-r0/recipe-sysroot/lib/libpthread.so.0: error adding symbols: DSO missing from command line
"We should mention the library on the command line after the object files being compiled" [1]
[1] https://stackoverflow.com/questions/19901934/libpthread-so-0-error-adding-symbols-dso-missing-from-command-line
Signed-off-by: Romain Naour <romain.naour@smile.fr>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r-- | meta-networking/recipes-support/wavemon/wavemon_0.9.5.bb | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/wavemon/wavemon_0.9.5.bb b/meta-networking/recipes-support/wavemon/wavemon_0.9.5.bb new file mode 100644 index 000000000..9da43cf9f --- /dev/null +++ b/meta-networking/recipes-support/wavemon/wavemon_0.9.5.bb | |||
@@ -0,0 +1,28 @@ | |||
1 | SUMMARY = "wavemon is a wireless device monitoring application" | ||
2 | HOMEPAGE = "https://github.com/uoaerg/wavemon" | ||
3 | DESCRIPTION = "wavemon is a wireless device monitoring application that \ | ||
4 | allows you to watch signal and noise levels, packet \ | ||
5 | statistics, device configuration and network parameters of \ | ||
6 | your wireless network hardware." | ||
7 | |||
8 | LICENSE = "GPL-3.0-or-later" | ||
9 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1ebbd3e34237af26da5dc08a4e440464" | ||
10 | |||
11 | PACKAGECONFIG ??= "cap" | ||
12 | PACKAGECONFIG[cap] = "--with-libcap,--without-libcap,libcap" | ||
13 | |||
14 | DEPENDS = "libnl ncurses" | ||
15 | |||
16 | SRC_URI = "git://github.com/uoaerg/wavemon;branch=master;protocol=https" | ||
17 | SRCREV = "a7c2f190e010db508ead31fa952478e2a1c13d64" | ||
18 | |||
19 | # Needs some help to find libnl3 headers. | ||
20 | # Reorder -pthread flag on the command line. | ||
21 | EXTRA_OEMAKE = "\ | ||
22 | CC='${CC}' CFLAGS='${CFLAGS} -pthread -I${STAGING_INCDIR}/libnl3' \ | ||
23 | " | ||
24 | |||
25 | S = "${WORKDIR}/git" | ||
26 | |||
27 | # wavemon does not support using out-of-tree builds | ||
28 | inherit autotools-brokensep pkgconfig | ||