summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:15:03 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:32 -0800
commitc96ff70bd6aa8fbf462d4da0603ec667d1967064 (patch)
tree844079280f8469c834bbf801acd1364b05d22116
parent3e1caf55ef798c802019a419cd01c2307c077ab3 (diff)
downloadmeta-openembedded-c96ff70bd6aa8fbf462d4da0603ec667d1967064.tar.gz
python3-u-msgpack-python: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb5
2 files changed, 4 insertions, 3 deletions
diff --git a/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest b/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest
index 7110f6bc4..8d2017d39 100644
--- a/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-u-msgpack-python/run-ptest
@@ -1,3 +1,3 @@
1#!/bin/sh 1#!/bin/sh
2 2
3pytest -o log_cli=true -o log_cli_level=INFO test_umsgpack.py| sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' 3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb
index 8baedcb95..6cde243fe 100644
--- a/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb
+++ b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.8.0.bb
@@ -12,7 +12,8 @@ SRC_URI += " \
12" 12"
13 13
14RDEPENDS:${PN}-ptest += " \ 14RDEPENDS:${PN}-ptest += " \
15 ${PYTHON_PN}-pytest \ 15 python3-pytest \
16 python3-unittest-automake-output \
16" 17"
17 18
18do_install_ptest() { 19do_install_ptest() {
@@ -20,7 +21,7 @@ do_install_ptest() {
20} 21}
21 22
22RDEPENDS:${PN} += " \ 23RDEPENDS:${PN} += " \
23 ${PYTHON_PN}-datetime \ 24 python3-datetime \
24" 25"
25 26
26BBCLASSEXTEND = "native nativesdk" 27BBCLASSEXTEND = "native nativesdk"