summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikko Rapeli <mikko.rapeli@bmw.de>2019-08-14 15:55:27 +0300
committerKhem Raj <raj.khem@gmail.com>2019-08-14 16:05:00 -0700
commitc95842cdca36bc2a7f62e5e995dfd1ca44e37e52 (patch)
tree125f331a6c0f6252285ea28b91414053bc7c02ff
parentd21d509b9f643371e9717a9a2c73607126d6029e (diff)
downloadmeta-openembedded-c95842cdca36bc2a7f62e5e995dfd1ca44e37e52.tar.gz
stress-ng: delete recipe
stress-ng is now available from poky directly. Signed-off-by: Mikko Rapeli <mikko.rapeli@bmw.de> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng/0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch31
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng/0001-Several-changes-to-fix-musl-build.patch132
-rw-r--r--meta-oe/recipes-test/stress-ng/stress-ng_0.09.45.bb26
3 files changed, 0 insertions, 189 deletions
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng/0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch b/meta-oe/recipes-test/stress-ng/stress-ng/0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch
deleted file mode 100644
index 469791d8e..000000000
--- a/meta-oe/recipes-test/stress-ng/stress-ng/0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From 7c97710bfc44d895b7111bef9c55866f00a3589c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Mon, 13 Aug 2018 11:54:27 -0700
4Subject: [PATCH] Revert "Makefile: force sync after build in case reboot loses
5 executable"
6
7This reverts commit ae6322b1baea56a589207c96e358daae8edd0a8f.
8
9Not needed for cross-builds
10
11Upstream-Status: Inappropriate [Cross compile specific]
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 Makefile | 1 -
15 1 file changed, 1 deletion(-)
16
17diff --git a/Makefile b/Makefile
18index c0db72c0..5781dda6 100644
19--- a/Makefile
20+++ b/Makefile
21@@ -348,7 +348,6 @@ endif
22 stress-ng: $(OBJS)
23 @echo "LD $@"
24 @$(CC) $(CPPFLAGS) $(CFLAGS) $(OBJS) -lm $(LDFLAGS) -o $@
25- @sync
26
27 makeconfig:
28 @if [ ! -s config ]; then \
29--
302.17.0
31
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng/0001-Several-changes-to-fix-musl-build.patch b/meta-oe/recipes-test/stress-ng/stress-ng/0001-Several-changes-to-fix-musl-build.patch
deleted file mode 100644
index c0b344901..000000000
--- a/meta-oe/recipes-test/stress-ng/stress-ng/0001-Several-changes-to-fix-musl-build.patch
+++ /dev/null
@@ -1,132 +0,0 @@
1From 9bcb4e170f01dbe0a9e7bf6b899c5d9b5283d4c6 Mon Sep 17 00:00:00 2001
2From: Randy MacLeod <Randy.MacLeod@windriver.com>
3Date: Sun, 11 Nov 2018 23:00:53 -0500
4Subject: [PATCH] Several changes to fix musl build
5MIME-Version: 1.0
6Content-Type: text/plain; charset=UTF-8
7Content-Transfer-Encoding: 8bit
8
9Rebased patch for:
10
11stress-{context, stackmmap}.c: Set tests to non-implemented because uses
12swapcontext, musl provide the definition but not the implementation due
13 to that functions are pre-POSIX and set to be deprecated.
14 stress-{resources, pty}.c: Doesn't include termio.h and remove stress
15 operations that uses struct termio, musl doesn't provide that struct.
16stress-malloc.c: Check for definition of M_MMAP_THRESHOLD musl doesn't
17 ptovide that constant.
18stress-madvise.c: Add static poision_count integer, definition of
19 MADV_SOFT_OFFLINE doesn't grauntee MADV_HWPOISON to be defined.
20cache.c: Define GLOB_ONLYDIR not available on MUSL.
21
22Signed-off-by: Aníbal Limón <anibal.limon@linaro.org>
23Signed-off-by: Tim Orling <timothy.t.orling@linux.intel.com>
24Signed-off-by: Randy MacLeod <Randy.MacLeod@windriver.com>
25
26Upstream-status: Pending
27---
28 cache.c | 4 ++++
29 stress-madvise.c | 1 +
30 stress-pty.c | 18 ------------------
31 stress-resources.c | 1 -
32 stress-stackmmap.c | 2 +-
33 5 files changed, 6 insertions(+), 20 deletions(-)
34
35diff --git a/cache.c b/cache.c
36index e8a0f791..4c7bb486 100644
37--- a/cache.c
38+++ b/cache.c
39@@ -28,6 +28,10 @@ typedef struct {
40
41 #include <glob.h>
42
43+#ifndef GLOB_ONLYDIR
44+#define GLOB_ONLYDIR 0x100
45+#endif
46+
47 #if defined(__linux__)
48 #define SYS_CPU_PREFIX "/sys/devices/system/cpu"
49 #define GLOB_PATTERN SYS_CPU_PREFIX "/cpu[0-9]*"
50diff --git a/stress-madvise.c b/stress-madvise.c
51index b2e3497f..77e43a91 100644
52--- a/stress-madvise.c
53+++ b/stress-madvise.c
54@@ -146,6 +146,7 @@ static int stress_random_advise(const args_t *args)
55 #if defined(MADV_SOFT_OFFLINE)
56 if (advise == MADV_SOFT_OFFLINE) {
57 static int soft_offline_count;
58+ static int poison_count;
59
60 /* ..and minimize number of soft offline pages */
61 if ((soft_offline_count >= NUM_SOFT_OFFLINE_MAX) ||
62diff --git a/stress-pty.c b/stress-pty.c
63index 4dd88ab9..c79a7021 100644
64--- a/stress-pty.c
65+++ b/stress-pty.c
66@@ -26,7 +26,6 @@
67
68 #if defined(__linux__)
69
70-#include <termio.h>
71 #include <termios.h>
72
73 typedef struct {
74@@ -111,7 +110,6 @@ static int stress_pty(const args_t *args)
75 */
76 for (i = 0; i < n; i++) {
77 struct termios ios;
78- struct termio io;
79 struct winsize ws;
80 int arg;
81
82@@ -133,22 +131,6 @@ static int stress_pty(const args_t *args)
83 if (ioctl(ptys[i].slave, TCSETSF, &ios) < 0)
84 pr_fail_err("ioctl TCSETSF on slave pty");
85 #endif
86-#if defined(TCGETA)
87- if (ioctl(ptys[i].slave, TCGETA, &io) < 0)
88- pr_fail_err("ioctl TCGETA on slave pty");
89-#endif
90-#if defined(TCSETA)
91- if (ioctl(ptys[i].slave, TCSETA, &io) < 0)
92- pr_fail_err("ioctl TCSETA on slave pty");
93-#endif
94-#if defined(TCSETAW)
95- if (ioctl(ptys[i].slave, TCSETAW, &io) < 0)
96- pr_fail_err("ioctl TCSETAW on slave pty");
97-#endif
98-#if defined(TCSETAF)
99- if (ioctl(ptys[i].slave, TCSETAF, &io) < 0)
100- pr_fail_err("ioctl TCSETAF on slave pty");
101-#endif
102 #if defined(TIOCGLCKTRMIOS)
103 if (ioctl(ptys[i].slave, TIOCGLCKTRMIOS, &ios) < 0)
104 pr_fail_err("ioctl TIOCGLCKTRMIOS on slave pty");
105diff --git a/stress-resources.c b/stress-resources.c
106index f3dcfb38..86f9a5ba 100644
107--- a/stress-resources.c
108+++ b/stress-resources.c
109@@ -28,7 +28,6 @@
110 #include <sys/inotify.h>
111 #endif
112 #if defined(__linux__)
113-#include <termio.h>
114 #include <termios.h>
115 #endif
116 #if defined(HAVE_LIB_PTHREAD) && defined(__linux__)
117diff --git a/stress-stackmmap.c b/stress-stackmmap.c
118index c2f4c31d..54308777 100644
119--- a/stress-stackmmap.c
120+++ b/stress-stackmmap.c
121@@ -24,7 +24,7 @@
122 */
123 #include "stress-ng.h"
124
125-#if defined(__linux__)
126+#if defined(__linux__) && False
127
128 #include <ucontext.h>
129
130--
1312.17.0
132
diff --git a/meta-oe/recipes-test/stress-ng/stress-ng_0.09.45.bb b/meta-oe/recipes-test/stress-ng/stress-ng_0.09.45.bb
deleted file mode 100644
index 3e8f2d4f5..000000000
--- a/meta-oe/recipes-test/stress-ng/stress-ng_0.09.45.bb
+++ /dev/null
@@ -1,26 +0,0 @@
1SUMMARY = "A tool to load and stress a computer system"
2HOMEPAGE = "http://kernel.ubuntu.com/~cking/stress-ng/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5
6DEPENDS = "zlib libaio"
7
8SRC_URI = "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/${BP}.tar.xz \
9 file://0001-Revert-Makefile-force-sync-after-build-in-case-reboo.patch \
10 "
11SRC_URI_append_libc-musl = " \
12 file://0001-Several-changes-to-fix-musl-build.patch \
13 "
14
15SRC_URI[md5sum] = "b03744c2eb68bf7e9a300e78e397f348"
16SRC_URI[sha256sum] = "0741e3004bf590bb7af3db979a46fe89bee7aaad6065cd1d87d0b7fa49046cb2"
17
18UPSTREAM_CHECK_URI ?= "http://kernel.ubuntu.com/~cking/tarballs/${BPN}/"
19UPSTREAM_CHECK_REGEX ?= "(?P<pver>\d+(\.\d+)+)\.tar"
20
21CFLAGS += "-Wall -Wextra -DVERSION='"$(VERSION)"'"
22
23do_install_append() {
24 install -d ${D}${bindir}
25 install -m 755 ${S}/stress-ng ${D}${bindir}/stress-ng
26}