diff options
author | Bian Naimeng <biannm@cn.fujitsu.com> | 2015-07-02 09:49:19 +0800 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2015-07-16 21:09:10 +0200 |
commit | c37028884de83c4ad5d0bab85f33f232c400d306 (patch) | |
tree | 9c4923171c8dfd3e6a16bfb525dbbd7918165ea5 | |
parent | 85b77d67cd37ddd755782158d058416607852edc (diff) | |
download | meta-openembedded-c37028884de83c4ad5d0bab85f33f232c400d306.tar.gz |
sysdig: add new recipe
sysdig is a tool for system-level exploration and troubleshooting
Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-extended/sysdig/sysdig/01-donot-set-default-value-to-va_list.patch | 22 | ||||
-rw-r--r-- | meta-oe/recipes-extended/sysdig/sysdig_0.1.101.bb | 34 |
2 files changed, 56 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/sysdig/sysdig/01-donot-set-default-value-to-va_list.patch b/meta-oe/recipes-extended/sysdig/sysdig/01-donot-set-default-value-to-va_list.patch new file mode 100644 index 000000000..9cb6378af --- /dev/null +++ b/meta-oe/recipes-extended/sysdig/sysdig/01-donot-set-default-value-to-va_list.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | fix build error as following. | ||
2 | |||
3 | sysdig-0.1.101/userspace/libsinsp/ctext.h:376:50: error: could not convert '0' from 'int' to 'va_list {aka __va_list}' | ||
4 | | int8_t vprintf(const char*format, va_list ap = 0); | ||
5 | | ^ | ||
6 | | make[2]: *** [userspace/libsinsp/CMakeFiles/sinsp.dir/ctext.cpp.o] Error 1 | ||
7 | |||
8 | |||
9 | Signed-off-by: Bian Naimeng <biannm@cn.fujitsu.com> | ||
10 | |||
11 | diff -Nurp sysdig-0.1.101.orig/userspace/libsinsp/ctext.h sysdig-0.1.101/userspace/libsinsp/ctext.h | ||
12 | --- sysdig-0.1.101.orig/userspace/libsinsp/ctext.h 2015-06-04 02:58:51.000000000 +0800 | ||
13 | +++ sysdig-0.1.101/userspace/libsinsp/ctext.h 2015-07-02 09:18:14.154627357 +0800 | ||
14 | @@ -373,7 +373,7 @@ class ctext | ||
15 | // application to this library seamlessly. | ||
16 | // | ||
17 | int8_t printf(const char*format, ...); | ||
18 | - int8_t vprintf(const char*format, va_list ap = 0); | ||
19 | + int8_t vprintf(const char*format, va_list ap); | ||
20 | |||
21 | // | ||
22 | // nprintf is identical to the printf above EXCEPT for | ||
diff --git a/meta-oe/recipes-extended/sysdig/sysdig_0.1.101.bb b/meta-oe/recipes-extended/sysdig/sysdig_0.1.101.bb new file mode 100644 index 000000000..789fd4790 --- /dev/null +++ b/meta-oe/recipes-extended/sysdig/sysdig_0.1.101.bb | |||
@@ -0,0 +1,34 @@ | |||
1 | SUMMARY = "A New System Troubleshooting Tool Built for the Way You Work" | ||
2 | DESCRIPTION = "Sysdig is open source, system-level exploration: capture \ | ||
3 | system state and activity from a running Linux instance, then save, \ | ||
4 | filter and analyze." | ||
5 | HOMEPAGE = "http://www.sysdig.org/" | ||
6 | LICENSE = "GPLv2" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263" | ||
8 | |||
9 | inherit cmake pkgconfig | ||
10 | |||
11 | DEPENDS = "luajit zlib ncurses" | ||
12 | RDEPENDS_${PN} = "bash" | ||
13 | |||
14 | |||
15 | SRC_URI = "https://github.com/draios/sysdig/archive/${PV}.tar.gz \ | ||
16 | file://01-donot-set-default-value-to-va_list.patch \ | ||
17 | " | ||
18 | |||
19 | SRC_URI[md5sum] = "5fe96a3a0fd98b2157a40cb29af41afc" | ||
20 | SRC_URI[sha256sum] = "6995e39be565514901b5cb587689ee2efbf8359293e4e597362382cccf0e9db6" | ||
21 | |||
22 | DIR_ETC="/etc" | ||
23 | EXTRA_OECMAKE = ' -DUSE_BUNDLED_LUAJIT="OFF" \ | ||
24 | -DUSE_BUNDLED_ZLIB="OFF" \ | ||
25 | -DBUILD_DRIVER="OFF" \ | ||
26 | -DUSE_BUNDLED_NCURSES="OFF" \ | ||
27 | -DDIR_ETC="${DIR_ETC}" \ | ||
28 | ' | ||
29 | |||
30 | FILES_${PN} += " \ | ||
31 | ${DIR_ETC}/* \ | ||
32 | ${datadir}/zsh/* \ | ||
33 | ${prefix}/src/* \ | ||
34 | " | ||