summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2017-11-29 15:17:16 -0500
committerArmin Kuster <akuster808@gmail.com>2017-12-11 07:58:57 -0800
commitbb497805f07f192118a280bdaa9ea44a26caae76 (patch)
tree2be2f1d2ece429609488a58bbb71c2955f5fb4a3
parent7e1e62d682448b2e276ec5b9c74627bdaa5a9503 (diff)
downloadmeta-openembedded-bb497805f07f192118a280bdaa9ea44a26caae76.tar.gz
pyrtm: break samples and unit tests into separate packages
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/pyrtm_0.4.2.bb21
1 files changed, 20 insertions, 1 deletions
diff --git a/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb b/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
index 72f0921e7..2272da91a 100644
--- a/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
+++ b/meta-python/recipes-devtools/python/pyrtm_0.4.2.bb
@@ -10,7 +10,26 @@ SRC_URI[sha256sum] = "b2d701b25ad3f9a1542057f3eb492c5c1d7dbe2b8d1e8f763043dcc14e
10 10
11inherit pypi setuptools 11inherit pypi setuptools
12 12
13PACKAGES =+ "${PN}-tests ${PN}-samples"
14
15FILES_${PN}-samples += " \
16 ${PYTHON_SITEPACKAGES_DIR}/rtm/samples \
17"
18
19FILES_${PN}-tests += " \
20 ${PYTHON_SITEPACKAGES_DIR}/rtm/tests \
21"
22
13RDEPENDS_${PN} += "\ 23RDEPENDS_${PN} += "\
14 ${PYTHON_PN}-json \ 24 ${PYTHON_PN}-json \
15 ${PYTHON_PN}-netclient \ 25 ${PYTHON_PN}-netclient \
16 " 26"
27
28RDEPENDS_${PN}-samples += " \
29 ${PN} \
30"
31
32RDEPENDS_${PN}-tests += " \
33 ${PN} \
34 ${PYTHON_PN}-unittest \
35"