summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-12 10:41:39 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commitb865cada4e887ea4e6875b3a4684f76c9f2760ac (patch)
tree7002579a59704cdd0eee0454e430429d77ff12b4
parent7b4643bea077559711420461149162e29ce4a3c1 (diff)
downloadmeta-openembedded-b865cada4e887ea4e6875b3a4684f76c9f2760ac.tar.gz
python3-decouple: new package
Add a recipe for python-decouple: generic tool for separating settings from code. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-decouple_3.6.bb16
2 files changed, 17 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index 5f97bd954..922a08af5 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -92,6 +92,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
92 python3-dbus-next \ 92 python3-dbus-next \
93 python3-dbussy \ 93 python3-dbussy \
94 python3-decorator \ 94 python3-decorator \
95 python3-decouple \
95 python3-defusedxml \ 96 python3-defusedxml \
96 python3-dill \ 97 python3-dill \
97 python3-diskcache \ 98 python3-diskcache \
diff --git a/meta-python/recipes-devtools/python/python3-decouple_3.6.bb b/meta-python/recipes-devtools/python/python3-decouple_3.6.bb
new file mode 100644
index 000000000..772ee7faf
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-decouple_3.6.bb
@@ -0,0 +1,16 @@
1SUMMARY = "Strict separation of settings from code."
2HOMEPAGE = "https://github.com/henriquebastos/python-decouple/"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=a46375b26bb7d7603565d829a2a51782"
6
7SRC_URI[sha256sum] = "2838cdf77a5cf127d7e8b339ce14c25bceb3af3e674e039d4901ba16359968c7"
8
9PYPI_PACKAGE = "python-decouple"
10
11inherit pypi setuptools3
12
13RDEPENDS:${PN} += " \
14 python3-shell \
15 python3-stringold \
16"