diff options
author | Khem Raj <raj.khem@gmail.com> | 2022-03-02 11:15:04 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-03-03 08:48:07 -0800 |
commit | b08d16afa2f5043ccbe5b8f8a20c6b22300b521e (patch) | |
tree | 074e26a54c5dcf14e02265ef127c86997f84e0fa | |
parent | 33bb50423460024166c8cf23f636cede55e3b596 (diff) | |
download | meta-openembedded-b08d16afa2f5043ccbe5b8f8a20c6b22300b521e.tar.gz |
python3-aws-iot-device-sdk-python: Upgrade to 1.5.0
Use github to fetch it since its not yet available on pypi
Port to use setuptools
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r-- | meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python/0001-setup.py-Use-setuptools-instead-of-distutils.patch | 29 | ||||
-rw-r--r-- | meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.5.0.bb (renamed from meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.9.bb) | 8 |
2 files changed, 35 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python/0001-setup.py-Use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python/0001-setup.py-Use-setuptools-instead-of-distutils.patch new file mode 100644 index 000000000..9bc8b36f3 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python/0001-setup.py-Use-setuptools-instead-of-distutils.patch | |||
@@ -0,0 +1,29 @@ | |||
1 | From 36f8106535150b970c75e8b8456ebc5a7d1dbdb3 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 2 Mar 2022 11:11:01 -0800 | ||
4 | Subject: [PATCH] setup.py: Use setuptools instead of distutils | ||
5 | |||
6 | distutils is deprecated and will be gone in 3.12+ | ||
7 | |||
8 | Upstream-Status: Submitted [https://github.com/aws/aws-iot-device-sdk-python/pull/305] | ||
9 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
10 | --- | ||
11 | setup.py | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 3846bae..d0c2b8d 100644 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -3,7 +3,7 @@ sys.path.insert(0, 'AWSIoTPythonSDK') | ||
19 | import AWSIoTPythonSDK | ||
20 | currentVersion = AWSIoTPythonSDK.__version__ | ||
21 | |||
22 | -from distutils.core import setup | ||
23 | +from setuptools import setup | ||
24 | setup( | ||
25 | name = 'AWSIoTPythonSDK', | ||
26 | packages=['AWSIoTPythonSDK', 'AWSIoTPythonSDK.core', | ||
27 | -- | ||
28 | 2.35.1 | ||
29 | |||
diff --git a/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.9.bb b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.5.0.bb index 27f37fec4..2f877487a 100644 --- a/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.4.9.bb +++ b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.5.0.bb | |||
@@ -6,10 +6,14 @@ LIC_FILES_CHKSUM = "\ | |||
6 | file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \ | 6 | file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \ |
7 | file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \ | 7 | file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \ |
8 | " | 8 | " |
9 | SRCREV = "90d7b05749e2da7a13193024c720e3c8d9bf1157" | ||
10 | SRC_URI = "git://github.com/aws/aws-iot-device-sdk-python;branch=master;protocol=https \ | ||
11 | file://0001-setup.py-Use-setuptools-instead-of-distutils.patch \ | ||
12 | " | ||
9 | 13 | ||
10 | SRC_URI[sha256sum] = "84b440c5929f33da1cd204f3ad0ea891e208637dd63de9fb039ed7d49d78c303" | 14 | S = "${WORKDIR}/git" |
11 | 15 | ||
12 | inherit pypi setuptools3 | 16 | inherit setuptools3 |
13 | 17 | ||
14 | PYPI_PACKAGE = "AWSIoTPythonSDK" | 18 | PYPI_PACKAGE = "AWSIoTPythonSDK" |
15 | 19 | ||