summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-16 19:52:13 -0700
committerKhem Raj <raj.khem@gmail.com>2022-03-17 08:18:31 -0700
commitae90b1f2172d9a3c4cc270295eb1122cc9431642 (patch)
treed9203d7e09fcbae58c75cab9f50d7feb0c074bba
parenta6569c76039f249c1547696f7b68d2ed813c505a (diff)
downloadmeta-openembedded-ae90b1f2172d9a3c4cc270295eb1122cc9431642.tar.gz
php: Fix build on rv32/musl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-devtools/php/php_8.1.3.bb11
1 files changed, 6 insertions, 5 deletions
diff --git a/meta-oe/recipes-devtools/php/php_8.1.3.bb b/meta-oe/recipes-devtools/php/php_8.1.3.bb
index bfe4d270d..8086bac55 100644
--- a/meta-oe/recipes-devtools/php/php_8.1.3.bb
+++ b/meta-oe/recipes-devtools/php/php_8.1.3.bb
@@ -7,6 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=99532e0f6620bc9bca34f12fadaee33c"
7 7
8BBCLASSEXTEND = "native" 8BBCLASSEXTEND = "native"
9DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native" 9DEPENDS = "zlib bzip2 libxml2 virtual/libiconv php-native lemon-native"
10DEPENDS:append:libc-musl = " libucontext"
10DEPENDS:class-native = "zlib-native libxml2-native" 11DEPENDS:class-native = "zlib-native libxml2-native"
11 12
12PHP_MAJOR_VERSION = "${@d.getVar('PV').split('.')[0]}" 13PHP_MAJOR_VERSION = "${@d.getVar('PV').split('.')[0]}"
@@ -66,6 +67,10 @@ EXTRA_OECONF = "--enable-mbstring \
66 67
67EXTRA_OECONF:append:riscv64 = " --with-pcre-jit=no" 68EXTRA_OECONF:append:riscv64 = " --with-pcre-jit=no"
68EXTRA_OECONF:append:riscv32 = " --with-pcre-jit=no" 69EXTRA_OECONF:append:riscv32 = " --with-pcre-jit=no"
70# Needs fibers assembly implemented for rv32
71# for example rv64 implementation is below
72# see https://github.com/php/php-src/commit/70b02d75f2abe3a292d49c4a4e9e4f850c2fee68
73EXTRA_OECONF:append:riscv32:libc-musl = " --disable-fiber-asm"
69 74
70CACHED_CONFIGUREVARS += "ac_cv_func_dlopen=no ac_cv_lib_dl_dlopen=yes" 75CACHED_CONFIGUREVARS += "ac_cv_func_dlopen=no ac_cv_lib_dl_dlopen=yes"
71 76
@@ -116,6 +121,7 @@ CFLAGS += " -D_GNU_SOURCE -g -DPTYS_ARE_GETPT -DPTYS_ARE_SEARCHED -I${STAGING_IN
116# See https://bugs.php.net/bug.php?id=60109 121# See https://bugs.php.net/bug.php?id=60109
117CFLAGS += " -DHAVE_LIBDL " 122CFLAGS += " -DHAVE_LIBDL "
118LDFLAGS += " -ldl " 123LDFLAGS += " -ldl "
124LDFLAGS:append:libc-musl = " -lucontext "
119 125
120EXTRA_OEMAKE = "INSTALL_ROOT=${D}" 126EXTRA_OEMAKE = "INSTALL_ROOT=${D}"
121 127
@@ -272,8 +278,3 @@ do_install:append:class-native() {
272# | {standard input}:3797: Error: unshifted register required -- `sub r2,r2,r0,asr#31' 278# | {standard input}:3797: Error: unshifted register required -- `sub r2,r2,r0,asr#31'
273# | make: *** [ext/standard/math.lo] Error 1 279# | make: *** [ext/standard/math.lo] Error 1
274ARM_INSTRUCTION_SET = "arm" 280ARM_INSTRUCTION_SET = "arm"
275
276# Needs fibers assembly implemented for rv32
277# for example rv64 implementation is below
278# see https://github.com/php/php-src/commit/70b02d75f2abe3a292d49c4a4e9e4f850c2fee68
279COMPATIBLE_HOST:libc-musl:riscv32 = "null"