summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-12 10:41:50 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-14 08:17:25 -0700
commita8915808b19080f64a5000d0f167eab0e18752ed (patch)
tree46a0986e26c3ed8cd0f590b54ce80019498b5aff
parente5b828d01b4f5d748e92614c5adaed551e1e220a (diff)
downloadmeta-openembedded-a8915808b19080f64a5000d0f167eab0e18752ed.tar.gz
python3-eth-account: new package
Add a recipe for python3-eth-account: a tool for signing Ethereum transactions and messages with local private keys. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-eth-account_0.6.1.bb18
2 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index db3f8516a..da83aab48 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -111,6 +111,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
111 python3-engineio \ 111 python3-engineio \
112 python3-et-xmlfile \ 112 python3-et-xmlfile \
113 python3-eth-abi \ 113 python3-eth-abi \
114 python3-eth-account \
114 python3-eth-hash \ 115 python3-eth-hash \
115 python3-eth-keyfile \ 116 python3-eth-keyfile \
116 python3-eth-keys \ 117 python3-eth-keys \
diff --git a/meta-python/recipes-devtools/python/python3-eth-account_0.6.1.bb b/meta-python/recipes-devtools/python/python3-eth-account_0.6.1.bb
new file mode 100644
index 000000000..9c87d3f5d
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-eth-account_0.6.1.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Assign Ethereum transactions and messages with local private keys."
2HOMEPAGE = "https://github.com/ethereum/eth-account"
3SECTION = "devel/python"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE;md5=287820ad3553117aa2f92bf84c219324"
6
7SRC_URI[sha256sum] = "54b0b7d661e73f4cd12d508c9baa5c9a6e8c194aa7bafc39277cd673683ae50e"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-bitarray \
13 python3-cytoolz \
14 python3-eth-abi \
15 python3-eth-keyfile \
16 python3-eth-rlp \
17 python3-hexbytes \
18"