summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2020-01-02 14:34:04 +0100
committerKhem Raj <raj.khem@gmail.com>2020-01-02 09:48:20 -0800
commita793e8aea3d2aedb9aaf94e6fdcd68648235ddf2 (patch)
treef13be8ebe02d27b9348818ab86f5a87f05a43d7a
parent7d7ad054e8210940e7292322208e5c294e516d40 (diff)
downloadmeta-openembedded-a793e8aea3d2aedb9aaf94e6fdcd68648235ddf2.tar.gz
libfile-slurper-perl: add recipe
Since File::Slurp is broken since ages and File::Slurp::Tiny discouraged for some years, newer perl5 module distributions often rely on File::Slurper. Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-perl/recipes-perl/libfile/libfile-slurper-perl_0.012.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-perl/recipes-perl/libfile/libfile-slurper-perl_0.012.bb b/meta-perl/recipes-perl/libfile/libfile-slurper-perl_0.012.bb
new file mode 100644
index 000000000..b684abd4b
--- /dev/null
+++ b/meta-perl/recipes-perl/libfile/libfile-slurper-perl_0.012.bb
@@ -0,0 +1,36 @@
1SUMMARY = "A simple, sane and efficient module to slurp a file"
2DESCRIPTION = "This module provides functions for fast and correct slurping and spewing. \
3All functions are optionally exported. All functions throw exceptions on \
4errors, write functions don't return any meaningful value."
5
6SECTION = "libs"
7LICENSE = "Artistic-1.0 | GPL-1.0+"
8
9HOMEPAGE= "https://metacpan.org/release/File-Slurper"
10
11LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Artistic-1.0;md5=cda03bbdc3c1951996392b872397b798 \
12file://${COMMON_LICENSE_DIR}/GPL-1.0;md5=e9e36a9de734199567a4d769498f743d"
13
14SRC_URI = "${CPAN_MIRROR}/authors/id/L/LE/LEONT/File-Slurper-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "5742c63096392dfee50b8db314bcca18"
17SRC_URI[sha256sum] = "4efb2ea416b110a1bda6f8133549cc6ea3676402e3caf7529fce0313250aa578"
18RDEPENDS_${PN} = " \
19 perl-module-carp \
20 perl-module-encode \
21 perl-module-exporter \
22 perl-module-perlio \
23 perl-module-perlio-encoding \
24 perl-module-strict \
25 perl-module-warnings \
26"
27
28RDEPENDS_${PN}-ptest += "libtest-warnings-perl \
29 perl-module-test-more \
30 "
31
32S = "${WORKDIR}/File-Slurper-${PV}"
33
34inherit cpan allarch ptest-perl
35
36BBCLASSEXTEND = "native"