diff options
author | alperak <alperyasinak1@gmail.com> | 2024-03-08 08:51:34 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-03-08 10:07:29 -0800 |
commit | a5fd08e401cbfe835206cc3305cb0ce954671aa3 (patch) | |
tree | f2aca3b032cb771bc06edbe8d6f370f8e93767b5 | |
parent | 8cf55e279fd08f71f281fc8e5f2dabd638d3fa79 (diff) | |
download | meta-openembedded-a5fd08e401cbfe835206cc3305cb0ce954671aa3.tar.gz |
python3-pytest-localserver: added recipe which is also include ptest
pytest-localserver is a plugin for the pytest testing framework which enables you to test server connections locally.
* Tested on qemux86-64 and qemuarm64
* Add ptest into PTESTS_SLOW_META_PYTHON
Ptest result:
==============
qemux86-64:
Testsuite summary
TOTAL: 55
PASS: 54
SKIP: 1
XFAIL: 0
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 44
END: /usr/lib/python3-pytest-localserver/ptest
2024-03-07T20:33
STOP: ptest-runner
TOTAL: 1 FAIL: 0
qemuarm64:
Testsuite summary
TOTAL: 55
PASS: 54
SKIP: 1
XFAIL: 0
FAIL: 0
XPASS: 0
ERROR: 0
DURATION: 38
END: /usr/lib/python3-pytest-localserver/ptest
2024-03-07T20:41
STOP: ptest-runner
TOTAL: 1 FAIL: 0
Signed-off-by: alperak <alperyasinak1@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
3 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/conf/include/ptest-packagelists-meta-python.inc b/meta-python/conf/include/ptest-packagelists-meta-python.inc index 20ca2763c..ce5ccf22d 100644 --- a/meta-python/conf/include/ptest-packagelists-meta-python.inc +++ b/meta-python/conf/include/ptest-packagelists-meta-python.inc | |||
@@ -80,6 +80,7 @@ PTESTS_SLOW_META_PYTHON = "\ | |||
80 | python3-arrow \ | 80 | python3-arrow \ |
81 | python3-lz4 \ | 81 | python3-lz4 \ |
82 | python3-marshmallow \ | 82 | python3-marshmallow \ |
83 | python3-pytest-localserver \ | ||
83 | python3-traitlets \ | 84 | python3-traitlets \ |
84 | python3-yappi \ | 85 | python3-yappi \ |
85 | " | 86 | " |
diff --git a/meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest b/meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest new file mode 100644 index 000000000..8d2017d39 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytest-localserver/run-ptest | |||
@@ -0,0 +1,3 @@ | |||
1 | #!/bin/sh | ||
2 | |||
3 | pytest --automake | ||
diff --git a/meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb b/meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb new file mode 100644 index 000000000..669817829 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-pytest-localserver_0.8.1.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | SUMMARY = "pytest plugin to test server connections locally." | ||
2 | HOMEPAGE = "https://github.com/pytest-dev/pytest-localserver" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=b8da7a541d738b054dcbf70c31530432" | ||
5 | |||
6 | DEPENDS += "python3-setuptools-scm-native" | ||
7 | |||
8 | inherit pypi python_setuptools_build_meta ptest | ||
9 | |||
10 | SRC_URI[sha256sum] = "66569c34fef31a5750b16effd1cd1288a7a90b59155d005e7f916accd3dee4f1" | ||
11 | |||
12 | SRC_URI += " \ | ||
13 | file://run-ptest \ | ||
14 | " | ||
15 | |||
16 | RDEPENDS:${PN}-ptest += " \ | ||
17 | python3-pytest \ | ||
18 | python3-requests \ | ||
19 | python3-unittest-automake-output \ | ||
20 | " | ||
21 | |||
22 | do_install_ptest() { | ||
23 | install -d ${D}${PTEST_PATH}/tests | ||
24 | cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/ | ||
25 | } | ||
26 | |||
27 | RDEPENDS:${PN} += " \ | ||
28 | python3-werkzeug \ | ||
29 | " | ||