summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-04-17 09:41:00 +0800
committerKhem Raj <raj.khem@gmail.com>2024-04-17 23:47:29 -0700
commita0ac2f52909d8515150f051a5780a6c573ebc9b7 (patch)
tree2df4e24a296f5d1eed6cdd315b976b3c5d8588de
parentaf3d9fe2915b44ed7177fadc2a5f372c4c07e2e9 (diff)
downloadmeta-openembedded-a0ac2f52909d8515150f051a5780a6c573ebc9b7.tar.gz
webkitgtk3: upgrade 2.44.0 -> 2.44.1
2922af379dc70b4b1a63b01d67179eb431f03ac4.patch removed since it's included in 2.44.1 Changelog: ========== - Fix handling of lifetime of web view child dialogs in GTK4. - Do not schedule layer flushes when drawing area size is empty. - Fix videos with alpha when using the DMA-BUF sink. - Fix the build with USE_GBM=OFF. - Fix the build in 32bit platforms - Fix several crashes and rendering issues. Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/webkitgtk/webkitgtk3/2922af379dc70b4b1a63b01d67179eb431f03ac4.patch36
-rw-r--r--meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.1.bb (renamed from meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.0.bb)3
2 files changed, 1 insertions, 38 deletions
diff --git a/meta-oe/recipes-support/webkitgtk/webkitgtk3/2922af379dc70b4b1a63b01d67179eb431f03ac4.patch b/meta-oe/recipes-support/webkitgtk/webkitgtk3/2922af379dc70b4b1a63b01d67179eb431f03ac4.patch
deleted file mode 100644
index 0f6b9a633..000000000
--- a/meta-oe/recipes-support/webkitgtk/webkitgtk3/2922af379dc70b4b1a63b01d67179eb431f03ac4.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From 2922af379dc70b4b1a63b01d67179eb431f03ac4 Mon Sep 17 00:00:00 2001
2From: Michael Catanzaro <mcatanzaro@redhat.com>
3Date: Mon, 18 Mar 2024 11:14:54 -0700
4Subject: [PATCH] REGRESSION(274077@main): failure to build on i586 (and likely
5 other 32bit arches): static assertion failed: Timer should stay small
6 https://bugs.webkit.org/show_bug.cgi?id=271108
7
8Unreviewed build fix. This changes SameSizeOfTimer to ensure it matches
9the size of Timer on 32-bit platforms.
10
11* Source/WebCore/platform/Timer.cpp:
12
13Canonical link: https://commits.webkit.org/276282@main
14
15Upstream-Status: Backport [https://github.com/WebKit/WebKit/commit/2922af379dc70b4b1a63b01d67179eb431f03ac4]
16---
17 Source/WebCore/platform/Timer.cpp | 6 +++++-
18 1 file changed, 5 insertions(+), 1 deletion(-)
19
20diff --git a/Source/WebCore/platform/Timer.cpp b/Source/WebCore/platform/Timer.cpp
21index 4f7c0f5c39ca9..0f3734cca2474 100644
22--- a/Source/WebCore/platform/Timer.cpp
23+++ b/Source/WebCore/platform/Timer.cpp
24@@ -263,7 +263,11 @@ struct SameSizeAsTimer {
25
26 WeakPtr<TimerAlignment> timerAlignment;
27 double times[2];
28- void* pointers[3];
29+ void* pointers[2];
30+#if CPU(ADDRESS32)
31+ uint8_t bitfields;
32+#endif
33+ void* pointer;
34 };
35
36 static_assert(sizeof(Timer) == sizeof(SameSizeAsTimer), "Timer should stay small");
diff --git a/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.0.bb b/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.1.bb
index 34afaed9d..fc96d5dc3 100644
--- a/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.0.bb
+++ b/meta-oe/recipes-support/webkitgtk/webkitgtk3_2.44.1.bb
@@ -15,9 +15,8 @@ SRC_URI = "https://www.webkitgtk.org/releases/webkitgtk-${PV}.tar.xz \
15 file://no-musttail-arm.patch \ 15 file://no-musttail-arm.patch \
16 file://0001-LowLevelInterpreter.cpp-339-21-error-t6-was-not-decl.patch \ 16 file://0001-LowLevelInterpreter.cpp-339-21-error-t6-was-not-decl.patch \
17 file://30e1d5e22213fdaca2a29ec3400c927d710a37a8.patch \ 17 file://30e1d5e22213fdaca2a29ec3400c927d710a37a8.patch \
18 file://2922af379dc70b4b1a63b01d67179eb431f03ac4.patch \
19 " 18 "
20SRC_URI[sha256sum] = "c66530e41ba59b1edba4ee89ef20b2188e273bed0497e95084729e3cfbe30c87" 19SRC_URI[sha256sum] = "425b1459b0f04d0600c78d1abb5e7edfa3c060a420f8b231e9a6a2d5d29c5561"
21 20
22inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gi-docgen 21inherit cmake pkgconfig gobject-introspection perlnative features_check upstream-version-is-even gi-docgen
23 22