summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBartosz Golaszewski <brgl@bgdev.pl>2022-05-16 14:45:53 +0200
committerKhem Raj <raj.khem@gmail.com>2022-05-16 09:09:47 -0700
commit9de3008c5a2f2f919e87ed97adea063edc19be82 (patch)
tree7330397691d8220325bac383f7e8e3c66bafd7de
parent72fbb8379fc47ec77cdcb1c15e992d99d205ced2 (diff)
downloadmeta-openembedded-9de3008c5a2f2f919e87ed97adea063edc19be82.tar.gz
python3-inotify: new package
We have a recipe for python3-pyinotify (not to be confused with the recently added python3-pyfanotify) but this project has been abandoned years ago. There's another - still maintained - project called simply inotify on pypi and this adds the recipe for it. Signed-off-by: Bartosz Golaszewski <brgl@bgdev.pl> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb1
-rw-r--r--meta-python/recipes-devtools/python/python3-inotify_0.2.10.bb14
2 files changed, 15 insertions, 0 deletions
diff --git a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
index d08908939..6ca652e12 100644
--- a/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
+++ b/meta-python/recipes-core/packagegroups/packagegroup-meta-python.bb
@@ -186,6 +186,7 @@ RDEPENDS:packagegroup-meta-python3 = "\
186 python3-imgtool \ 186 python3-imgtool \
187 python3-incremental \ 187 python3-incremental \
188 python3-inflection \ 188 python3-inflection \
189 python3-inotify \
189 python3-intelhex \ 190 python3-intelhex \
190 python3-intervals \ 191 python3-intervals \
191 python3-ipaddress \ 192 python3-ipaddress \
diff --git a/meta-python/recipes-devtools/python/python3-inotify_0.2.10.bb b/meta-python/recipes-devtools/python/python3-inotify_0.2.10.bb
new file mode 100644
index 000000000..524c3a0d2
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-inotify_0.2.10.bb
@@ -0,0 +1,14 @@
1SUMMARY = "An adapter to Linux kernel support for inotify directory-watching."
2AUTHOR = "Dustin Oprea"
3HOMEPAGE = "https://pypi.org/project/inotify/"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://setup.py;md5=79b7ec72aa0d446a552d3cceb5799e41;beginline=28;endline=28"
6
7SRC_URI[sha256sum] = "974a623a338482b62e16d4eb705fb863ed33ec178680fc3e96ccdf0df6c02a07"
8
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-ctypes \
13 python3-logging \
14"