diff options
author | Paul Barker <paul@paulbarker.me.uk> | 2016-10-22 21:20:09 +0100 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2016-10-26 10:28:40 +0200 |
commit | 9af1859ed13e6bfde4e0aaa8e13f3c77dd1ef900 (patch) | |
tree | 98dea8783cc704cf0a18d291a58610f08321e50b | |
parent | b09611969a2a2ab9efbbade402b44241b448918e (diff) | |
download | meta-openembedded-9af1859ed13e6bfde4e0aaa8e13f3c77dd1ef900.tar.gz |
vim: Update to v8.0.0022
v8.0.0022 is currently used in Debian Testing.
In the license file (uganda.txt) only the version number has changed.
The new version installs icons for gvim into /usr/share/icons. For now these are
just placed in the vim-common package as they use only a kB or so.
Signed-off-by: Paul Barker <paul@paulbarker.me.uk>
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r-- | meta-oe/recipes-support/vim/files/0001-patch-7.4.1733.patch | 169 | ||||
-rw-r--r-- | meta-oe/recipes-support/vim/vim-tiny_8.0.0022.bb (renamed from meta-oe/recipes-support/vim/vim-tiny_7.4.1689.bb) | 0 | ||||
-rw-r--r-- | meta-oe/recipes-support/vim/vim_8.0.0022.bb (renamed from meta-oe/recipes-support/vim/vim_7.4.1689.bb) | 6 |
3 files changed, 3 insertions, 172 deletions
diff --git a/meta-oe/recipes-support/vim/files/0001-patch-7.4.1733.patch b/meta-oe/recipes-support/vim/files/0001-patch-7.4.1733.patch deleted file mode 100644 index 98cf62906..000000000 --- a/meta-oe/recipes-support/vim/files/0001-patch-7.4.1733.patch +++ /dev/null | |||
@@ -1,169 +0,0 @@ | |||
1 | From ff1f017e5ab049557896655535e7d79663f89262 Mon Sep 17 00:00:00 2001 | ||
2 | From: Bram Moolenaar <Bram@vim.org> | ||
3 | Date: Thu, 14 Apr 2016 16:46:02 +0200 | ||
4 | Subject: [PATCH] patch 7.4.1733 | ||
5 | |||
6 | Problem: "make install" doesn't know about cross-compiling. (Christian | ||
7 | Neukirchen) | ||
8 | Solution: Add CROSS_COMPILING. (closes #740) | ||
9 | |||
10 | Signed-off-by: Paul Barker <paul@paulbarker.me.uk> | ||
11 | Upstream-status: Backport | ||
12 | --- | ||
13 | src/Makefile | 19 +++++++++++++++---- | ||
14 | src/auto/configure | 4 ++++ | ||
15 | src/config.mk.in | 1 + | ||
16 | src/configure.in | 3 +++ | ||
17 | src/version.c | 2 ++ | ||
18 | 5 files changed, 25 insertions(+), 4 deletions(-) | ||
19 | |||
20 | diff --git a/src/Makefile b/src/Makefile | ||
21 | index cf9636d..195cbd5 100644 | ||
22 | --- a/src/Makefile | ||
23 | +++ b/src/Makefile | ||
24 | @@ -1998,23 +1998,25 @@ test1 \ | ||
25 | test70 test71 test72 test73 test74 test75 test76 test77 test78 test79 \ | ||
26 | test80 test81 test82 test83 test84 test85 test86 test87 test88 test89 \ | ||
27 | test90 test91 test92 test93 test94 test95 test97 test98 test99 \ | ||
28 | - test100 test101 test102 test103 test104 test105 test107 test108: | ||
29 | + test100 test101 test102 test103 test104 test107 test108: | ||
30 | cd testdir; rm -f $@.out; $(MAKE) -f Makefile $@.out VIMPROG=../$(VIMTARGET) $(GUI_TESTARG) SCRIPTSOURCE=../$(SCRIPTSOURCE) | ||
31 | |||
32 | # Run individual NEW style test, assuming that Vim was already compiled. | ||
33 | test_arglist \ | ||
34 | test_assert \ | ||
35 | test_assign \ | ||
36 | + test_autocmd \ | ||
37 | test_backspace_opt \ | ||
38 | test_cdo \ | ||
39 | test_channel \ | ||
40 | test_cursor_func \ | ||
41 | test_delete \ | ||
42 | test_ex_undo \ | ||
43 | - test_expr \ | ||
44 | test_expand \ | ||
45 | + test_expr \ | ||
46 | test_feedkeys \ | ||
47 | test_file_perm \ | ||
48 | + test_fnamemodify \ | ||
49 | test_glob2regpat \ | ||
50 | test_hardcopy \ | ||
51 | test_help_tagjump \ | ||
52 | @@ -2024,17 +2026,22 @@ test_arglist \ | ||
53 | test_json \ | ||
54 | test_langmap \ | ||
55 | test_lispwords \ | ||
56 | + test_matchstrpos \ | ||
57 | test_menu \ | ||
58 | test_packadd \ | ||
59 | test_partial \ | ||
60 | test_perl \ | ||
61 | test_quickfix \ | ||
62 | + test_regexp_latin \ | ||
63 | + test_regexp_utf8 \ | ||
64 | test_reltime \ | ||
65 | test_searchpos \ | ||
66 | test_set \ | ||
67 | test_sort \ | ||
68 | + test_statusline \ | ||
69 | test_syn_attr \ | ||
70 | test_syntax \ | ||
71 | + test_tabline \ | ||
72 | test_timers \ | ||
73 | test_undolevels \ | ||
74 | test_unlet \ | ||
75 | @@ -2042,6 +2049,8 @@ test_arglist \ | ||
76 | test_viml \ | ||
77 | test_visual \ | ||
78 | test_window_id \ | ||
79 | + test_alot_latin \ | ||
80 | + test_alot_utf8 \ | ||
81 | test_alot: | ||
82 | cd testdir; rm -f $@.res test.log messages; $(MAKE) -f Makefile $@.res VIMPROG=../$(VIMTARGET) $(GUI_TESTARG) SCRIPTSOURCE=../$(SCRIPTSOURCE) | ||
83 | @if test -f testdir/test.log; then \ | ||
84 | @@ -2126,9 +2135,11 @@ installrtbase: $(HELPSOURCE)/vim.1 $(DEST_VIM) $(DEST_RT) \ | ||
85 | # Generate the help tags with ":helptags" to handle all languages. | ||
86 | # Move the distributed tags file aside and restore it, to avoid it being | ||
87 | # different from the repository. | ||
88 | - cd $(HELPSOURCE); if test -f tags; then mv -f tags tags.dist; fi | ||
89 | + cd $(HELPSOURCE); if test -z "$(CROSS_COMPILING)" -a -f tags; then \ | ||
90 | + mv -f tags tags.dist; fi | ||
91 | @echo generating help tags | ||
92 | - -@cd $(HELPSOURCE); $(MAKE) VIMEXE=$(DEST_BIN)/$(VIMTARGET) vimtags | ||
93 | + -@cd $(HELPSOURCE); if test -z "$(CROSS_COMPILING)"; then \ | ||
94 | + $(MAKE) VIMEXE=$(DEST_BIN)/$(VIMTARGET) vimtags; fi | ||
95 | cd $(HELPSOURCE); \ | ||
96 | files=`ls *.txt tags`; \ | ||
97 | files="$$files `ls *.??x tags-?? 2>/dev/null || true`"; \ | ||
98 | diff --git a/src/auto/configure b/src/auto/configure | ||
99 | index a708230..91b075d 100755 | ||
100 | --- a/src/auto/configure | ||
101 | +++ b/src/auto/configure | ||
102 | @@ -721,6 +721,7 @@ OS_EXTRA_OBJ | ||
103 | OS_EXTRA_SRC | ||
104 | XCODE_SELECT | ||
105 | CPP_MM | ||
106 | +CROSS_COMPILING | ||
107 | STRIP | ||
108 | AWK | ||
109 | FGREP | ||
110 | @@ -4113,11 +4114,14 @@ else | ||
111 | $as_echo "no" >&6; } | ||
112 | fi | ||
113 | |||
114 | +CROSS_COMPILING= | ||
115 | if test "$cross_compiling" = yes; then | ||
116 | { $as_echo "$as_me:${as_lineno-$LINENO}: result: cannot compile a simple program; if not cross compiling check CC and CFLAGS" >&5 | ||
117 | $as_echo "cannot compile a simple program; if not cross compiling check CC and CFLAGS" >&6; } | ||
118 | + CROSS_COMPILING=1 | ||
119 | fi | ||
120 | |||
121 | + | ||
122 | test "$GCC" = yes && CPP_MM=M; | ||
123 | |||
124 | if test -f ./toolcheck; then | ||
125 | diff --git a/src/config.mk.in b/src/config.mk.in | ||
126 | index 7c0726c..1002d7c 100644 | ||
127 | --- a/src/config.mk.in | ||
128 | +++ b/src/config.mk.in | ||
129 | @@ -104,6 +104,7 @@ AWK = @AWK@ | ||
130 | STRIP = @STRIP@ | ||
131 | |||
132 | EXEEXT = @EXEEXT@ | ||
133 | +CROSS_COMPILING = @CROSS_COMPILING@ | ||
134 | |||
135 | COMPILEDBY = @compiledby@ | ||
136 | |||
137 | diff --git a/src/configure.in b/src/configure.in | ||
138 | index f29b62c..0a8c95b 100644 | ||
139 | --- a/src/configure.in | ||
140 | +++ b/src/configure.in | ||
141 | @@ -88,9 +88,12 @@ fi | ||
142 | |||
143 | dnl If configure thinks we are cross compiling, there might be something | ||
144 | dnl wrong with the CC or CFLAGS settings, give a useful warning message | ||
145 | +CROSS_COMPILING= | ||
146 | if test "$cross_compiling" = yes; then | ||
147 | AC_MSG_RESULT([cannot compile a simple program; if not cross compiling check CC and CFLAGS]) | ||
148 | + CROSS_COMPILING=1 | ||
149 | fi | ||
150 | +AC_SUBST(CROSS_COMPILING) | ||
151 | |||
152 | dnl gcc-cpp has the wonderful -MM option to produce nicer dependencies. | ||
153 | dnl But gcc 3.1 changed the meaning! See near the end. | ||
154 | diff --git a/src/version.c b/src/version.c | ||
155 | index 8d32e2a..f0630ea 100644 | ||
156 | --- a/src/version.c | ||
157 | +++ b/src/version.c | ||
158 | @@ -749,6 +749,8 @@ static char *(features[]) = | ||
159 | static int included_patches[] = | ||
160 | { /* Add new patch number below this line */ | ||
161 | /**/ | ||
162 | + 1733, | ||
163 | +/**/ | ||
164 | 1689, | ||
165 | /**/ | ||
166 | 1688, | ||
167 | -- | ||
168 | 2.1.4 | ||
169 | |||
diff --git a/meta-oe/recipes-support/vim/vim-tiny_7.4.1689.bb b/meta-oe/recipes-support/vim/vim-tiny_8.0.0022.bb index bb8f2b7ea..bb8f2b7ea 100644 --- a/meta-oe/recipes-support/vim/vim-tiny_7.4.1689.bb +++ b/meta-oe/recipes-support/vim/vim-tiny_8.0.0022.bb | |||
diff --git a/meta-oe/recipes-support/vim/vim_7.4.1689.bb b/meta-oe/recipes-support/vim/vim_8.0.0022.bb index f94a49734..112ae80a2 100644 --- a/meta-oe/recipes-support/vim/vim_7.4.1689.bb +++ b/meta-oe/recipes-support/vim/vim_8.0.0022.bb | |||
@@ -4,14 +4,13 @@ DEPENDS = "ncurses gettext-native" | |||
4 | # vimdiff doesn't like busybox diff | 4 | # vimdiff doesn't like busybox diff |
5 | RSUGGESTS_${PN} = "diffutils" | 5 | RSUGGESTS_${PN} = "diffutils" |
6 | LICENSE = "vim" | 6 | LICENSE = "vim" |
7 | LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=c74ec0ada9a68354f9461e81d3596f61" | 7 | LIC_FILES_CHKSUM = "file://../runtime/doc/uganda.txt;md5=eea32ac1424bba14096736a494ae9045" |
8 | 8 | ||
9 | SRC_URI = "git://github.com/vim/vim.git \ | 9 | SRC_URI = "git://github.com/vim/vim.git \ |
10 | file://disable_acl_header_check.patch;patchdir=.. \ | 10 | file://disable_acl_header_check.patch;patchdir=.. \ |
11 | file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \ | 11 | file://vim-add-knob-whether-elf.h-are-checked.patch;patchdir=.. \ |
12 | file://0001-patch-7.4.1733.patch;patchdir=.. \ | ||
13 | " | 12 | " |
14 | SRCREV = "758535a1df4c5e86b45dddf12db2a54dea28ca40" | 13 | SRCREV = "ec68a99464055029c01082762517e97245ddae0c" |
15 | 14 | ||
16 | S = "${WORKDIR}/git/src" | 15 | S = "${WORKDIR}/git/src" |
17 | 16 | ||
@@ -98,6 +97,7 @@ FILES_${PN}-common = " \ | |||
98 | ${datadir}/${BPN}/${VIMDIR}/plugin \ | 97 | ${datadir}/${BPN}/${VIMDIR}/plugin \ |
99 | ${datadir}/${BPN}/${VIMDIR}/print \ | 98 | ${datadir}/${BPN}/${VIMDIR}/print \ |
100 | ${datadir}/${BPN}/${VIMDIR}/spell \ | 99 | ${datadir}/${BPN}/${VIMDIR}/spell \ |
100 | ${datadir}/icons \ | ||
101 | " | 101 | " |
102 | 102 | ||
103 | RDEPENDS_${PN} = "ncurses-terminfo-base" | 103 | RDEPENDS_${PN} = "ncurses-terminfo-base" |