summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-11-06 14:30:28 +0800
committerKhem Raj <raj.khem@gmail.com>2024-11-05 22:45:18 -0800
commit8edfb199e4b8a46d28aea6a4dd301cac936e535b (patch)
treee3114bfb2c88c9f5c8053eb7217922f05f5a8e64
parent426cacacea287359b219f1146ad72ec26692b791 (diff)
downloadmeta-openembedded-8edfb199e4b8a46d28aea6a4dd301cac936e535b.tar.gz
osinfo-db-tools: upgrade 1.11.0 -> 1.12.0
0001-Make-xmlError-structs-constant.patch removed since it's included in 1.12.0 Changelog: ========== - Fix some memory leaks - Fix runtime warnings on osinfo-db-export - Adapt to libxml2 changes - Several CI improvements - Several translation improvements Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-oe/recipes-support/libosinfo/osinfo-db-tools/0001-Make-xmlError-structs-constant.patch56
-rw-r--r--meta-oe/recipes-support/libosinfo/osinfo-db-tools_1.12.0.bb (renamed from meta-oe/recipes-support/libosinfo/osinfo-db-tools_1.11.0.bb)3
2 files changed, 1 insertions, 58 deletions
diff --git a/meta-oe/recipes-support/libosinfo/osinfo-db-tools/0001-Make-xmlError-structs-constant.patch b/meta-oe/recipes-support/libosinfo/osinfo-db-tools/0001-Make-xmlError-structs-constant.patch
deleted file mode 100644
index edff5732c..000000000
--- a/meta-oe/recipes-support/libosinfo/osinfo-db-tools/0001-Make-xmlError-structs-constant.patch
+++ /dev/null
@@ -1,56 +0,0 @@
1Upstream-Status: Backport [https://gitlab.com/libosinfo/osinfo-db-tools/-/commit/34378a4]
2
3Signed-off-by: Kai Kang <kai.kang@windriver.com>
4
5From 34378a4ac257f2f5fcf364786d1634a8c36b304f Mon Sep 17 00:00:00 2001
6From: Michal Privoznik <mprivozn@redhat.com>
7Date: Mon, 27 Nov 2023 15:04:43 +0100
8Subject: [PATCH] Make xmlError structs constant
9
10In libxml2 commits v2.12.0~14 and v2.12.0~77 the API changed so
11that:
12
131) xmlGetLastError() returns pointer to a constant xmlError
14 struct, and
15
162) xmlSetStructuredErrorFunc() changed the signature of callback
17 (validate_structured_error_nop()), it too is passed pointer to
18 a constant xmlError struct.
19
20But of course, older libxml2 expects different callback
21signature. Therefore, we need to typecast it anyway.
22
23Also, drop obviously incorrect @error annotation in
24validate_structured_error_nop; the variable is used.
25
26Signed-off-by: Michal Privoznik <mprivozn@redhat.com>
27---
28 tools/osinfo-db-validate.c | 5 +++--
29 1 file changed, 3 insertions(+), 2 deletions(-)
30
31diff --git a/tools/osinfo-db-validate.c b/tools/osinfo-db-validate.c
32index a721b4d..b1434a6 100644
33--- a/tools/osinfo-db-validate.c
34+++ b/tools/osinfo-db-validate.c
35@@ -35,7 +35,7 @@ static void validate_generic_error_nop(void *userData G_GNUC_UNUSED,
36 }
37
38 static void validate_structured_error_nop(void *userData G_GNUC_UNUSED,
39- xmlErrorPtr error G_GNUC_UNUSED)
40+ const xmlError *error)
41 {
42 if (error->file)
43 g_printerr("%s:%d %s", error->file, error->line, error->message);
44@@ -173,7 +173,8 @@ static gboolean validate_files(GFile *schema, gsize nfiles, GFile **files, GErro
45 g_autofree gchar *schemapath = NULL;
46
47 xmlSetGenericErrorFunc(NULL, validate_generic_error_nop);
48- xmlSetStructuredErrorFunc(NULL, validate_structured_error_nop);
49+ /* Drop this typecast when >=libxml2-2.12.0 is required */
50+ xmlSetStructuredErrorFunc(NULL, (xmlStructuredErrorFunc) validate_structured_error_nop);
51
52 schemapath = g_file_get_path(schema);
53 rngParser = xmlRelaxNGNewParserCtxt(schemapath);
54--
552.34.1
56
diff --git a/meta-oe/recipes-support/libosinfo/osinfo-db-tools_1.11.0.bb b/meta-oe/recipes-support/libosinfo/osinfo-db-tools_1.12.0.bb
index 0584bee15..4434a851e 100644
--- a/meta-oe/recipes-support/libosinfo/osinfo-db-tools_1.11.0.bb
+++ b/meta-oe/recipes-support/libosinfo/osinfo-db-tools_1.12.0.bb
@@ -7,9 +7,8 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
7DEPENDS = "glib-2.0 json-glib libarchive libsoup-2.4" 7DEPENDS = "glib-2.0 json-glib libarchive libsoup-2.4"
8 8
9SRC_URI = "git://gitlab.com/libosinfo/osinfo-db-tools.git;branch=main;protocol=https \ 9SRC_URI = "git://gitlab.com/libosinfo/osinfo-db-tools.git;branch=main;protocol=https \
10 file://0001-Make-xmlError-structs-constant.patch \
11 " 10 "
12SRCREV = "85a1788c6977419b6facad11dbfbf823e739eb3b" 11SRCREV = "e5564be303bfac49cc3490bd0fada342cd65566f"
13 12
14S = "${WORKDIR}/git" 13S = "${WORKDIR}/git"
15 14