summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-16 16:14:57 -0800
committerKhem Raj <raj.khem@gmail.com>2024-02-16 16:42:31 -0800
commit82561d6a3d48a34b7f58690eb1d313661f78f5fe (patch)
tree810a052115bb319d2d2ad3b189c3068f79872671
parentd114bafa718c7fe774ba687b907d73683d4678e9 (diff)
downloadmeta-openembedded-82561d6a3d48a34b7f58690eb1d313661f78f5fe.tar.gz
python3-tomlkit: switch to pytest --automake
* Also replace ${PYTHON_PN} with python3 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-tomlkit/run-ptest2
-rw-r--r--meta-python/recipes-devtools/python/python3-tomlkit_0.12.3.bb7
2 files changed, 5 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest b/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest
index b63c4de0d..8d2017d39 100644
--- a/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest
+++ b/meta-python/recipes-devtools/python/python3-tomlkit/run-ptest
@@ -1,3 +1,3 @@
1#!/bin/sh 1#!/bin/sh
2 2
3pytest -o log_cli=true -o log_cli_level=INFO | sed -e 's/\[...%\]//g'| sed -e 's/PASSED/PASS/g'| sed -e 's/FAILED/FAIL/g'|sed -e 's/SKIPPED/SKIP/g'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS"){printf "%s: %s\n", $NF, $0}else{print}}'| awk '{if ($NF=="PASS" || $NF=="FAIL" || $NF=="SKIP" || $NF=="XFAIL" || $NF=="XPASS") {$NF="";print $0}else{print}}' 3pytest --automake
diff --git a/meta-python/recipes-devtools/python/python3-tomlkit_0.12.3.bb b/meta-python/recipes-devtools/python/python3-tomlkit_0.12.3.bb
index 89acd7777..d4162a110 100644
--- a/meta-python/recipes-devtools/python/python3-tomlkit_0.12.3.bb
+++ b/meta-python/recipes-devtools/python/python3-tomlkit_0.12.3.bb
@@ -18,9 +18,10 @@ RDEPENDS:${PN} += " \
18" 18"
19 19
20RDEPENDS:${PN}-ptest += " \ 20RDEPENDS:${PN}-ptest += " \
21 ${PYTHON_PN}-poetry-core \ 21 python3-poetry-core \
22 ${PYTHON_PN}-pytest \ 22 python3-pytest \
23 ${PYTHON_PN}-pyyaml \ 23 python3-pyyaml \
24 python3-unittest-automake-output \
24" 25"
25 26
26do_install_ptest() { 27do_install_ptest() {