diff options
author | Armin Kuster <akuster808@gmail.com> | 2016-11-05 11:00:36 -0700 |
---|---|---|
committer | Joe MacDonald <joe_macdonald@mentor.com> | 2016-11-14 13:01:33 -0500 |
commit | 7f8915a6ecdd5c4b03c7e5b5f1fa903f89c2d560 (patch) | |
tree | 78a1692d5dbfceeafb321a639583f02e36d955f2 | |
parent | 294d7126ff5a6a079595a56513b789619de5944d (diff) | |
download | meta-openembedded-7f8915a6ecdd5c4b03c7e5b5f1fa903f89c2d560.tar.gz |
wireshark: install missing header files
Wireshark does not install header files. add install_append
Remove ALLOW_EMPTY & INHIBIT_PACKAGE_DEBUG_SPLIT, they are no longer needed
V2]
add missing libssh and sbc config
V3]
restore removed FILES append and fixed missing sbc in PACKAGECONFIG
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
-rw-r--r-- | meta-networking/recipes-support/wireshark/wireshark_2.2.1.bb | 31 |
1 files changed, 26 insertions, 5 deletions
diff --git a/meta-networking/recipes-support/wireshark/wireshark_2.2.1.bb b/meta-networking/recipes-support/wireshark/wireshark_2.2.1.bb index a5fb7f69b..a8f61fead 100644 --- a/meta-networking/recipes-support/wireshark/wireshark_2.2.1.bb +++ b/meta-networking/recipes-support/wireshark/wireshark_2.2.1.bb | |||
@@ -4,7 +4,7 @@ SECTION = "net" | |||
4 | LICENSE = "GPL-2.0" | 4 | LICENSE = "GPL-2.0" |
5 | LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0" | 5 | LIC_FILES_CHKSUM = "file://README.linux;md5=631e077455b7972172eb149195e065b0" |
6 | 6 | ||
7 | DEPENDS = "pcre expat glib-2.0 sbc" | 7 | DEPENDS = "pcre expat glib-2.0" |
8 | 8 | ||
9 | SRC_URI = "https://2.na.dl.wireshark.org/src/all-versions/${BP}.tar.bz2" | 9 | SRC_URI = "https://2.na.dl.wireshark.org/src/all-versions/${BP}.tar.bz2" |
10 | 10 | ||
@@ -16,8 +16,7 @@ inherit autotools pkgconfig perlnative | |||
16 | 16 | ||
17 | ARM_INSTRUCTION_SET = "arm" | 17 | ARM_INSTRUCTION_SET = "arm" |
18 | 18 | ||
19 | 19 | PACKAGECONFIG ?= "libpcap gnutls libnl libcap sbc" | |
20 | PACKAGECONFIG ?= "libpcap gnutls libnl libcap" | ||
21 | PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}" | 20 | PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "x11", "gtk2 graphics", "", d)}" |
22 | #PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}" | 21 | #PACKAGECONFIG += " ${@bb.utils.contains("DISTRO_FEATURES", "opengl", "gtk3", "", d)}" |
23 | 22 | ||
@@ -37,13 +36,35 @@ PACKAGECONFIG[lua] = "--with-lua=yes, --with-lua=no, lua" | |||
37 | PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib" | 36 | PACKAGECONFIG[zlib] = "--with-zlib=yes, --with-zlib=no, zlib" |
38 | PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip" | 37 | PACKAGECONFIG[geoip] = "--with-geoip=yes, --with-geoip=no, geoip" |
39 | PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no" | 38 | PACKAGECONFIG[plugins] = "--with-plugins=yes, --with-plugins=no" |
39 | PACKAGECONFIG[sbc] = "--with-sbc=yes, --with-sbc=no, sbc" | ||
40 | |||
41 | PACKAGECONFIG[libssh] = "--with-ssh=yes, --with-ssh=no, libssh2" | ||
42 | |||
40 | 43 | ||
41 | # these next two options require addional layers | 44 | # these next two options require addional layers |
42 | PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares" | 45 | PACKAGECONFIG[c-ares] = "--with-c-ares=yes, --with-c-ares=no, c-ares" |
43 | 46 | ||
44 | EXTRA_OECONF += "--with-qt=no --enable-tshark --enable-rawshark" | 47 | EXTRA_OECONF += "--with-qt=no --enable-tshark --enable-rawshark" |
45 | 48 | ||
46 | ALLOW_EMPTY_${PN} = "1" | 49 | # Currently wireshark does not install header files |
47 | INHIBIT_PACKAGE_DEBUG_SPLIT = "1" | 50 | do_install_append () { |
51 | |||
52 | install -d ${D}/${includedir}/${BPN} | ||
53 | install -d ${D}/${includedir}/${BPN}/epan | ||
54 | install -d ${D}/${includedir}/${BPN}/epan/crypt | ||
55 | install -d ${D}/${includedir}/${BPN}/epan/dfilter | ||
56 | install -d ${D}/${includedir}/${BPN}/epan/dissectors | ||
57 | install -d ${D}/${includedir}/${BPN}/epan/ftypes | ||
58 | install -d ${D}/${includedir}/${BPN}/epan/wmem | ||
59 | |||
60 | install config.h ${D}/${includedir}/${BPN} | ||
61 | install ${S}/register.h ${D}/${includedir}/${BPN} | ||
62 | install -D ${S}/epan/*.h ${D}/${includedir}/${BPN}/epan | ||
63 | install -D ${S}/epan/crypt/*.h ${D}/${includedir}/${BPN}/epan/crypt | ||
64 | install -D ${S}/epan/dfilter/*.h ${D}/${includedir}/${BPN}/epan/dfilter | ||
65 | install -D ${S}/epan/dissectors/*.h ${D}/${includedir}/${BPN}/epan/dissectors | ||
66 | install -D ${S}/epan/ftypes/*.h ${D}/${includedir}/${BPN}/epan/ftypes | ||
67 | install -D ${S}/epan/wmem/*.h ${D}/${includedir}/${BPN}/epan/wmem | ||
68 | } | ||
48 | 69 | ||
49 | FILES_${PN} += "${datadir}*" | 70 | FILES_${PN} += "${datadir}*" |