summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2022-02-25 10:55:51 -0800
committerKhem Raj <raj.khem@gmail.com>2022-02-28 08:32:19 -0800
commit7b0c8989bf6d53ac92da08e8662e30e1f3204b5e (patch)
tree96403909fcdb6224efbaf68d11ccf7c69059405f
parentd605093bc16d14ddffe9eb318f73c5ae9c7c534b (diff)
downloadmeta-openembedded-7b0c8989bf6d53ac92da08e8662e30e1f3204b5e.tar.gz
python3-pyruvate: fix wheel build
Like python3-setuptools-rust-native, the wheel is being built in ${S}/dist rather than ${B}/dist so set PIP_INSTALL_DIST_PATH accordingly. Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
-rw-r--r--meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb b/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb
index b83302d44..4429e4c32 100644
--- a/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb
+++ b/meta-python/recipes-devtools/python/python3-pyruvate_1.1.2.bb
@@ -14,6 +14,8 @@ S = "${WORKDIR}/pyruvate-${PV}"
14 14
15inherit pypi setuptools3_rust 15inherit pypi setuptools3_rust
16 16
17PIP_INSTALL_DIST_PATH = "${S}/dist"
18
17# crossbeam-* -> std::sync::atomic AtomicI64, AtomicU64 19# crossbeam-* -> std::sync::atomic AtomicI64, AtomicU64
18# not supported on mips/powerpc with 32-bit pointers 20# not supported on mips/powerpc with 32-bit pointers
19# https://doc.rust-lang.org/std/sync/atomic/#portability 21# https://doc.rust-lang.org/std/sync/atomic/#portability