diff options
author | Maxin John <maxin.john@intel.com> | 2018-02-28 17:29:29 +0200 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-03-16 19:14:24 -0700 |
commit | 7a6f6434e7f60cc3ae788beccac7e34b7abb2750 (patch) | |
tree | 452603d58a0efe62bb8711a488db10333a568041 | |
parent | 692fb97e2a22c02ba63717da61a0d6e232618cc5 (diff) | |
download | meta-openembedded-7a6f6434e7f60cc3ae788beccac7e34b7abb2750.tar.gz |
breakpad: remove unused patch
Remove the following unused patch:
0005-Import-necessary-definitions-from-stab.h.patch
Signed-off-by: Maxin B. John <maxin.john@intel.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
-rw-r--r-- | meta-oe/recipes-devtools/breakpad/breakpad/0005-Import-necessary-definitions-from-stab.h.patch | 199 |
1 files changed, 0 insertions, 199 deletions
diff --git a/meta-oe/recipes-devtools/breakpad/breakpad/0005-Import-necessary-definitions-from-stab.h.patch b/meta-oe/recipes-devtools/breakpad/breakpad/0005-Import-necessary-definitions-from-stab.h.patch deleted file mode 100644 index 80de8c684..000000000 --- a/meta-oe/recipes-devtools/breakpad/breakpad/0005-Import-necessary-definitions-from-stab.h.patch +++ /dev/null | |||
@@ -1,199 +0,0 @@ | |||
1 | From fa7a3b7312307acad0045549d5f306e7fd117804 Mon Sep 17 00:00:00 2001 | ||
2 | From: Felix Janda <felix.janda@posteo.de> | ||
3 | Date: Sun, 1 Feb 2015 14:34:44 +0100 | ||
4 | Subject: [PATCH 5/6] Import necessary definitions from stab.h | ||
5 | |||
6 | --- | ||
7 | configure.ac | 1 - | ||
8 | src/common/android/include/stab.h | 100 ------------------------------------ | ||
9 | src/common/common.gyp | 1 - | ||
10 | src/common/stabs_reader.cc | 1 - | ||
11 | src/common/stabs_reader.h | 13 +++-- | ||
12 | src/common/stabs_reader_unittest.cc | 1 - | ||
13 | 6 files changed, 10 insertions(+), 107 deletions(-) | ||
14 | delete mode 100644 src/common/android/include/stab.h | ||
15 | |||
16 | diff --git a/configure.ac b/configure.ac | ||
17 | index 2223920..0e55cd9 100644 | ||
18 | --- a/configure.ac | ||
19 | +++ b/configure.ac | ||
20 | @@ -73,7 +73,6 @@ AC_HEADER_STDC | ||
21 | AC_SYS_LARGEFILE | ||
22 | m4_include(m4/ax_pthread.m4) | ||
23 | AX_PTHREAD | ||
24 | -AC_CHECK_HEADERS([a.out.h]) | ||
25 | |||
26 | # Only build Linux client libs when compiling for Linux | ||
27 | case $host in | ||
28 | diff --git a/src/common/android/include/stab.h b/src/common/android/include/stab.h | ||
29 | deleted file mode 100644 | ||
30 | index cd92902..0000000 | ||
31 | --- a/src/common/android/include/stab.h | ||
32 | +++ /dev/null | ||
33 | @@ -1,100 +0,0 @@ | ||
34 | -// Copyright (c) 2012, Google Inc. | ||
35 | -// All rights reserved. | ||
36 | -// | ||
37 | -// Redistribution and use in source and binary forms, with or without | ||
38 | -// modification, are permitted provided that the following conditions are | ||
39 | -// met: | ||
40 | -// | ||
41 | -// * Redistributions of source code must retain the above copyright | ||
42 | -// notice, this list of conditions and the following disclaimer. | ||
43 | -// * Redistributions in binary form must reproduce the above | ||
44 | -// copyright notice, this list of conditions and the following disclaimer | ||
45 | -// in the documentation and/or other materials provided with the | ||
46 | -// distribution. | ||
47 | -// * Neither the name of Google Inc. nor the names of its | ||
48 | -// contributors may be used to endorse or promote products derived from | ||
49 | -// this software without specific prior written permission. | ||
50 | -// | ||
51 | -// THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS | ||
52 | -// "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT | ||
53 | -// LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR | ||
54 | -// A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT | ||
55 | -// OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, | ||
56 | -// SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT | ||
57 | -// LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, | ||
58 | -// DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY | ||
59 | -// THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT | ||
60 | -// (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE | ||
61 | -// OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE. | ||
62 | - | ||
63 | -#ifndef GOOGLE_BREAKPAD_COMMON_ANDROID_INCLUDE_STAB_H | ||
64 | -#define GOOGLE_BREAKPAD_COMMON_ANDROID_INCLUDE_STAB_H | ||
65 | - | ||
66 | -#include <sys/cdefs.h> | ||
67 | - | ||
68 | -#ifdef __BIONIC_HAVE_STAB_H | ||
69 | -#include <stab.h> | ||
70 | -#else | ||
71 | - | ||
72 | -#ifdef __cplusplus | ||
73 | -extern "C" { | ||
74 | -#endif // __cplusplus | ||
75 | - | ||
76 | -#define _STAB_CODE_LIST \ | ||
77 | - _STAB_CODE_DEF(UNDF,0x00) \ | ||
78 | - _STAB_CODE_DEF(GSYM,0x20) \ | ||
79 | - _STAB_CODE_DEF(FNAME,0x22) \ | ||
80 | - _STAB_CODE_DEF(FUN,0x24) \ | ||
81 | - _STAB_CODE_DEF(STSYM,0x26) \ | ||
82 | - _STAB_CODE_DEF(LCSYM,0x28) \ | ||
83 | - _STAB_CODE_DEF(MAIN,0x2a) \ | ||
84 | - _STAB_CODE_DEF(PC,0x30) \ | ||
85 | - _STAB_CODE_DEF(NSYMS,0x32) \ | ||
86 | - _STAB_CODE_DEF(NOMAP,0x34) \ | ||
87 | - _STAB_CODE_DEF(OBJ,0x38) \ | ||
88 | - _STAB_CODE_DEF(OPT,0x3c) \ | ||
89 | - _STAB_CODE_DEF(RSYM,0x40) \ | ||
90 | - _STAB_CODE_DEF(M2C,0x42) \ | ||
91 | - _STAB_CODE_DEF(SLINE,0x44) \ | ||
92 | - _STAB_CODE_DEF(DSLINE,0x46) \ | ||
93 | - _STAB_CODE_DEF(BSLINE,0x48) \ | ||
94 | - _STAB_CODE_DEF(BROWS,0x48) \ | ||
95 | - _STAB_CODE_DEF(DEFD,0x4a) \ | ||
96 | - _STAB_CODE_DEF(EHDECL,0x50) \ | ||
97 | - _STAB_CODE_DEF(MOD2,0x50) \ | ||
98 | - _STAB_CODE_DEF(CATCH,0x54) \ | ||
99 | - _STAB_CODE_DEF(SSYM,0x60) \ | ||
100 | - _STAB_CODE_DEF(SO,0x64) \ | ||
101 | - _STAB_CODE_DEF(LSYM,0x80) \ | ||
102 | - _STAB_CODE_DEF(BINCL,0x82) \ | ||
103 | - _STAB_CODE_DEF(SOL,0x84) \ | ||
104 | - _STAB_CODE_DEF(PSYM,0xa0) \ | ||
105 | - _STAB_CODE_DEF(EINCL,0xa2) \ | ||
106 | - _STAB_CODE_DEF(ENTRY,0xa4) \ | ||
107 | - _STAB_CODE_DEF(LBRAC,0xc0) \ | ||
108 | - _STAB_CODE_DEF(EXCL,0xc2) \ | ||
109 | - _STAB_CODE_DEF(SCOPE,0xc4) \ | ||
110 | - _STAB_CODE_DEF(RBRAC,0xe0) \ | ||
111 | - _STAB_CODE_DEF(BCOMM,0xe2) \ | ||
112 | - _STAB_CODE_DEF(ECOMM,0xe4) \ | ||
113 | - _STAB_CODE_DEF(ECOML,0xe8) \ | ||
114 | - _STAB_CODE_DEF(NBTEXT,0xf0) \ | ||
115 | - _STAB_CODE_DEF(NBDATA,0xf2) \ | ||
116 | - _STAB_CODE_DEF(NBBSS,0xf4) \ | ||
117 | - _STAB_CODE_DEF(NBSTS,0xf6) \ | ||
118 | - _STAB_CODE_DEF(NBLCS,0xf8) \ | ||
119 | - _STAB_CODE_DEF(LENG,0xfe) | ||
120 | - | ||
121 | -enum __stab_debug_code { | ||
122 | -#define _STAB_CODE_DEF(x,y) N_##x = y, | ||
123 | -_STAB_CODE_LIST | ||
124 | -#undef _STAB_CODE_DEF | ||
125 | -}; | ||
126 | - | ||
127 | -#ifdef __cplusplus | ||
128 | -} // extern "C" | ||
129 | -#endif // __cplusplus | ||
130 | - | ||
131 | -#endif // __BIONIC_HAVE_STAB_H | ||
132 | - | ||
133 | -#endif // GOOGLE_BREAKPAD_COMMON_ANDROID_INCLUDE_STAB_H | ||
134 | diff --git a/src/common/common.gyp b/src/common/common.gyp | ||
135 | index f01ede5..c49ff85 100644 | ||
136 | --- a/src/common/common.gyp | ||
137 | +++ b/src/common/common.gyp | ||
138 | @@ -46,7 +46,6 @@ | ||
139 | 'android/include/elf.h', | ||
140 | 'android/include/link.h', | ||
141 | 'android/include/sgidefs.h', | ||
142 | - 'android/include/stab.h', | ||
143 | 'android/include/sys/procfs.h', | ||
144 | 'android/include/sys/signal.h', | ||
145 | 'android/include/sys/user.h', | ||
146 | diff --git a/src/common/stabs_reader.cc b/src/common/stabs_reader.cc | ||
147 | index 6019fc7..9562caa 100644 | ||
148 | --- a/src/common/stabs_reader.cc | ||
149 | +++ b/src/common/stabs_reader.cc | ||
150 | @@ -34,7 +34,6 @@ | ||
151 | #include "common/stabs_reader.h" | ||
152 | |||
153 | #include <assert.h> | ||
154 | -#include <stab.h> | ||
155 | #include <string.h> | ||
156 | |||
157 | #include <string> | ||
158 | diff --git a/src/common/stabs_reader.h b/src/common/stabs_reader.h | ||
159 | index d89afc0..591f007 100644 | ||
160 | --- a/src/common/stabs_reader.h | ||
161 | +++ b/src/common/stabs_reader.h | ||
162 | @@ -53,12 +53,19 @@ | ||
163 | #include <config.h> | ||
164 | #endif | ||
165 | |||
166 | -#ifdef HAVE_A_OUT_H | ||
167 | -#include <a.out.h> | ||
168 | -#endif | ||
169 | #ifdef HAVE_MACH_O_NLIST_H | ||
170 | #include <mach-o/nlist.h> | ||
171 | #endif | ||
172 | +// Definitions from <stab.h> and <a.out.h> for systems which | ||
173 | +// do not have them | ||
174 | +#undef N_UNDF | ||
175 | +#define N_UNDF 0x0 | ||
176 | +#define N_FUN 0x24 | ||
177 | +#define N_SLINE 0x44 | ||
178 | +#define N_SO 0x64 | ||
179 | +#define N_LSYM 0x80 | ||
180 | +#define N_BINCL 0x82 | ||
181 | +#define N_SOL 0x84 | ||
182 | |||
183 | #include <string> | ||
184 | #include <vector> | ||
185 | diff --git a/src/common/stabs_reader_unittest.cc b/src/common/stabs_reader_unittest.cc | ||
186 | index a84da1c..854ac42 100644 | ||
187 | --- a/src/common/stabs_reader_unittest.cc | ||
188 | +++ b/src/common/stabs_reader_unittest.cc | ||
189 | @@ -33,7 +33,6 @@ | ||
190 | |||
191 | #include <assert.h> | ||
192 | #include <errno.h> | ||
193 | -#include <stab.h> | ||
194 | #include <stdarg.h> | ||
195 | #include <stdlib.h> | ||
196 | #include <string.h> | ||
197 | -- | ||
198 | 2.0.5 | ||
199 | |||